Widevine problems


#1

Hi!
As described in the raspberry section i’m having some trouble with widevine…

things i did:
installed SkyGo Addon from Kodi Ners repository
-> problem with arch

modified ~/.kodi/addons/script.module.inputstreamhelper/lib/inputstreamhelper.py as suggested by eminga in the other threads first post
-> “Widevine CDM is required…” pop up appeared when i tried to open a stream from SkyGo Addon

followed the popups suggestions and installed Widevine downloading a chrome os recovery image (just pressed “ok” a few times)
-> streams still don’t play, i get this error

22:10:19.232 T:3864920832 ERROR: AddOnLog: InputStream Adaptive: Unable to load widevine shared library (/home/osmc/.kodi/cdm/libwidevinecdm.so)
22:10:19.232 T:3864920832 ERROR: AddOnLog: InputStream Adaptive: OpenDRMSystem failed"

/home/osmc/.kodi/cdm/libwidevinecdm.so exists, but don’t ask me if it’s the right lib?

what could have gone wrong - and what can i do to get it right!?

cheers :confused:


Wrong Architecture with Amazon VOD
Wrong Architecture with Amazon VOD
#2

I think u miss the link pointing to /usr/lib/kodi/addons/inputstream.adaptive/libssd_wv.so in the cdm directory, pls check that. And u have to create a dir widevine too.


#3

could you go more into detail?
i’m absolutely not linux proof…
what should point where and how can i do this?
where should i create a widevine dir?


#4

enter this into your commandline

ln -fs /usr/lib/kodi/addons/inputstream.adaptive/libssd_wv.so /home/osmc/.kodi/cdm/libssd_wv.so

#5

Are you on Leia? (Sorry for asking)

  • Delete the content of the folder “home/osmc/.kodi/cdm”
  • put the new Inputstreamhelper.py into “home/osmc/.kodi/addons/script.modul. inputstreamhelper”
  • delete Amazon-Add-on
  • reboot Vero
  • install Amazon Add-on (take a look if inputstream 0.24 is installed)
  • “Widevine is required…” -> libwidevine will be installed

Now you can find in “home/osmc/.kodi/cdm” a link to libwidevinecdm.so (size: 1KB). In “home/osmc/.kodi/userdata/addon_data/script.module.inputstreamhelper/cdm” you will find the file libwidevinecdm.so with the size of 7.267 KB.

  • reboot

Settings for InputstreamAdaptive:

  • Max. Resolution general decoder: 720p
  • Max. Resolution secure decoder: 720p
  • Override HDCP status: unchecked
  • Ignore Display Resolution: unchecked

Settings for AmazonVOD

  • DRM Check aktivieren: unchecked
  • Ungültige Tonspur…: checked

Enjoy Amazon, Netflix and Skygo

(sorry, but I’m not able to upload a file)


Kodi 18 and netflix
#6

ok - problem still the same.

no, kodi 17.6

as i didn’t know which “new” inpustreamhelper.py i should put there i didn’t folow these step.
the link in home/osmc/.kodi/cdm was already there, so was the file libwidevinecdm.so with a size of exactly 7.267 kb

but i still have the same error :frowning:
https://pastebin.com/6QLkncDy


#7

first of all, u have to install leia.

doesn’t work with 17.6


#8

huh, that was easy! working again! :hugs:
sometimes it’s just too easy… sorry for this useless thread :confused:


#9

Hi,
I’m using Leia and now my inputstreamhelper vanished from my Vero. The last days I always got the error that no Widevine CDM is available for my system.


#10

Widevine is not shipped with OSMC anymore. This explains it: https://github.com/osmc/osmc/issues/42013

@samnazarko I would actually advise you to not include libwidevinecdm as part of OSMC because redistribution of the binary breaks the EULA.

"Google Inc. and its affiliates ("Google") own all legal right, title and
interest in and to the content decryption module software ("Software") and
related documentation, including any intellectual property rights in the
Software. You may not use, modify, sell, or otherwise distribute the Software
without a separate license agreement with Google.  The Software is not open
source software.

If you are interested in licensing the Software, please contact
widevine@google.com.

#11

This may help: Can I use Netflix on my Raspy OSMC?

But not sure, if it’s just working with RPi… Check with others or wait for feedback here.


#12

I already tried it, but the error in Amazon VOD remains (too old version?).


#13

yes, update amazon vod, then u will be prompted for action.


#14

0.4.8, should be the newest one. But widevine is old


#15

After doing all the steps above (post 5) it’s working now, but sometimes I can’t see my watchlist (have to try several times) and all streams are 960x540 pixels. Have to investigate further. Thanks


#16

Release 3.2 of Inputstreamhelper.


#17

i was on Leia for a week or so but yesterday i had to switch back to stable :confused: (too many problems for daily use)

there’s no way to make “this” work with 17.6 ?


#18

Unfortunately no.


#19

after watching skygo on PC for some time now i’m using two devices on my tv: vero 4k for video files / livetv and my old libreelec device (leia alpha) for skygo…

“waf” is dropping and i can’t blame her :frowning:
i’m aware that it’s not osmc’s fault but it sucks anyway :confused:


#20

Why not just install Leia on the Vero 4K?