Web Server Failed to Start

#44

Run ls -l /var/cache/apt/archives/atv-device-osmc* on each device to see if you have a package file still on the drive. It’ll be called something like atv-device-osmc_1.1.3_i386.deb (but could be slightly different).

You might need to copy it over, then to install it run sudo dpkg -i <filename>

0 Likes

#45

Nope, didn’t turn up on the other 3. No such file or directory

0 Likes

#46

Perhaps @sam_nazarko can find a copy of atv-device-osmc 1.1.3 down the back of the sofa or advise what will be the consequences of trying to install version 1.1.7 on your system.

0 Likes

#47

OK, thanks for the info and the assistance, I’ll keep an eye out here for any other responses…

0 Likes

#48

1.1.7 will be fine

1 Like

#49

So, I just need to run this?

sudo apt-get -f install

0 Likes

#50

Hi,

I would try:

sudo apt-get install atv-device-osmc=1.1.7

Thanks Tom.

0 Likes

#51

Well… sudo apt-get install atv-device-osmc=1.1.7 didn’t work. So, I ran sudo apt-get -f install as the OS suggested. I rebooted. Then, I had to run…

sudo systemctl stop lighttpd and
sudo systemctl disable lighttpd

…again, because it was apparently triggered by the install?

Anything I can do to completely get rid of Pi-hole / lighttpd ??

0 Likes

#52

Hi,

sudo apt-get remove lighttpd

If you’re still having issues:

sudo apt-get purge lighttpd

Thanks Tom.

1 Like

#53

OK, everything seems to be good to go now. The missing package is restored, lighttpd is g-o-n-e and, the webserver has started and is up and running.

Thank you all very much for your assistance and patience with me!

1 Like