Web Server Failed to Start

#22

Here ya go:

http://paste.osmc.io/oduqajapur

0 Likes

#23

Hi,

Not sure whats going on here, you could try stopping kodi and changing:

<webserver default="true">true</webserver>

to <webserver default="true">false</webserver>

This should disable to webinterface, restart kodi and see if this sticks (check the log or upload)

Then with kodi stopped try setting:

<webserver default="true">true</webserver>
<webserverport>8080</webserverport>

Then start kodi again.

Thanks Tom.

0 Likes

#24

It doesn’t stick. As soon as I run the command to start mediacenter, within a few seconds, guisettings.xml reverts back to a file size of 28,850.

0 Likes

#25

Hi,

It looks like kodi believes something is invalid in guisettings.xml, when the change is made. So stop kodi, change the port to 8080 and without restarting kodi, please provide the link from this command again:

cat ~/.kodi/userdata/guisettings.xml | paste-log

Thanks Tom.

0 Likes

#26

OK, here’s the link, 8080 is showing right now. I edited using nano (looking at FTP I could see the file size increase to 28,852 from 28850:

http://paste.osmc.io/ijineruvin

I waited about an hour and as soon as I started mediacenter again, it overwrote the guisettings.xml file. Looks like I have stumped everyone… just my luck.

0 Likes

#29

Hi,

Sorry for the delay I was at work, I think you need to change another flag as well the port 8080 Change:

<webskin>webinterface.arch</webskin>

To:

<webskin default="true">webinterface.default</webskin>

Thanks Tom.

0 Likes

#30

OK, I changed the webskin yesterday using the ATV remote and the Kodi interface, just to see if a skin change would “kick” the webserver into working. I just never set it back to the default. I’ll go try to do that now.

0 Likes

#31

Does it matter if I edit the xml file with Ultraedit & FTP or should I edit via nano in SSH? Does it matter?

0 Likes

#32

Well, different result… The guisettings.xml file changed once I started mediacenter again. But! It did not change the webinterface.default that I edited. It only set the port back from 8080 to 80. So it isn’t overwriting the xml file, it is updating it. Is there another port besides 8080 I could try?

0 Likes

#33

Have to go away for a meeting, if anyone has any other ideas, post’em here and I’ll try them when i get back. Should be less than an hour away, thanks!

0 Likes

#34

Hi,

Long shot here, I’ve just noticed you are running kodi 15.2, where I think the default used to be 8080; so you could try this flag:

<webserverport default="true">8080</webserverport>

Thanks Tom.

0 Likes

#35

Why not try changing the pi-hole web interface port?

0 Likes

#36

If there are remnants of Pi-hole left, I’d be more than happy to completely remove them. I tried to uninstall, it doesn’t appear that it cleared itself out completely.

0 Likes

#37

Hi,

I would try:

sudo systemctl stop lighttpd
sudo systemctl disable lighttpd

Thanks Tom.

@ActionA cheers I’d missed that bit from the first post.

0 Likes

#38

OK, I tried stopping/disabling lighttpd, below’s what I got, is that good?

osmc@AT40:~$ sudo systemctl stop lighttpd osmc@AT40:~$ sudo systemctl disable lighttpd Synchronizing state for lighttpd.service with sysvinit using update-rc.d... Executing /usr/sbin/update-rc.d lighttpd defaults Executing /usr/sbin/update-rc.d lighttpd disable insserv: warning: current start runlevel(s) (empty) of scriptlighttpd’ overrides LSB defaults (2 3 4 5).
insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script lighttpd' overrides LSB defaults (0 1 6).

0 Likes

#39

SUCCESS! I now have visibility of the webserver through my web browser. It was Pi-hole that was still causing my issue. Thank you all so very much for your assistance and patience with me. Good final calls by ActionA and Tom. So relieved! :grin:

3 Likes

#40

I see you tried to remove an OSMC package, atv-device-osmc, that should not have been removed. Reinstalling it might work but we can’t know until you try. Please try this:

sudo apt-get install --reinstall atv-device-osmc=1.1.3

(The only version now available on the OSMC repository is 1.1.7, so I’m hoping you still have a copy of 1.1.3 cached on your local drive.)

If that succeeds, then run:

sudo apt-get -f install
0 Likes

#41

I didn’t knowingly try to remove it. What does this package do and what will it hurt to not have it? Because everything is seemingly working as it should now… At least from what I can tell until I get home and can view the Kodi interface on my TV…

0 Likes

#42

It was a result of this:

Start-Date: 2018-05-15  14:07:57
Commandline: apt-get -y remove --purge apt-utils

This caused the following, because of a dependency:

Log started: 2018-05-15  14:07:57
Removing atv-device-osmc (1.1.3) ...
WARNING: You have tried to remove a package that is essential to OSMC's operation.
To undo these changes, run 'sudo apt-get -f install'.
dpkg: error processing package atv-device-osmc (--purge):
 subprocess installed pre-removal script returned error exit status 1
dpkg: apt-utils: dependency problems, but removing anyway as you requested:
 atv-device-osmc depends on apt-utils.

So to answer your question, the package is essential to OSMC’s operation.

0 Likes

#43

OK, looks like it failed:

osmc@AT40:~$ sudo apt-get install --reinstall atv-device-osmc=1.1.3 Reading package lists... Done Building dependency tree Reading state information... Done Reinstallation of atv-device-osmc is not possible, it cannot be downloaded. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: atv-device-osmc : Depends: apt-utils but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I have 3 other ATVs on my network running the same version of OSMC as this box, could I grab it off of one of those boxes?

0 Likes