Want to verify if Vero 4k Box is right for me


#23

Most likely, yes.

Your logs aren’t debug logs so unfortunately I can’t discern much from them.

Sam


#24

hmmm ok, here once again a log:

https://paste.osmc.tv/wakosihanu

BR


#25
23:22:50.925 T:3555718128   DEBUG: CAMLCodec::Decode: write_av_packet looping
23:22:50.929 T:4113895424   DEBUG: CRenderManager::PrepareNextRender m_QueueSkip:5 iter.pts:57002.077 front.pts:57002.057 renderPts:57002.159  latency:0.080
23:22:50.929 T:4113895424   DEBUG: CRenderManager::PrepareNextRender m_QueueSkip:5 iter.pts:57002.097 front.pts:57002.057 renderPts:57002.159  latency:0.080
23:22:50.949 T:4113895424   DEBUG: CRenderManager::PrepareNextRender m_QueueSkip:7 iter.pts:57002.137 front.pts:57002.117 renderPts:57002.179  latency:0.080
23:22:50.970 T:3555718128   DEBUG: CPullupCorrection: detected pattern of length 1: 20000.00, frameduration: 20000.000000
23:22:51.645 T:3555718128   DEBUG: write codec data failed, write_bytes(-1), errno(11), size(926)
23:22:51.665 T:3555718128   DEBUG: usleep(RW_WAIT_TIME), len(0)
23:22:51.665 T:3555718128   DEBUG: CAMLCodec::Decode: write_av_packet looping

Looks throughput related.


#26

Network or something else? Can you be more specific?

:slight_smile: Thx

Edit: Just installed http://download.osmc.tv/installers/diskimages/OSMC_TGT_vero3_20180103.img.gz

no change. Still stuttering playback.


#27

Network related by the looks of it.
I’ll do some testing with TVHeadend tomorrow to make sure there haven’t been any regressions

I will also see if I can set up DVBViewer

Sam


#28

Hi Sam,

just installed the debian stretch version on the raspi3 http://download.osmc.tv/installers/diskimages/OSMC_TGT_rbp2_20180103.img.gz.

It works absolutely perfect on the raspi3 with Live-TV DVBViewer.

Here the Logfile of the raspi3: https://paste.osmc.tv/ayicohehef

Shortly after that I attached the vero4k with the debian stretch version to the same HDMI and Network Cable and tuned the same channel. Again…stuttering.
Here the logfile of the vero4k: https://paste.osmc.tv/femubewayu

Bit frustrated now :-/

BR
Sascha


#29

Hi how long after the order is placed do they take to arrive i ordered last week Thursday…
UK mainland.


#30

Thanks for the logs. It might be an issue with this addon, if recordings are working as expected.

I will look in to this shortly

Sam


HDTV 720p50 playback problems (stuttering) with DVBViewer setup
#31

You would have received an email with tracking when this was dispatched. It should arrive today if you ordered it before 3PM on Thursday.


#32

Hi Sam,

I thank you for your always quick response.

But the addon is working correct on the raspberry. So you think it has something to do especially with the addon on the vero?

…and yes, recordings work fine on the vero.

BR


#33

The addons would be compiled from the same source.
I don’t really know what the issue is yet. If the Vero 4K can play the recordings OK then the problem isn’t with the hardware acceleration.

First thing we need to do early next week is bump the add-on version anyway.

Sam


#34

I’m currently setting up a tvheadend server to also check how that is running. Will post logs once it is live.

BR
Sascha


#35

TVheadend is up and running.

Live-TV is smooth now.

So it does look like the currently implemented DVBViewer Plugin is the problem.

Here the logfile with TVheadend running:

https://paste.osmc.tv/egevifegug

When will the updated dvbviewer plugin be available for osmc?

Thx, BR and good night :slight_smile:


#36

Glad to hear things are now improved.

As promised, testing can be available as early as next week if you’re willing to test.

Sam


#37

Great, yes please…would like to stick to dcbviewer on Windows because of multiple reasons.

BR


#38

I’ll update this thread when we have something to test

Sam


#39

I have also an problem with the hdtv (720p50) playback in combination with DVBViewer (See HDTV 720p50 playback problems (stuttering))

Yesterday I compiled the newest pvr.dvbviewer release 2.4.14 with the WoL functionality but the stuttering is still present :frowning:.

2 Days before I installed TvHeadend on Kubuntu 16.04.3 LTS and recognized also problems with the HDTV playback on Vero4K with the TvHeadend PVR client.


#40

well…that does not sound promising.

I’ll wait until the official update from Sam and then see if I have to return the box :frowning: Hope not, because the rest runs good. But Live-TV is my main use.

BR


#41

I test it without hardware acceleration as fzinken recommended in my thread and this works :hushed:. Very fast channel loading and the video plays without stuttering.
But I don’t want to switch constanly between hardware acceleration on/off.


#42

Hi,

I also just tested it without HW acceleration. It does change the situation.

Sam, just FYI what is broadcasted in german television.

We have:
-SD Channel in 576i in MPEG2
-HD Channel in 720p in h264
-HD Channel in 1080i in h264

Situation with HW acceleration:
-SD Channel in 576i in MPEG2 -> no stuttering
-HD Channel in 720p in h264 -> stuttering
-HD Channel in 1080i in h264 -> stuttering

Situation without HW acceleration:
-SD Channel in 576i in MPEG2 -> no stuttering
-HD Channel in 720p in h264 -> no stuttering
-HD Channel in 1080i in h264 -> stuttering (probably due to high cpu load in software rendering)

So hw acceleration for mpeg2 with dvbviewer looks fine, but not for h264.

Hope this helps.

I also want to stick to dvbviewer like Sebi because of timeshift, simple config, other windows dvbviewer clients, etc… So I hope you can fix it.

BR
Sascha


HDTV 720p50 playback problems (stuttering) with DVBViewer setup