Wake on Lan issue at Standby


Hiho Folks. I am new to OSMC. Since now i used Libreelec on multiple Raspberry Pi2+3 combined with a MySQL Server on a Windows 7 based 18TB Fileserver. I started upgrading to 4k Content and with this i purchased a Vero 4k. Setting it up was not really a Problem and everything works fine. With the February Update i saw the Support of the Standby Mode. My File Server drains a lot of power, so i configured it to hibernate after 45 Minutes of inactivity. The Problem i have is that the Vero seems to send constantly Magic Paket’s, even when it is in Standby Mode. So it is waking up my Server all the time. If i shut down the Vero my Server keeps asleep. Any Idea how i can prevent that?


Vero 4K will still run service add-ons when in standby mode. It may be possible (and make sense) for us to disable some add-ons when this standby mode is active.

What is the name of the WOL add-on you are using?



I do not use an add-on. I am using the build in WOL feature of Kodi.


I believe that this only sends WOL packets when files are accessed.


i know that behaviour from my Raspberry Pi’s. When i do not turn them off they also keep waking up my Server.
Just checked the Kodi Wiki and saw, that there is a timeout parameter and a limitation that the WOL Feature can come “out of sync” if server stays on shorter time than specified in parameter ‘timeout’ before it suspends. Maybe that is the Problem. Perhaps i should try an WOL Add-on. Will test it and report later


Keep us posted.


hmm, Problem. I only found one Addon called “Advanced Wake on Lan” but i cannot use it. I have a MySQL Library which is located on my Server and the Addon will run first after Kodi did a complete start up, and this is not going to happen when the Server is still asleep and Kodi cannot access the Library :slight_smile: .
I now googled half an hour to find another WOL Addon but found nothing. Any suggestions?

For now i will try to change the parameters i found in the WOL Kodi Wiki, especially the timeout parameter and the pingport. If this is not going to work i will have to do it like i always did, shut down the Vero and reconnect power to start it up.


So, little Update. I tried different Settings but nothing really seems to work. 2-3 Minutes after my Server has gone to sleep it wakes up as long as my Vero is in Standby. Same picture if i try it with one of my Raspberry when not turning them off, no matter if i use Libreelec or OSMC.
Would it be possible to implement WOL funtionality directly in OSMC? Obviously the Kodi Solution has Problems. Best Solution would be that OSMC is sending continously Magic Pakets as long is the Vero is not in Standby or stops with it when there is no User Interaction for some time, so the Raspberry Version would also benefit from this and it would be an advantage in using OSMC instead of Libreelec.
For now i will keep on turning the Vero off. Luckily i have a remote controlled Power Plug :slight_smile:



I’ve made some changes so that Kodi will not sent Wake on LAN packets when Vero 4K is in standby mode.

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.



So, first Test looks good, Server is still hinbernating 30 minutes after shutdown. For your information, i deleted my wakeonlan.xml and let Kodi create a new one to be sure it works with default Settings. Now i will change some settings for a better matching with my environment (especially the waitonline parameter). I will report later if these changes influence the behaviour in any way.
Thanks a Lot :slight_smile:


Great. Can you also test that WOL still works?


Sorry, i forgot to mention. WOL still works, no matter if the Vero was turned of or in Standby. When turning on from Standby Kodi is waking up the Server at the latest when i first access the Library.

I am very happy that i bought a Vero, not only because it is a great piece of Hardware, the Support here is outstanding.
I will have to test another few things here at home and when everything works i think i need 2 more Vero 4K :smiley:


That’s what I need too.

I have the same issue with my TV server. I will test the fix this evening.


I did a short test and it seems to work :slight_smile:


Thanks for confirming.