VNC on Vero 2


#21

yes i ran “make” in the version for vero3 like suggested above: it was able to compile with the following warning

make
cc -Wall -std=c11 -mfpu=neon -o aml-vnc bgra2rgb565_neon.S framebuffer.c newinput.c vncserver.c -lvncserver -lpng -ljpeg -lpthread -lssl -lcrypto -lz -lresolv
framebuffer.c: In function ‘roundUpToPageSize’:
framebuffer.c:50:15: warning: implicit declaration of function ‘getpagesize’ [-Wimplicit-function-declaration]
return (x + (getpagesize()-1)) & ~(getpagesize()-1);
^~~~~~~~~~~

when i try to run, it seems to freeze.


#23

Did you do make clean before running make again?


#24

ok, that solved the issue. thx a lot!
cheers,
bendsch


#25

This is still not working properly. i can login and see a picture but navigation is painfully slow. on my old raspberry2 i get a much better performance with vnc … also, on vero vnc seems to freeze after a certain time and i can not even stop the process with “sudo killall aml-vnc”.

any idea why it behaves like this?

cheers
bendsch


#26

Not sure – it’s a bit hacky and put together quickly as we haven’t had a lot of demand for VNC.

I’ll try and revisit it in the near future.


#27

ok, cool!


#28

any news on this?


#29

Not really – there hasn’t been enough demand for this to warrant us looking in to improving VNC functionality further at this time.