Vero1, OSMC 2017.03-1 update, black screen instead of progress bar

#21

My Vero 1 does the same thing as @JimKnopf Screen goes completely black after clicking reset now. Was only after reading this i realised i just need to wait, and it came on after a few minutes.

0 Likes

#22

Has anything been done to try and fix this? I still get an old framebuffer showing during upgrade when updating to the september 2017 version.

0 Likes

#23

I thought this one was fixed.

Does the issue only occur after playback? I.e if you update without watching anything, is it OK?

Sam

0 Likes

#24

I honestly don’t know. The device is always on so during the course of one month something is bound to have been played.

Should I try to reboot the device before doing the next upgrade?

0 Likes

#25

Yes – that would be very helpful.
I’ll take a look at the windowing code for changes. It’s likely setting an ioctl on the framebuffer and not restoring the framebuffer properly when Kodi is exiting.

1 Like

#26

Ok, will do and report back after the next update

0 Likes

#27

Got the second september update, so I rebooted the vero and applied the update manually from the gui afterwards.

The screen went black during the whole update process, no progress bar or anything.

@sam_nazarko

0 Likes

#28

OK – I suspect the issue lies in the EGL init code then.

Sam

0 Likes

#29

Updates the thread - the December 2017 update came today, and as usual a totally black screen during the initial update. After the reboot when the main update takes place, the GUI worked., but it showed a little garbage before the actual progress bar was going.

After the reboot the box seems dead - no image on the TV and no IP-address claimed.

0 Likes

#30

You might need to reinstall if you can’t connect to the device at all

0 Likes

#31

Looks like i am having the same issue, performed a fresh install (using October release) things worked then performed the upgrade again. Then a blank screen.

It could be a coincidence, but this is also running on a Sony TV using the Verio v1

Unable to get logs of the unit and tried a fresh install of the latest release and find that the TV screen never shows anything.

0 Likes

#32

Tried a fresh install on another card, and it seemed to work, but the RF-remote stops working almost immediately, and also yatse stops connecting to it. It also looses the websocket connection trying to access the web gui from a browser.

Did a grab-logs -A, but have not enabled logging yet so I guess it wont say much.

https://paste.osmc.tv/ofadoyeced

0 Likes

#33

I don’t know it the hardware has given up or there are some subtle bugs - i consistently loose the websocket connection when using a browser - that does not happen on the vero 2 or 4k or my rasperry pi 3 all with December 2017 software on the same network.

It’s ok to ssh to it and the supplied IR-remote seem to work.

0 Likes

#34

Which RF remote are you using?
Debug logging is ideal to see what’s going on

Sam

0 Likes

#35

The RF remote looks like this:

I enabled debug log and paired the remote and pressed a few buttons:

https://paste.osmc.tv/gikacihabo

The pairing seemed to work, but the remote doesn’t.

Here are logs after a reboot and a new RF pairing when the remote worked a few presses, but stopped responding

https://paste.osmc.tv/tikajamemi

The IR remote continues to work.

0 Likes

[SOLVED] OSMC RF remote stops responding after a few minutes
#36

TBH, I see it all the time - and have done so for a long time on my Pi 4 and Vero4K. In my case, the connection is quickly restored. I always put it down to a minor Kodi bug.

0 Likes

#37

I found that too with Chrome. Switched to FF and resolved.
I looked at it once and it seems to poll the web server. I think the web server is single threaded and the AJAX like approach causes problems.

I don’t know why evbug is loaded on your device, but it shows a lot of disconnects.

Jan 10 22:03:18 vero-osmc kernel: evbug: Disconnected device: input52
Jan 10 22:03:18 vero-osmc kernel: evbug: Disconnected device: input53

Seems like the dongle isn’t getting enough power, which would be surprising for the Vero as the power requirements are minimal.

Can you try it in another device like a PC for a couple of minutes? Not all buttons will work out of the box for that iteration of remote, but the directional keys will.

Sam

0 Likes

#38

I dusted off my rpi2 running osmc 2017-6 and connected the remote and did a graphical update to 2017-12. It worked flawlessly (good work on the update process!) And the remote worked fine with it.

I’m guessing my vero has some kind of hardware problem then or maybe the ac adapter is wonky. I bought the device upon release, so it’s been running 24/7 since in different parts of the house.

0 Likes

#39

Shucks. Nice theory, but I use FF.

0 Likes

#40

Mhhh … but it could not be such profane thing like a battery issue?
Would be good to split this RF remote issue from the original thread.

0 Likes