Vero problems

#22

OK so I updated to the July build of OSMC (based on Kodi 17) and in Settings --> Player --> Videos under Processing, “Render method” is set to “Auto detect” and is blacked out. There is no option for amcodec.

IMAGE

However, I can’t connect to my networked HDD to test anything because OSMC can’t seem to find anything on my network. Although it is connected and has an IP and has internet access…

0 Likes

#23

Is that with Samba? Try to limit the max protocol to SMB1 in Settings -> Services -> SMB Client

0 Likes

#24

@adimifus PM me that he has reached the daily (first day joiner) post limit. So discussion will continue tomorrow.

0 Likes

#25

There is no amcodec because he is on a Vero 1, which isn’t an AmLogic based SoC.

I have lifted the poster’s post limits

0 Likes

#27

I’m sorry if I haven’t been clear about the fact that I’m using a first generation Vero aka Vero 1 (not Vero 2 or Vero 4K).

I don’t have any options for setting max protocol under SMB client settings.

0 Likes

#28

This setting was only added in the 2017.08-1 version of OSMC.

Sam

0 Likes

#29

Try picking 2016.12-1 and seeing if it behaves better

Sam

0 Likes

#30

Supposingly he upgraded to latest version for testing

0 Likes

#31

Okay – I got a PM about reinstalling; so just wanted to offer some further advice if he embarks on that.

0 Likes

#32

Regarding hardware acceleration, is the option to turn it on or off the blacked out option I keep mentioning?

For accessing my networked HDD, entering in my IP/login manually works fine in older Kodi 16 based builds, but doesn’t seem to work in the newer Kodi 17 based builds. Is there a different procedure involved in setting up such a connection?

I’m not a complete noob when it comes to Linux, add I’ve used it in a desktop environment before, but how do I go about accessing a device connected directly to the Vero (like a USB drive)? It says a device is connected when I plug one in, but I can’t figure out where it’s mounted. I would like to try playing back a file that way to be sure it’s not a network connectivity issue.

This is also something I would consider doing. I thought I was already doing this by installing OSMC directly to the SD card via the windows client, but I now get the feeling there’s more to it than that.

0 Likes

#33

I don’t think you can trivially toggle it anymore.

If you’re using Samba shares, then things have changed a bit, because of security improvements. You should be able to set the Samba version your device uses in a new Settings menu and then connect.

Attached media are automatically mounted in the /media directory.

0 Likes

#34

That’s what I thought. But nothing was showing up there (in /media) for me when I tried doing that last night. I’ll try again later tonight, as I’m not by my Vero right now.

I’m actually only on 2017.07-1 right now, which as of now is the latest version available to install onto the SD card via the Windows client. I haven’t had the opportunity to upgrade through Vero yet. I’ll update to the latest version when I get an opportunity tonight (I’m not at home right now)

0 Likes

#36

If it’s a spinning hard disk; make sure it’s getting enough power.

0 Likes

#37

It was a flash drive. Do you need to normally exit out of the file manager and go back into it for the drive to appear?

I’ll try that out, too.

0 Likes

#38

I updated to 2017.08-1 and tried playing back a file from a USB flash drive and it plays back fine. Disconnected the HDD from the router and connected it directly to the Vero, and files play back fine. Something must have changed with my router that the Vero doesn’t like, but none of my other networked devices have a problem with. I’m not sure where to go from here exactly, but the Vero is not at fault.

Also, HD video plays back fine, so I’m gonna stay at the current version.

There is no option for me to set the samba protocol in SMB client settings, even in 2017.08-1. I did manage to connect to the HDD just fine manually, though.

EDIT: Very interesting development. I thought about what the difference was between the Vero and the other devices on my network that I tried playing video files from, and the only thing was everything else was Wi-Fi and Vero was Ethernet. I connected the Vero via Wi-Fi and now videos play back fine from the network HDD. I feel pretty dumb I never even thought to try this earlier.

0 Likes

#39

try a different network cable then, sounds like a faulty cat5 cable to me

tom.

0 Likes

#40

Is it a Gigabit port?
Can you toggle flow control on the router?

Otherwise: this will do the trick (I suspect):

sudo apt-get install ethtool
sudo ethtool -s eth0 speed 100 duplex full autoneg on

I am glad HD video is working well for you!

It requires Expert Settings to be on and appears under Network.

0 Likes

#41

Yes the LAN ports are all gigabit. Switching back and forth between 100 and 1000 with ethtool didn’t seem to help at all.

I tried using a different cable on a different port, made no difference.

Wi-Fi seems to work OK. For the most part it can keep up with video, but it struggles and drops frames sometimes.

0 Likes

#42

See Vero network speed - choppy playback

If your router allows you to; disable flow control.

0 Likes

#43

I can’t find anything related to flow control in the settings of my router.

Unfortunately, Wi-Fi doesn’t seem to work very well at all. A lot of my movies are fairly large and require more bandwidth than Wi-Fi seems to allow.

EDIT: I noticed QoS was mentioned along with flow control when I was looking up where to find it. I disabled QoS, and now everything seems to work fine again over Ethernet. Videos play without issue, folders load instantly.
I had enabled QoS a while back-- long before this problem started. I wonder why it only started causing problems now?

0 Likes