Vero 4K, Video short blackouts


how do I edit the file? it says it is read only, sorry not too familiar with unix shell


sudo nano /etc/apt/sources.list

Then Ctrl-X to exit and confirm with Y.


Can you always get blackouts with a specific clip?

no specific clip, happens with every content I play

Is it the same point of the video?

No, it seems to be randomit happens once while I was on the menu of kodi, not playing anything

Can you share that video?

as I mentioned, it happens with all MKV movies that I have

Can you try some improvements (below)

I just did, and same thing happened

I tried to capture the video, you may view it here, I dont know if it is clear or not!Ag8SFa85wbKq6x89NczNQUgCdcQW


I’ve actually experienced this a few times myself but haven’t really thought about it much since it’s like 1 second of no video and audio continues. Has happened in menu as well as movies but very rarely. I’ve got the vero connected to a power strip/surge protector at all times. Can’t connect it directly but can probably get some regular extension cord of that’s better?


Is it at the start or randomly?
Check log for discontinuity. A bad mux will do this. Don’t think it’s the same as others have described though; but same questions given to Pieter apply.


Completely random, as it I’ve seen it happen idling in the menus. I’ll see if I can see something in the log next time it happens.


I have a new update, I’ve set the resolution from 4K to 1080P, watched a hole movie without any heck ups.

initial feedback, problem happened with display set at 4K and 24 fps


Now try 1080p at 24Hz.
Should be OK.

I watched your video. That doesn’t look like an OSMC / Vero bug to me. The sound continues. I assume you have an AV receiver. This suggests the HDMI signal to the AVR is OK.

When you changed the cable, did you change it between AVR and projector or the Vero 4K -> AVR.
Does the AVR’s display show any change when the video starts acting weird? Like a loss of signal or changes to audio track (usually signify HPD).

Had a similar problem with a PS3 once. Upgrading the cable between the projector and the receiver did the trick.



it is between the vero 4k and the video switch. I actually have a video switch that has a connection to the projector and another hdmi to the Audio processor.

the one I changed is the one between the vero 4K and video switch and the only change is the resolution in the vero 4K that I have changed and it worked fine with 1080P.


yes, I can confirm it, after I connected the OSMC to the video processor directly, it stopped flickering and the problem was resolved.

Thank you