Vero 4K, Video short blackouts


Hi @pieter

I suspect if you’ve tried with a few cables, then that isn’t the issue.
I’ll send you a new power supply tomorrow. Please provide me with your order # so I can get a replacement out to you and please confirm whether your shipping address needs updating.

Ideally, it would be good to test with Vero 4K plugged directly in to the wall. Some extension chords have been problematic in the past before.



My order # was: #5342
Shipping address: Waterhoen 56, 7423 CR, Deventer, Netherlands.

I haven’t been able to try yesterday, but I’m willing to try (tonight) and see if I have an alternative power supply laying around and try with that one first. (trying to prevent unneeded costs to you if the power supply is not the origin of the problem).


Hi @pieter

Sorry for the late reply.

I’m happy to send you a new PSU, but we really do recommend powering the device directly. Trying on a new TV directly powering the device would be great.

Failing that, I’m more than happy to get a new PSU out for you. This has dragged out for some time and I’d like to get it solved promptly for you



Hi @sam_nazarko

This weekend I found another PSU (5V 2.5Amp) that also has a longer lead so I can plug it directly into the wall and the TV. So far It seems to work (only saw one episode at 25min) but too soon to tell.

Unfortunately I don’t have the option of testing against another TV :frowning:

I’ll let you know how the “new” PSU affects playing.


Keep an eye on it.

If things work well, we’ll get you a new PSU out in the post promptly.



I have the problem too but only with files from itunes. Since I am able to recreate the problem on a different Kodi system (nvidia shield), I believe that the problem is with Kodi. Vdeo starts normally for about 10 seconds, then goes black for a second and continues normally. It kind of feels like the refresh rate is changed again because it just looks the black out at the start of the movie when refresh rate is switched from 60hz to 23.976… it sometimes happens later in the movie as well,

It is not a big problem and I identified that the problem is with itunes movie files, so I kind of know what will happen, so I either avoid those files or just live with it. But it sounds very similiar to what people are reporting here.


Does your TV tell you when the Refresh Rate has changed?
On my main display, I see ‘Searching’ when it changes, then followed by the new resolution and refresh rate. If you also see this then that’s what’s happening.

It sounds like @pieter is getting repeated blackouts however.



I have to check but I think it only shows the new resolution not the new frame rate. Is it even possible for a file to change frame rate during playback? Or any other (non osmc related) causes for frame rate switching during playback?

Because I have actually sorted out all mentioned files, I was just curious for the reason why they behaved that way. The thread just reminded me of the problem I did have with short blackouts with certain files.


Yes. This sometimes happens with Live TV programs during a commercial break; or if the video is not encoded correctly.

WEB-DL releases are usually pretty good; so not sure why it would happen with those.
Some framerate fixes went in to staging last night. Maybe it will benefit this scenario.


ok thx for the info, it happens only with itunes web-dl, I will keep an eye on the issue and give more detailed infos (logs) if it happens again… but it is a very small issue anyway.


@sam_nazarko An update on the “new” PSU. So far there have been no blackouts with the 2.5Amp PSU. It is a bit early to celebrate but it looks promising so far.


I am also experiencing the same, I’ve tested other media players, xstreamer (never had an issue before kodi 17.3) after the update exact same behavior, black out for 2 seconds then it continues playing. I’ve also tested Wetek and the same thing happens.

the most recent one now is the vero 4K. same thing happens. could this be Kodi?


If you have this on several devices, I’d investigate things further. That’s certainly not normal and probably not caused by a PSU; unless you are sharing them between a socket or using the same PSU.


If I understood what u r saying correctly, this is how I have my setup
Electrical socket — power regulator — two power strips — AV equipment including OSMC and xtreamer

Will that be an issue?


Cannot be ruled out until you plug it directly to mains. 2 power strips absolutely has the potential to be an issue.



I’ll get you a new power supply out in tomorrow’s post.
I’m also sorry that it took so long to get to the bottom of this. I’ve added a credit to your account for any future purchase.




I can confirm this, I have connected vero 4k to a seperate electrical outlet alone and still does the same thing. it kicks me our for few seconds, playback of video stops, audio continues to be okay. then it resumes video


testing a new HDMI cable to see how it goes


Test with that. If you have the same problem then we should investigate further.

  • Can you always get blackouts with a specific clip?
  • Is it the same point of the video?
  • Can you share that video?
  • Can you try some improvements (below)
  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


let me test the new HDMI cable, after I changed it last night, I watched for 40 min without any issues. I will test it today and will provide feedback.