Vero 4K, Video short blackouts


Other points:

  • If you have an HDMI cable you can swap over; try that.
  • Is HDMI connected directly to the TV?


So far I’ve tried 3 different HDMI cables, including the one included with the Vero 4K. No difference.
The HDMI cable is connected directly in the Vero 4K and the TV. In all 3 cases it was directly connected.

I have one other HDMI cable left (a 15m one), I’ll try that one this weekend.


No need. It wouldn’t be the case that all those cables are faulty.

Try a direct connection to the wall if you can. If the problem occurs enable debug logging and upload a set of logs. It should give some clues.

Let’s get this solved.


I have the same problem, blackouts happen from time to time. At first I thought that it was a faulty file, but now it started happening more often. Don’t see any resolution on this thread, did you manage to find what was wrong?

I also used osmc with raspberry pi 2 before and problem only appeared when I bought vero 4k. It is not connected directly to wall, but neither was old raspberry pi. Basically everything is the same in the setup, except that I switched to vero 4k box.


Try that first.

Some debug logs when it happens may give some clues.



It’s been a while since I last used the vero 4k. I started using the vero 4k again this week and the problem is still here.

The vero 4k is up-to-date, plugged directly into the wall socket, multiple hdmi cables have been tried (including the one delivered with the vero 4k). The problem of short blackouts continues :frowning:

Log of my vero 4k a few minutes after the blackout happened:


Thanks for the logs. I will check them out


Hi @pieter

Can you make this a debug log and re-upload?




How do I do that?


To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.


As a developer I understand the need for good information and debug logs :slight_smile:
It took me a while to get a debug log with the blackout.

I started debug, rebooted, watched one episode (nothing happened) and then watched another episode (different series). The blackout happend and I halted playback and went to the Osmc addon and uploaded the log.

I hope I did it corectly and that this will help.
(post edited to correct typos)



Thanks for your understanding.
What’s the name of the file when you start to get blackouts?

There are a few listed in the log.



It was in Westworld.S01E01.The.Original.mkv


Looks like a discontinuity there:

20:47:34.859 T:3491111920   DEBUG: CDVDClock::ErrorAdjust - CVideoPlayerAudio::OutputPacket - error:-56743.706818, adjusted:-56743.706818
20:47:38.967 T:3504235504   DEBUG: CPullupCorrection: detected pattern of length 1: 41708.33, frameduration: 41708.333333

Does it always occur at the same point in this file?



Not that I have noticed.

So far, If I would playback a file again im which it happened, the file always played without any problems.

After a blackout happens, I usually rewind to a few seconds before where it happened, and the file plays without problems.

A few days back I even had the blackout happen while navigating through the kodi interface.


So that would point to a signal drop on HDMI most likely related to the long cable you use. Not sure if any HDMI amplification can be done.


The cable I used during this playback was less then 1m in length.

I tried with 3 different cables (inluding the supplied one) all with different length, and I have this problem with all of them.


Sorry didn’t know that, just was going thru the posts and saw that you had long one at one time.
Let’s wait for the master brain be back but if it happens during navigation that is very much a basic task where e.g. no refresh rate adjustment should happen.


Please try another HDMI cable.
Please can you confirm that the device is plugged directly in to the wall?

Your logs didn’t show any loss of HDMI connectivity to me. If it happens again and the TV shows no signal, please send a log and I will be able to see what’s going on



I already tried 3 different hdmi cables. What kind of HDMI cable do you want me to try?
(all three have been tested to work fine with other appliances, including a rpi-2 with osmc).

The device is currently not plugged directly into the wall, I had a setup with the device plugged directly into the wall and it also happens in that config, since the wall plug is farther away then the short cable is long, a setup in that config is pretty annoying. Should I try to replace the supplied “powerbrick” with another one with similar spec?

The whole setup is about the same as I used sucessfully with the rpi-2 (which is even more vulnerable to power problems) since the first versions of raspbmc. The only difference are the osmc versions, vero 4k and the powerbrick used (rpi uses microusb power).