Vero 4K+ does not boot from SD Cart

#21

I test again tomorrow with new USB stick.

I’ll rename the kernel.img file to recovery.img.

If it does not work then I’ll send it back.

0 Likes

#22

Have you tried just leaving it on the black screen for a while… My 4k went bonkers before running the pre-release build of Kodi v18 and I couldn’t get it to enter the reinstallation menu like it used too… It used to flash a warning with a count down about things being erased or something… I messed about for ages trying to get it work, after getting fed up I left it on the black screen, TV said no HDMI signal, went made a coffee came back and it had done it and was on the start up screen

1 Like

#23

I found an issue which could cause the installer to show a black screen on some displays and have since addressed this.

0 Likes

#24

That explains that then… I did message you at the time about it as I thought it had died, but like Jesus it was reborn lol

0 Likes

#25

Hi, I just received my Vero 4k+ and the experience so far from my expectations. I read about it as plug&play solution, but from the beginning i am struggling to get it to work.

My adventure is very similar to what is explained in this thread. At first power on i got linux booting screen with lots of failures, see screenshot.

Then i read about installing OSMC via SD card or USB. Tried, but did not work, various errors printed. Then tried recovery procedure, but after holding toothpick for 30s i got screen with message “Please stan-by” lasting for >15minutes. Few tries with sd card, and usb drive, with re-installation of the drives. Did not work, when restarting without sd/usb got failure “FATAL ERROR: could not find root filesystem device /device/vero-nand/root…”

Just before giving up, after 3h of fighting, i thought lets try with older release of OSMC and took version 2018.10-1. When plugged in and started i got message “OSMC: You have 60 seconds to power down before the device is formatted”.

Wow, at least so sing of expected functionality. After the counter went down, the device got formatted and OSMC was installed, followed by OSMC installation process.

It is working now, at least i was able to make few tests. Now i am thinking if there is something wrong with my device, and it will give me problems with each new release of SW. I will try to update to latest in the evening.

Hopefully helpful.
Best Regards

0 Likes

#26

Why are veros sold here that do not work? Are the devices not checked?

0 Likes

#27

Yes, they are checked.

1 Like

#28

Then I do not understand why there are these problems.

0 Likes

#29

Zero defects is impossible. Just ask Boeing…

3 Likes

#30

Every single Vero is powered and checked before dispatch.

There are a number of reasons why a user may experience a problem when they receive their unit. It looks like the user above has resolved the issue with a reinstallation.

If you have an issue that you’d like me to look in to, let me know.

0 Likes