Vero 2 does not detect beamer when turned on


#21

OK – if you can test with another display it will really help.

Sam


#22

i tried with an external display i had in my basement. unfortunately the display turned out to be broken.

at the moment i have no other possibility to test this, since i have no other display nearby. however i think this is a more general issue that should be resolved. my beamer is an Optoma H25 Beamer and a pretty common device. it was even suggested in the forum so i thought it would be a good fit with the vero2.

is there any other possiblity to continue testing?

cheers
bendsch


#23

I also have this projector but can’t reproduce the issue with it.

I’ll see if I can backport custom mode support

Sam


#24

ok, thank you!


#25

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Now, when you have a picture run:

sudo cp /sys/class/amhdmitx/amhdmitx0/disp_cap /home/osmc/.kodi/disp_cap
and reboot. This should fix the issue.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam


#26

i installed and executed the command. unfortunately it is still not working …

cheers
bendsch


#27

Can you confirm the disp_cap file is there?
If it still does not work then I believe it’s an environmental issue. I tested on a Vero 2 with an Optoma HD25 with and without a Sony AVR.

Can you post a new log when the issue occurs?

Sam


#28

the file seems to be there but is empty:

osmc@B2VERO:~/.kodi$ ls
addons disp_cap media system temp userdata
osmc@B2VERO:~/.kodi$ cat ./disp_cap

in order to provide a log while issue is occurring (no picture when beamer is turned on) i have to do it from command line. what is the right way to do that?


#29

From commandline use: grab-logs -A


#30

https://paste.osmc.tv/huyozopogo


#31

You need to copy the file when the display is working, from a fresh boot

Sam


#32

Ok, i copied the file once again to .kodi directory. now the file shows the content:

cat ./.kodi/disp_cap
720p
1080i
1080p
720p50hz*
1080i50hz
1080p50hz
1080p24hz

on reboot with beamer turned off now i have the following situation when beamer is turned on: “HDMI 1 searching” (see screenshot attached).

I reuploaded the log while in this situation: https://paste.osmc.tv/hecitotaqa

cheers
bendsch


#33
00:21:07.312 T:2958520320   ERROR: GetString: error reading /home/osmc/.kodi/userdata/disp_cap

Maybe a permissions issue there.

00:21:07.313 T:2958520320  NOTICE: Found resolution 1280 x 720 for display 0 with 1280 x 720 @ 60.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080i @ 60.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080 @ 60.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found resolution 1280 x 720 for display 0 with 1280 x 720 @ 50.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080i @ 50.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080 @ 50.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found resolution 1920 x 1080 for display 0 with 1920 x 1080 @ 24.000000 Hz
00:21:07.313 T:2958520320  NOTICE: Found (1280x720@50.000000) at 19, setting to RES_DESKTOP at 16

I am not sure why the projector is advertising it’s preferred mode as 720p. Is there something in between?


#34

hm, i am a bit confused.
kodi seems to be looking in /home/osmc/.kodi/userdata/disp_cap, the file should be put in /home/osmc/.kodi/userdata tough and apparently, despite of the getstring error, a couple of resolutions are found. were those read from the file?!


#35

any thoughts on this?


#36

Can you check the permissions on the file?

I am not sure why this doesn’t work for you unfortunately. I can’t reproduce this with HPD Lock on the exact same projector.

I don’t think you have told me if you have a receiver still so it’s hard to know if other equipment is causing a problem.

I would try on another display when possible


#37

hi

for testing i gave 777 persmissions to the file:

osmc@B2VERO:~/.kodi$ ls -l -a
insgesamt 44
drwxr-xr-x 8 osmc osmc 4096 Jun 23 14:45 .
drwxr-xr-x 24 osmc osmc 4096 Jun 27 09:12 …
drwxrwxrwx 228 osmc osmc 12288 Jun 19 16:25 addons
-rwxrwxrwx 1 osmc osmc 57 Jun 25 00:22 disp_cap
drwxr-xr-x 2 osmc osmc 4096 Jan 1 1970 media
drwxr-xr-x 2 osmc osmc 4096 Mär 19 2017 .smb
drwxr-xr-x 2 osmc osmc 4096 Jan 1 1970 system
drwxr-xr-x 5 osmc osmc 4096 Jun 30 10:49 temp
drwxr-xr-x 10 osmc osmc 4096 Jun 25 08:50 userdata
osmc@B2VERO:~/.kodi$

as already said, its just the beamer, no other equipment is connected to the vero.


#38

lately my vero installation went corrupt (root partition was not found), so i had to reinstall osmc.
i also replaced the hdmi cable which was i bit faulty i figured. i don’t exactly know which one of the two changes is responsible, but know i get a pciture on the beamer even if its not turned on on osmc boot.

on the other hand i still have the problem, that kodi boots in 720p resolution, even if i manually set the resolution manually to 1080p. how can i force kodi to keep the 1080p resolution even on reboot?


#39

but i noticed two other odd things that are new:

1st: if beamer was off while osmc booted (and then is turned on) i am not able to change resolution, and mode is set to “windowed” (not fullscreen)

2ns: if beamer was off while osmc booted (and then is turned on) sometimes osmc crashes

i think there is really something wrong with the display recognition that should be fixed somehow.


#40

If your projector is off, there is no display to recognise, hence why we fall back to 720p.
This is a bit more flexible on Vero 4K / 4K + but this customisation is more limited on Vero 2.

You could try using the disp_modes file as previously suggested

Sam