TVHeadend 4.2 released


#41

Sure if you really need them. To be honest it’s all default settings. May take a day or 2 worse case. Work gets in the way. ;-( Initial install was OSMC 4.1 which was upgraded to 5.2, Installed tvheadend from the store, i believe it was marked 4.2.2, but was 4.0.9. Followed Sam instructions, and upgraded, verified 4.2.2 via web interface. Used the wizard to setup and scan for muxes etc. Verified channels and EPG. Took some time to remember how to setup the live tv option in OSMC.


#42

That’s very helpful, thanks. I configured in 4.0.9 then upgraded. That’s probably the difference. I’m now sure there’s a bug with the instant recording but don’t know if it’s in tvh, the tvh plug-in or Kodi. I’ve raised it on the TVH bug list so we’ll see what comes back. So don’t bust a gut.


#43

Crash course in Git and PR submitted.


#44

Cheers, I’ll see if I can look over it today


#45

FWIW, 4.2.2 has been running on my main installation (RPi2) for a week now and no apparent issues. For testing, I’ve been just installing/uninstalling the tvheadend-app-osmc deb without all the other stuff in the jessie-devel repo. Seems to work.


#46

Ditto,
I abused it over the weekend,recorded “Get Smart” marathon.Learned a few things during the process. Was also able to copy all my settings over with no issues. EPG working via zap2it. Pretty happy camper here.


#47

Quick aside, 4.2 has also been compiled for Raspbian Jessie. Instructions are on the tvheadend download page. This upgraded nicely on my Pi 3.

The EPG smart state seems to work well so you don’t have a ton of padding at the start and end of a recording.


#48

Did you use Sam’s jessie-devel repo or the mpmc one?


#49

I assume jessie-devel, as third party repositories aren’t supported. It will work for now but cause serious problems in the future, which is why we ship our own, officially supported version.


#50

I didn’t explain myself too well! :wink:
I use a Vero 4K for Kodi, but because the Vero 4K didn’t support my TV tuner at that time I installed TV Headend on Raspbian on a Pi 3 using the bintray repository from here:
https://tvheadend.org/projects/tvheadend/wiki/AptRepository

However, 4.2 didn’t have an official compiled version for armhf due to their new build system I think.

So, I used the mpmc repo as now advised on the tvheadend page on Raspbian and it worked fine to upgrade.


#51

Just wanted to say thanks Sam, I needed to start a new config but other than that it’s all working really well :+1:


#52

Cool – we’re looking to see if we can provide a better form of migration.


#53

Hi all.

I’m quite new using osmc and finally managed to install tvheadend 4.2. Unfortunately hardware CI is not supported (DVBSky 960CI is connected to my RPi3). Could it be that liben50221 has not been added to the build as described in tvheadend board.

Many thanks.


#54

Sorry, I used jessie-devel repo and switched now to mpmc - that solved my problem!


#55

+1. This is the only thing holding me back from using OSMC as my only media source.


#56

I know I’m a bit late to the game, but wanted to add my experience with upgrading. I was running the appstore version of tvheadend on an rpi3. I wanted the auto IPTV feature, so I followed Sam’s instructions above to upgrade. All went well and I haven’t encountered any issues yet. All of my config settings seemed to carry over to the upgrade without issue. My previous network/channel mappings remained as well as my EPG grabber. I ended up deleting all of my network configuration anyway to redo it with IPTV (my cable company recently encrypted so I could no longer record most channels with my hdhomerun which was my reason for going to IPTV) so I didn’t care if it was lost, but it carried over fine. I’m happy to be able to record again!


#57

You can thank @grahamh for that.

Sam


#58

4.2 is in staging repository. Can anyone give it a go?

Sam


#59

Sounds like it’s just about ready for prime time. I’m happy to give it a go, how do I upgrade from ‘staging’?


#60