[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch


#142

no problem let me know if you find any more info

cheers


#143

@the_bo Back infront of the puter,

Will research starting a script, been awhile since i did these things (10+ years)


#144

Thanks take your time :slight_smile:


#145

@the_bo This is the way to go:

nano /home/osmc/.config/lxsession/LXDE/autostart

@lxpanel --profile LXDE
@pcmanfm --desktop --profile LXDE
@xscreensaver -no-splash
sudo openvpn ~/OpenVPNConfig/UKSouthampton.ovpn &

This should do it, else get back to me.


#146

Unfortunately that didnt work joakim :confused:


#147

@the_bo PM :slight_smile:


#148

Thanks for this, it definitely fixed my problem with screen switching to a “no signal” mode.

I’m still having an issue though where the “X11 desktop” background is black, and the cursor is black. When I right click the desktop and choose settings, the popup has a cancel but not an “ok” so not able to actually apply any of the changes I make. Are preferences locked somewhere, and can I unlock them?


#149

@ZacWolf The background shouldn’t be black, which hardware are you running on?


#150

The new Vero 4K. Everything seems to be working, and Chrome starts wonderfully (and looks great), it’s just that the desktop background is black and I can’t make any changes via the right-click desktop-settings, options.

Is there a config file where I can unlock the settings panel?


#151

@ZacWolf
Nope, had the same issues with my Vero4K, it’s an issue with the driver for Vero4K, I’ll pm you some instructions to get a accelerated driver installed.


#152

Thanks very much!


#153

Accelerated driver is pretty good.
If there’s enough demand, I’ll produce an optimised Chromium for Vero 4K.

Cheers

Sam


#154

I’d like to go on record as saying please for the Vero4k Chromimum build! Basically everything else is super fast (my X11 loads in five seconds from the Kodi addon), but starting Chromimum takes several seconds. It’s been well on 25 years since I did any serious x11 work, so I’m gonna dig today to find away to make Chromimum autostart on the x11 load (just so it’s a better perceptual startup time flow), but anything that could improve Chromimum performance would be awesome! I am love the 4K so much! You have put together and amazing little machine.

I know you’re shooting for the non techy user base, but with the 64bit architecture, it would have been absolutely amazing if you’d have added about another 1/4 in height to the box and allowed adding labtop memory. With more memory this little box could probably be a serious living room computer, especially with the X11 environment running now!

Oh well, maybe v2.0?


#155

So today when I logged in, I got a msg for a Chromium-browser update. I went to the download page, and it gave me a downloaded for a 64-bit .deb file.

Is it safe to install that? Do I need to use any special parameters to install it over the existing binaries?


#156

I doubt it, but there is only one way to find out, I will try it in a couple of hours


#157

Started chromium no msg, and i bet that the 64bit deb is for intel 64bit debian


#159

Thx Joakim everything is working nice, but is it possible to install chrome to use netflix ?


#160

No, but be patient :wink:


#162

Hi @joakim_s

Is there way to enable hardware acceleration in chromium on rpi3.

Seems raspbian has enable hardware accelation on there chromium.

Do you need a patched version of chromium to enable it?

Thanks for any info


#163

i’ve got all the patches needed but i have no real experience with applying diff files to source, and I’ve haven’t yet been successful in compiling a OSMC version of chromium yet, third build running is starting in a few hours (takes almost 20 h to compile on my laptop). But my aim is to get there =)