[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch


#325

Good Job, it works nicely.

It is possible to control mouse using CEC ?


#326

Haven’t tried, and i dont know how to. But i do recommend UnifiedRemote


#327

Hi @joakim_s,

I’ve installed chromium-browser on Vero 4K according to the instructions here.

When I start a browser with any webpage, I get ‘Aw, Snap’ message.
I’ve tried also with Kodi disabled, and the same result.

I can see that chromium-browser starts two instances and the combined CPU load is approx 100% (see picture below)

Any suggestions? Thanks.


#328

It’s ok … I fixed my own problem :slight_smile:

Installed Chromium 50, and it starts up without any errors.

Thanks.
Best regards,
Niall.


#329

Hi there; I had the system up and running on my RBP3 (OSMC as my main system, retro pie as an add-on and X11 launcher as well).

I started getting the “aww snap errors” in chromium noted by others (prior to this it was running wonderfully!); so i re-flashed OSMC. installed retropie, installed my vpn etc…

However, now when i use the installer above the entire system “freezes” at the main selection screen on OSMC - i’m unable to use mouse or keyboard or xbox controller.
I can sometimes SSH into the system but i really only know how to follow other people’s instructions and I’m not very adept at linux.

wondering if you knew what was going on or if others had experienced this? should i use the installer and prior to a “sudo reboot” run the sudo apt-get install chromium=63.0.3239.84-1~deb9u1 instead?

if I don’t use the X11 installer everything runs fine on my system… so it appears its the act of installing that is causing some crash/freeze?

Any thoughts would be great! :slight_smile:


#330

@MattGee I will do a clean install either tonight or tomorrow and try out the installer again and get back to you.


#331

yeap there seems to been some changes in the debian dependencies. To solve it here is what you do:

sudo systemctl disable lightdm

don’t know why lightdm suddenly is running from start, it never used to. will ahve to look at the installer again. Thanks for telling me, and chromium version isn’t longer in repository. So we are out of a webbrowser unless you use the one from ubuntu


#332

yeap there seems to been some changes in the debian dependencies. To solve it here is what you do:

sudo systemctl disable lightdm

Don’t know why lightdm suddenly is running from start, it never used to. Will have to look at the installer again. Thanks for telling me, and a working chromium version isn’t longer in repository. So we are out of a web browser unless you use the one from ubuntu from post 321

Edited the install script to install ubuntus chromium as per post 321, and disabled lightdm.


#333

Awesome! Thanks I’ll give this a go in the next few days and let you know :slight_smile: most appreciated


#334

everything works great!
also i followed the instructions for the old browser:

wget http://launchpadlibrarian.net/380369885/chromium-codecs-ffmpeg-extra_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
wget http://launchpadlibrarian.net/380369879/chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo dpkg -i chromium-codecs-ffmpeg-extra_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo dpkg -i chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo apt --fix-broken install
sudo dpkg -i chromium-browser_68.0.3440.75-0ubuntu0.16.04.1_armhf.deb
sudo apt-get purge chromium

many thanks for this! it was just was OSMC is missing! :slight_smile: