[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch


#265

looks like that log was cut short, try this from console:

cat /var/log/Xorg.0.log | paste-log


#266

yes ,sorry for that

https://paste.osmc.tv/jikicebovi


#267

it the “keyboard/mouse” new addition from when it worked?


#268

yes i just plugged in for testing it out but i can’t reach to the desktop


#269

I think there is some driver issues for that keyboard in Xwindows, it tries to load some drivers but it seems to fail. I’m no expert when it comes to Xwindows and hardware. I’m sorry but i dont think i can help you, Google might be your friend: Debian “model of keyboard” xwindows/x11


#270

I tried without plugging the keyboard in but i have the same results

log : https://paste.osmc.tv/rijavavade


#271

i also tried to increase the sleep commands but nothing changed


#272

Ok, if you’re comfortable with ssh we can try to start Xwidows and see if it gives errors to prompt.

Login via ssh and run these commands:

sudo systemctl stop mediacenter

startx


#273

Yes this worked and i can see the desktop now. Noob question but the launcher wont work again?

Edit : i used this as mentioned above: #!/bin/bash sleep 2 sudo fbi -T 7 -d /dev/fb0 --noverbose /home/osmc/Pictures/Desktop/lxdewallpaper.jpg & sleep 3 sudo su osmc -c "startx" sudo openvt -c 7 -s -f clear sudo systemctl start mediacenter exit

And everything is working


#274

Did you upgrade to Kodi v.18 (Leila) ?

Does you x_init.sh have two “sudo openvt -c 7 -s -f clear” lines? one before and one after startx line?


#275

Whenever I run “startx” from my terminal. It logged in, but, the session itself is different than running it from osmc programs. And why is that?


#276

Are you logged in as another user then osmc? Desktop settings are stored in the user homedirectory.


#277

Installed and running great on March update of krypton, but have to reboot otherwise videos back in Kodi play with audio only.


#278

Which hardware are you using?


#279

Vero 4k


#280

Try this:

in xinit.sh, insert this line before “sudo systemctl start mediacenter”

echo d01068b4 0x3fc0 | sudo tee /sys/kernel/debug/aml_reg/paddr

now it’s been a while might be 0x7fc0 instead of 0x3fc0, you got to try.


#281

Will give that a try in the morning, what’s it meant to do?


#282

There is a Alpha swap that changes the alpha channel, that is reverted by those commands. I just dont remember which of them sets the alpha swap and which changes it back.


#283

Is it possible to use this version of chromium to get the chrome launcher application working?
When I open chrome launcher I get an error: “chrome not installed”.


#284

No chrome launcher is not for OSMC, since chromium cant run beside Kodi in OSMC. Chromium needs X11, which is started after Kodi closes, and when you exit X11 kodi restarts again. There is no way in the current setup to send links to chromium from Kodi.