[Testing] X11(simple desktop) + Chromium(web browser) in a simple installer for Stretch


#204

Could you check if the /etx/X11/xorg.conf contains

Option "alpha_swap" "true"

It sounds like some step in wget ing the xorg.conf and installing it into /etc/X11/xorg.conf went wrong.


#205

It sure does. Let me try re-downloading the recommended xorg.conf. Alternatively will changing alpha_swap to “false” help?

Ted


#206

I just redownloaded again from wget https://raw.githubusercontent.com/zjoasan/x11-osmc/master/xorg.conf
Seems to be the right xorg.conf…md5sums match.

47ce9541319928a387983d08ed4914cc xorg.conf (downloaded)
47ce9541319928a387983d08ed4914cc /etc/X11/xorg.conf

Ted


#207

Yeah, they should be identical since both had alpha swap. I thought the apha swap directive was missing, because that gives those symtoms. Right now i’m haveing issues starting X on my newly reimaged Vero4k. Will get back to you when i get it up and running myself


#208

Thanks very much for your quick response! I will look forward to any updates if you get it up and running successfully.

Ted


#209

@tedsears PM with alternative solution sent, please test and update me on results, might have to change the instructions for the vero 4k driver installation


#210

nice work. but i have the issue, that lot of icons are not visible.
on rasp2/3

btw. for firefox i used "sudo apt-get install firefox-esr"
desktop icons are placed in /usr/share/applications


#211

Hello. Sorry if this is a dumb question. Is there a subset of X11 that can be installed if all you care about doing is forwarding X11 to another server? I don’t intend to run a desktop on OSMC but I’d like to be able to run a few things “ssh -X oscm@myosmcbox.” This theoretically shouldn’t require an XServer running (on the osmc box) but I couldn’t get it to work by just installing, for example, xterm and its dependencies.


#212

Love this setup - thank you for the work you put into it!
Looks like the latest update to Stretch + Leia broke this and it just instantly reboots back into Kodi (Prior was Jessie + Leia and was working),


#213

Will check the stretch + leila combo out and get back to you. Thanks for letting me know.


#214

Hi @Artlan_Wolf

There are two problems:

Timieng issue since leila takes abit longer to close then krypton, easy to fix edit /home/osmc/x11-start/x_init.sh change the sleep 2 to sleep 12

Second problem, user osmc seems not to be allowed to make changes to fbdev in openvt in stretch, so you can run xwindows if you replace sudo su osmc -c “startx” with sudo su -c “startx” in the same file. This however lets you run Xwindows as root, and it is a security issue.

The strange part is that if you run the commands manually in shell, shutdown mediacenter and startx as osmc it works, but not in the script. Will figure this out when i get alittle more time on my hands. Suspect opentvt is to blame here.


#215

VERY much appreciated! I was at least able to get back in with your edits - and while Chromium was being stubborn and not launching, I was able to get an instance of Firefox running (I suspect this is due to the osmc user vs root issue login) and get my background noise website running again :slight_smile:


#216

Hi @joakim_s

I’ve read this post here about improving video playback in chromium. From the comments users saying 1080p is smooth now using these commands and not choppy anymore.

Do you recommend trying these commands?

https://www.linkedin.com/pulse/how-get-smooth-youtubeflash-video-playback-raspberry-pi-kovalenko


#217

Should be okey since mesa-vdpau-drivers was installable in OSMC too, but remember we are on an old version of Chromium


#218

I think Debian stretch has latest version 62. I’ll wait for the osmc stretch update and try installing the latest chromium and test those commands see if it makes a difference.


#219

hi !

Your post and your solution to install chromium on raspberry pi is perfect but I didn’t have terminal on my desktop, is it possible to install a terminal to improve my X11?

Thank you


#220

As said earlier in thread, sudo apt-get install xterm. Sorry for short reply I’m mobile at the moment


#221

sorry, but how can I do sudo apt-get install without terminal?


#222

Ohh sorry I’ve search in this topic xterm and I have seen your answer. I try with ssh. Thanks


#223

Hi!
Can I install everything on X11? I try with p7zip and I can’t realise my installation.