[TESTING] Vero 4K / 4K + video improvements


#176

We’re outputting 422 for 10bit as most video has 420 chroma subsampling (it’s used by the BD and UHD BD) and it’s the standard for many devices to output content. You won’t miss out any quality as your TV will sample to 444 internally anyway and then convert to RGB.
Good that you could get it to work. The whitelisting option is unfortunately a bit counter intuitive especially as it basically disables framerate switching when no resolutions are activated in the whitelist. But well…

@grahamh, I think it’s there. :+1:t2:


#177

Hi

I’m also on Leia and I also have problems with 4k HDR and 10-bit. (Kernel 121)

The biggest problem is with 4k HDR 60 fps movies (mainly tv test samples from LG, Philips and Sony)

When I whitelist 3840x2160p 59,94Hz there are no picture at all when I play them.

When I disable that resolution - 4k HDR 10- bit movies plays but only in 1080p and 24-bits.

In SSH (echo now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr) I see Colour Depth - 10 -bit and Coluourspace - YUV422 but there is certainly no 10 bit colour on my screen (to test I am using LG Cinematic Jazz 4k Demo.ts).

On Krypton build everything was fine on every file I tested.

When I show info about source on my receiver I see 24-bit YCbCr422 and 1080p and 59Hz

When I play 23,978 movies in 4k my receiver shows 4k 24 Hz but also in 24 bit YCbCr422

There is something wrong…I know it is a test build…I only want to say there are some problems to resolve.

There is no possibility to return to Krypton without installing it from beginning?
Leia is very fast…everything works great except 4k HDR 60fps and 10 bit :frowning:
I don’t know what to do…wait for upgrade or instal Krypton…

PS: There is one bug…every time I restert Vero I need to recalibrate my screen

Best regards


#178

Leia is still work-in-progress so if you want reliability you had better go back to Krypton.

As for 10-bit switching it should be working the same with Leia as with Krypton. I’ve been trying to reproduce what you report but something else has broken my Leia install today.

As @wesk05 says above, if you see 422 and 24-bit on your receiver it doesn’t always mean what it says. Receivers can’t distinguish between 24 (8) or 30 (10)bits.

What is your make and model of receiver and TV?


#179

Hi

Thx for answer.

On krernel 119 my Pioneer VSX - 932 shows 30 bits on HDR 24 HZ movies.
On 121 it shows 24 bit

But I have one specific file LG Cinematic Jazz 4k Demo.ts in which there is huge differnce between 8 and 10 bits. This is HDR file but on Krypton and Leia it plays in normal SDR mode ( I think it is HLG file).

Spec:

Wideo
ID : 33 (0x21)
ID menu : 301 (0x12D)
Format : HEVC
Format/Informacja : High Efficiency Video Coding
Profil formatu : Main 10@L5.1@Main
ID kodeka : 36
Czas trwania : 17 h 6 min
Szerokość : 3.840 pikseli
Wysokość : 2.160 pikseli
Proporcje obrazu : 16:9
Szybkość wyświetlania klatek : 59,940 (60000/1001) kl/s
ColorSpace : YUV
ChromaSubsampling/String : 4:2:0 (Type 2)
BitDepth/String : 10 bitów
Biblioteka zapisująca : ATEME Titan File 3.7.7 (4.7.7.1)
colour_range : Limited
colour_primaries : BT.2020
transfer_characteristics : HLG / BT.2020 (10-bit)
matrix_coefficients : BT.2020 non-constant

When I check on VERO (cat /sys/class/amhdmitx/amhdmitx0/config) I see 10 - bit YUV 422.
On my receiver (kernel 121) I see 24 bit.
I’m looking on my TV and I’m sure it is only 8 bit colour depth (because on Krypton this file plays in 10 bits and I know how it should to look).

On kernel 119 on Leia when I try to play this file on VERO (cat /sys/class/amhdmitx/amhdmitx0/config) I see 10 - bit YUV 422 and on my receiver I see 30 bit but when I look at TV there is for sure only 8 bits.

I don’t know If You understand what I’m trying to say but…

Weird things are happening on Leia:) Or maybe there is a problem only in that specific file. Other movies shows 24 bit on receiver but maybe play in 30 bits (I doesn’t see difference:)

Best regards


#180

This is expected. See above. With 121 it will be 422.

Can you give us a link to that file?

Again, this is (probably) expected. It does not necessarily mean it’s 24bit.

OK. Now I’m slightly worried. But you say ‘sure it is only 8 bits’ are you just going on the banding? There may be other reasons for banding. Please confirm, Krypton is OK with kernel 119 and 121.

On kernel 119 it should be playing as 10-bit 420 and the receiver is saying the right bitdepth. Please double-check.

Do you get the same behaviour with Leia with vero plugged directly into the TV?

Just to be sure - it’s only Leia that’s affected. Krypton is OK for you, right?


#181

Did anyone else experience sluggish UI after installing this test build?


#182

Nope, everything seems as usual.
I hope you set it at 1080p? Since 2160p is scaled.


#183

Yes. 1080p, adjust refresh rate set to always and auto switch HDR disabled. I should be following the steps on the 1st post by Sam right?


#184

Better to update from staging as that is the latest. See above: [TESTING] Vero 4K / 4K + video improvements


#185

Sorry. How do I do that?


#186

Click the link to post 127 in this thread.


#187

Thanks, @grahamh!


#188

"If you’ve enabled 10-bit output or you are using the HDR auto-switch option, you should disable this before testing this kernel. "

Could anyone walk me through disabling 10 bit output? I think i still have this set.


#189

Hi

Link t file - https://4kmedia.org/lg-cymatic-jazz-hdr-hlg-uhd-4k-demo/

I;m sure it is only 8 bits - I did not mean banding. Colours are diffrent on 8 and 10 bits in this file.
On krypton this file plays in 10 bits when I ( echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr)
But with no HDR. When I play this file on Leia theres is no HDR and no 10 bits.
When I play this file directly from my TV USB there is HDR and 10 bits.

Krypton works very well withm my Pioneer VSX 932 receiver. It shows correct information about colour and resolution.

I ddn’t try conect Vero directly into TV. When I try this I give You feedback

Best regards


#190

Turn off HDR autoswitching in Settings-Player-videos.
If you have added a line like echo 444,10-bit > /sys/class/amhdmitx/amhdmitx0/attr to rc.local, remove it or comment it with # and reboot.


#191

The answer is in the name. This is a HLG video which is not yet supported by either Kodi or OSMC. Both Leia and Krypton are playing it at 10 bits but the transfer function is wrong, hence the different colours.

We should have HLG support incorporated shortly.


#192

Thx for info

Maybe You could look closer to bug with resolution 3840x2160p and 59,94Hz movies.

When I whitelist 3840x2160p 59,94Hz there are no picture at all when I play 4k hdr 60 fps movies.
Maybe it is my receiver but on Krypton everything was ok.

Best regards


#193

I cannot reproduce this. The whole logic of the whitelisting system seems a bit odd, though. It clearly needs more work.


#195

Thanks. Done that. Video looks great with everything i can throw at it, i did notice i’m getting some skipped frames on “the world in 4k” demo mentioned on this thread though, is that normal? Getting 20-50 skipped frames each playthrough. On a v4k+, wired, no issues with bandwidth.


#196

Are the skips continuous or just at the start?

Sam