[TESTING] Vero 4K / 4K + video improvements


#218

osmc@VERO4K:~$ uname -a
Linux VERO4K 3.14.29-121-osmc #1 SMP Sat Sep 29 05:20:26 UTC 2018 aarch64 GNU/Linux

https://paste.osmc.tv/yiniqiroyu

Martian = Banding
John Wick 2 = Banding
The World in 4k HDR10 = No Banding.

I will now switch back to Sams 119 kernel and do the same test and post logs


#219

osmc@VERO4K:~$ uname -a
Linux VERO4K 3.14.29-119-osmc #1 SMP Wed Sep 12 21:28:17 UTC 2018 aarch64 GNU/Linux

https://paste.osmc.tv/ilagusaqoc

Martian = No Banding
John Wick 2 = No Banding
The World in 4k HDR10 = No Banding


#220

Many thanks. Did you notice whether your TV reported HDR/PQ when there was banding?


#221

TV did enable HDR mode in all cases


#222

And does it report bit-depth?


#223

No sadly not. TV reports “2160p24hzHDR” or “2160p60hzHDR” respectively for all those files regardless of banding or not.
It’s not very detailed


#224

Any chance you can clip out a short bit of Martian which has obvious banding? I can’t reproduce banding on any of the 24Hz clips I have here, but they don’t have big areas of light colour where it would show up.


#225

The Martian bands at 03:35-03:54 where the Sky can be seen in the background.
I can’t take a screenshot of it to show you as I’m sticking with the 119 Kernel which has no banding.

I’m not sure I can clip out a small section from a 10bit HDR file, I don’t know if avidemix (the software I use for cutting/spliting/joining video files) will support it.

I will have a go in the morning and see if it can done. Will update you in the morning.
My wife would not be happy if she heard me creeping around the office at this time starting up my PC etc etc :flushed:


#226

This should cut a chunk out of the file. As there will be issue at the beginning of the “cut” I started at 3 minutes in the sample.

ffmpeg -ss 00:03:00 -i <inputfile> -t 00:02:00 -c copy <outputfile>

#227

Okay i was able to use avidemux, but it doesn’t support TrueHD/Atmos audio so that has been removed from the clip (this shouldn’t effect the test should it ?)

Anyway here is a short clip that would show plenty of banding on the sky in the background on kernel 121 (Kernel 119 has no banding rememeber)

https://drive.google.com/open?id=1I0QGZRwJjNNfQcgwXcDyZ-OqvqAT8Qjl


#228

Right. I get no banding with kernel 121 with that clip so the plot thickens.

I paused the vid and snapped it:

Then if I go echo 8bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr it switches to 8 bits and I get a noticeable difference (look just above the 29 flag):

On my TV (Panasonic) that is typically the difference between 8 and 10 bits. Is this similar to what you are getting? If not, then we need to look elsewhere for the cause of banding.

You can check what bit-depth is being sent to the display with cat /sys/class/amhdmitx/amhdmitx0/config On kernel 121 it should say

cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV422
Colour range: limited
EOTF: HDR10
YCC colour range: limited
PLL clock: 0xc000027b, Vid clock div 0x000a339c
audio config: off
3D config: off

On kernel 119 it should say 10-bit YUV444 and the line PLL clock will be different.

If you are playing around with bitdepths and get blank screen, echo now | sudo tee /sys/class/amhdmitx/amhdmitx0/attr will usually fix it.


#229

@Grahamh I am just out at the moment but I will try and test what you have asked this afternoon when I get back.

But based on the screenshots you have posted my banding is worse than that.
I will have to switch back to Kernel 121 and then take a screen shot to show you what ‘real’ banding is !!!

Edit banding is probably the same, it doesn’t look as bad on a still screenshot as it does in motion

Edit Erroneous removed

Will update later when I get chance to test and take a screenshot


#230

Screenshot probably won’t help but a photo from your phone will.


#231

Very strange - as I said it’s 119 that should be sending 444 and 121 that sends 422.

I can’t recall if you have tried taking the Denon out of the chain. It might give us some clues.


#232

Sorry made a mistake in my previous post.

XB1X I have unchecked “allow 4:2:2” - this removed banding. No idea what this means for the actual output.

Roku+ I have selected 4:2:0 and not 4:2:2 in advanced settings, this seems to give a smoother picture.

Sorry to potentially lead you up a blind alley.
I will be doing some tests on the Vero soon.

And no I haven’t tested without the Denon AVR yet.


#233

Ok so I have just tested (still using Kernel 119) and i can confirm that when it is running 4:4:4 10bit output there is no noticeable banding.
If I force 8bit output then banding appears.

Here are some screens (note had to load to Gdrive as it wouldn’t upload here)
https://drive.google.com/open?id=11_b0GezCoqCZd6iBmyu7KIibVGETIm23

I haven’t loaded kernel 121 again as I don’t think i will have time at the minute.


#234

OK, thanks, I would say that’s exactly what I get. But for me it’s the same whether I’m on 4:4:4 or 4:2:2.

Without the faff of loading 121 kernel, could you try echo 42210bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attrand echo 4228bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr?

Note that after changing the bit depth, just advance the vid a frame or two for it to take effect. Any more than a couple of frames and you risk a blank screen (bug not yet traced).

cat /sys/class/amhdmitx/amhdmitx0/config would be useful for each case as well.


#235

osmc@VERO4K:~$ echo 42210bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
42210bitnow
osmc@VERO4K:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 10-bit
Colourspace: YUV422
Colour range: limited
EOTF: HDR10
PQ colour range: limited
audio config: on
3D config: off
osmc@VERO4K:~$

= Introduces banding

osmc@VERO4K:~$ echo 4228bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr
4228bitnow
osmc@VERO4K:~$ cat /sys/class/amhdmitx/amhdmitx0/config
cur_VIC: 93
VIC: 93 3840x2160p24hz
Colour depth: 8-bit
Colourspace: YUV422
Colour range: limited
EOTF: HDR10
PQ colour range: limited
audio config: on
3D config: off
osmc@VERO4K:~$

=Introduces banding


#236

Just a wild one - how about echo 42212bitnow | blah blah


#237

echo 42212bitnow | sudo tee /sys/class/amhdmitx/amhdmitx0/attr

= Banding