[TESTING] Transmission app


#41

Hello, I also tried to setup transmission from the app store (on a Pi 1st gen), the install process goes smoothly until the “Operations successfully completed” popup, however the application is not installed.
Here are the logs : http://paste.osmc.io/yebahukehe
Thx.


#42

What happens when you run

sudo apt-get update
sudo apt-get install armv6l-transmission-app-osmc

(for Pi1)

or

sudo apt-get update
sudo apt-get install armv7-transmission-app-osmc

For Pi 2 or Vero

S


#43


#44

Third time is the charm. Try through the App Store again this time

S


#45

Great work. thx


#46

Does it work?

Sam


#47

yes
only had to figure out the Problem 403:forbidden
unauthorized ipaddress
Must Change the daemon config


#48

Please can you provide some more information here?

S


#49

now it works, had to change /home/osmc/.config/transmission-daemon/Settings.json

rpc-whitelist enabeld from true to false

thx dir help


#50

Can you send me your Settings.json so we can include it by default?

S


#51

Works for me too (after the settings.json modification). Thanks for your work !


#52

settings.json modified

{
“alt-speed-down”: 50,
“alt-speed-enabled”: false,
“alt-speed-time-begin”: 540,
“alt-speed-time-day”: 127,
“alt-speed-time-enabled”: false,
“alt-speed-time-end”: 1020,
“alt-speed-up”: 50,
“bind-address-ipv4”: “0.0.0.0”,
“bind-address-ipv6”: “::”,
“blocklist-enabled”: false,
“blocklist-url”: “http://www.example.com/blocklist”,
“cache-size-mb”: 2,
“dht-enabled”: false,
“download-dir”: “/home/osmc/Downloads”,
“download-queue-enabled”: true,
“download-queue-size”: 5,
“encryption”: 0,
“idle-seeding-limit”: 30,
“idle-seeding-limit-enabled”: false,
“incomplete-dir”: “/home/osmc/Downloads”,
“incomplete-dir-enabled”: false,
“lpd-enabled”: false,
“message-level”: 1,
“peer-congestion-algorithm”: “”,
“peer-id-ttl-hours”: 6,
“peer-limit-global”: 200,
“peer-limit-per-torrent”: 50,
“peer-port”: 51413,
“peer-port-random-high”: 65535,
“peer-port-random-low”: 49152,
“peer-port-random-on-start”: false,
“peer-socket-tos”: “default”,
“pex-enabled”: false,
“port-forwarding-enabled”: true,
“preallocation”: 1,
“prefetch-enabled”: 0,
“queue-stalled-enabled”: true,
“queue-stalled-minutes”: 30,
“ratio-limit”: 2,
“ratio-limit-enabled”: false,
“rename-partial-files”: true,
“rpc-authentication-required”: false,
“rpc-bind-address”: “0.0.0.0”,
“rpc-enabled”: true,
“rpc-password”: “”,
“rpc-port”: 9091,
“rpc-url”: “/transmission/”,
“rpc-username”: “”,
“rpc-whitelist”: “127.0.0.1”,
“rpc-whitelist-enabled”: false,
“scrape-paused-torrents-enabled”: true,
“script-torrent-done-enabled”: false,
“script-torrent-done-filename”: “”,
“seed-queue-enabled”: false,
“seed-queue-size”: 10,
“speed-limit-down”: 100,
“speed-limit-down-enabled”: false,
“speed-limit-up”: 100,
“speed-limit-up-enabled”: false,
“start-added-torrents”: true,
“trash-original-torrent-files”: false,
“umask”: 18,
“upload-slots-per-torrent”: 14,
“utp-enabled”: true
}


#53

Wouldn’t it be more secure to leave the whitelist enabled, and add your local network to it, wildcards are allowed, so…

“rpc-whitelist”: “127.0.0.1, 192.168.0.*”,

Not sure how best to automate this though, would need updating if local network changed.


#54

No, because OSMC is designed to be behind NAT anyway, so provided this isn’t port forwarded, it will be safe

S


#55

i change “rpc-whitelist-enabled”: false, but after reboot it changes to “true”


#56

You probably need to edit the file while the transmission service is shut down otherwise it overwrites your changes on exit.

Before editing the file issue this command:

sudo systemctl stop transmission.service

Edit your file then reboot. See if that helps. BTW you can also stop/disable transmission via the Services section of OSMC settings.


Transmission Access Denied
Error installing transmission
#57

“rpc-password”: “”,
“rpc-port”: 9091,
“rpc-url”: “/transmission/”,
“rpc-username”: “”,

if i understand this correctly, the username/PW combo should be empty. but if ic call my kodi IP at port 9091 transmission keeps asking me for identification and does not accept it if i just hit Enter twice … anybody has the same problem?

cheers


#58

Look at “rpc-authentication-required”: false,


Password problem with transmission
#59

Having stopped the service manually at the command line and changed my RPC settings, confirmed the app works for me too. Don’t understand the interface options to stop or start the service via OSMC settings, so was trying to “sudo systemctl start transmission-daemon”, and have been led to start reading about masking services but haven’t learned why this would be desirable. If anyone cares to explain why it’s masked, I’d love to learn. Thanks


#60

Thanks, it’s works for me. :smile: