[TESTING] Standby mode for Vero 4K


#41

https://paste.osmc.tv/odexidibew

After more testing, I noticed the behavior I described before only happens if I suspend and then wake up the Vero before the normal screensaver timeout has expired.

If I suspend, then wait until the screensaver timeout, then the first key doesn’t even wake up the Vero. The second key does, and it is correctly swallowed.


#42

Scrap the debug log. I’ve spent some time on this here.

I only need one key to wake Vero 4K as I’d expect.

If I press Suspend via Power menu and hit OK again, I don’t end up being put into suspend. But if I press an arrow key appropriately, the dialog is closed on resume (force all dialogs closed).

Haven’t built this yet.


#43

I’ve built this now. Can you give it a go now?

Sam


#44

Everything is broken now.

Resume from standby, and the screensaver doesn’t kick in, plus only certain keys seem to wake it, but some keys pressed while “asleep” aren’t swallowed.

My first test I hit “OK” twice, and it didn’t wake, then hitting :house: did cause it to wake. The next test, I hit “OK” several times, then some arrows, and finally hitting :information_source: woke it, and I noticed that the arrows had not all been swallowed.

Logs: https://paste.osmc.tv/apogejiwes


#45

We are getting very different results then. I wonder if anyone else can reproduce this.


#46

I don’t use the OSMC skin…I use Titan. I’ll try again with the OSMC skin when I get a chance.


#47

Not sure if that would make a difference but it rules something out.

What screensaver do you use?


#48

Digital Clock…it’s part of the Kodi standard repository.


#49

I tried the OSMC skin, and it didn’t change the behavior.

I had more time to test, though, and found that the “OK” button was the only one that wouldn’t wake the Vero. But, other buttons aren’t being swallowed. You can see it easily if you have added enough items to the menu where “Suspend” appears (I have a custom menu with things like reboot and power off, since I disable the power menu). Just wake with up or down arrows, and you’ll see a different item is highlighted after waking.

Likewise, :back: will wake the system and close the submenu.


#50

Standby works great for me.

Now I just need some way to configure “Kodi callbacks” to do something on enter standby and resume from standby then I am fine.


#51

Are you using the OSMC remote?
I cannot reproduce this behaviour here at all, but have been testing extensively.

I’m using OK to suspend and wake the device


#52

Yes. I have an IR remote configured, but didn’t touch it while testing.

Other than the Titan skin and the screensaver, I don’t think I have any add-ons installed that should be an issue. I do have things like the Universal Movie Scraper, etc., but nothing that should do anything while on the home screen.

I’ll play around some more and see if I can pin it down.


#53

I configured the home key of the Vero remote to send the Vero to standby when pressed on the home page. After a few seconds the Vero wakes up without me doing anything.

I remember this has been working a few kernel/kodi updates back.
Is this currently in a buggy state?


#54

Not unless you’ve updated to the staging repository, which might have some problems.


#55

Yes, I am running on the latest staging repository version.


#56

I made some changes to try and resolve @nabsltd’s issues. It may have caused some regressions.

Sam


#57

The first try worked perfectly except for the screen saver being disabled. Since other people agree on that, and it can be reproduced, it might be good to go back to that and try and figure out that one bug.


#58

Hi Jeff, Marc

Just to give you an update on things.

I’ve reverted things to the way they were before any changes were made.

I’m going to see if I can fix your issue in a less intrusive manner. For now, standby will at least work as it did before.

Cheers

Sam


#59

Thanks. TBH, I only tested it because I was trying to see if I could make the “Power” button on my remote enter standby from any screen. That did work fine, and the behavior was the same as picking the menu item.


#60

I don’t want to drag this off topic, but if I could pick your brain about this some time it would be useful. I would also like to make my IR power button do the same as you are doing. Even a PM with a mini guide as to what you did would be good.

Thanks.