[TESTING] Standby mode for Vero 4K


#21

Well, when I was on LibreELEC on a NUC, the “Turn off display when idle” had a huge impact on the CPU. I mean, Kodi didn’t have to “draw” anything then…

I still haven’t got any answer why this option isn’t available. For me that a better thing then the “fake suspend”…

/Söder


#22

Turning off the display is basically DPMS. It’s important to notice that features on a PC will differ to other devices.

I worked on a small screen saver which turns off the display. You could download this and set the screensaver to any interval. When it runs it will send no signal to your TV. It could be patched further to turn the TV off via CEC


#23

Just to put this into context, I plugged the Vero into my digital power meter today, and once boot-up had settled down, with the Kodi home screen showing on my TV, the Vero was drawing a mighty 2.7W. Based on my electricity tariff per kWh, that works out at around 32p/month for non-stop stand-by use. During playback, power draw was in the region of 3 - 4 W (my blu ray player would be much more). On powering down the Vero, power consumption dropped to 1.3W. So regular use of a suspend mode could indeed save me some money, but it’s going to take a while to save up for those new speakers :slight_smile:

If the suspend mode helps keep my AVR in stand-by that will save me a few more pennies, every little helps.

Also, can I put in a plug for retaining network connectivity in suspend mode - my Vero remote has never been out of its wrapper, as I mainly use the Kodi app on my iPad.


#24

The main request for this feature is the TMDS clock being shut down. I am very much behind this feature. Some users also like the idea of being able to standby.

I can bring down the power consumption a little bit more, but I think it’s safe to say that stopping network activity won’t be one of these methods.

Thanks for your measurements :slight_smile:

Sam


#25

Just tried the Suspend mode, absolutely no change in power consumption, hovering around the 2.6/2.7W level, as per normal.


#26

There will be power saving improvements in the future, but as mentioned, that is not really the goal of this suspend mode.


#27

This is an Intel feature (DPMS)
You could try killing Kodi and running:

echo “standby 0” | cec-client -s

if that works, then we can send the standby signal via CEC to turn off the display. I’m not sure if people would want this by default however.

Sam


#28

Been trying this out since the update.

Vero4k successful goes to suspend when choosing ‘suspend’ from the Menu…

And successfully wakes using any button on the included remote or and RC6 remote.

However i cant get it to suspend using the power toggle button on an RC6 remote like it would do with most other kodi systems.

What this means is i cant get a macro to turn on and off the Vero along with amp display etc


#29

Keymap Editor will probably let you map a button to suspend

Sam


#30

Is this integrated in the latest official update?
Just installed this and it is working as far as i can tell.

Thanks for integrating this, now i can forget again to turn of the tv :wink:


#31

Yes – it’s now in the official update.


#32

When testing my keymap changes for a one-key standby, I found that waking from suspend disables the regular screensaver for me.

I have the screensaver set for one minute, so it’s easy to see that it doesn’t kick in after suspend/wake has happened at least once. The only way that appears to fix it is to change something in the screensaver config.


#33

YES! You could be on to something here. My screensaver stopped working most of the time, but I never thought the new standby could be the cause.


#34

Bingo. Can it be fixed?


#35

Standby hijacks screensaver functionality.

Are you saying that if you standby once and resume, the screensaver (real one) doesn’t kick in properly?


#36

Seems that way. I was stomped for a couple of weeks why Screensaver works sometimes and sometimes not. Only now it has occurred to me that once I reboot the device because the ui is sluggish the Screensaver works until the next suspend.


#37

That’s exactly what I found.

The only way to get the screensaver to kick in normally without a Kodi restart is to change a setting on the screensaver and save it. Even if the “change” is the same value, this seems to work. So, perhaps you could do this in code upon resume…just fetch the screensaver timeout value, and set it right back with the same value.

If that doesn’t work, you could fetch the timeout, set the timeout to the fetched value plus one, then set it again to the fetched value.


#38

After a quick look over, it’s possible that the issue stems from failing to reset m_bScreenSave, a member state variable used to check whether the screensaver is active.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

Sam


#39

This fixed the screensaver not starting after wake-up, but introduced a new bug.

Now, sometimes 2 key presses are required to wake up the Vero 4K. The skin I use has “Suspend” on a widget (as well as the menu), so I can see that the second key press wakes up the system and isn’t swallowed. I used “OK”, then “right arrow”, and the next item in the widget was highlighted when the Vero woke up.

The real problem is that two presses of “OK” cause the Vero to wake up and immediately suspend again, as the second “OK” isn’t swallowed, and activates the “Suspend” again.


#40

I see what you mean. Can you post a debug log of this?

Sam