[TESTING] Kodi 18 (Leia) builds for Vero 2 & 4K


#960

Updated and am getting a :frowning: face cycling around and around.


#961

Also getting sad face boot loop after upgrade to latest version. Downgrading does not solve the issue.

In kodi.log :
ERROR: Failed to load skin ‘skin.osmc.v18alpha’
FATAL: Default skin ‘skin.osmc.v18alpha’ could not be loaded! Terminating…


#962

This was due to the skin being renamed which is now causing the sad face.
You will need to SSH in and run:

mv /home/osmc/.kodi/userdata/addon_data/skin.osmc.v18alpha /home/osmc/.kodi/userdata/addon_data/skin.osmc

Then start up mediacenter:

sudo systemctl start mediacenter


#963

It keeps resetting back to skin.osmc.v18alpha after starting mediacenter again.


#964

I’ve updated my post. Seems this is a better option.


#965

Same error in the log. I even tried to copy the skin and named one skin.osmc and one skin.osmc.v18alpha, no change.


#966

Can you try this. Edit

sudo vi /usr/share/kodi/system/settings/settings.xml

Search for alpha and change the skin name there. I will update my patch for the next build as we hard code it.


#967

Well, that changed the error to

FATAL: Default skin 'skin.osmc' could not be loaded!

I suppose I’ll wait for the next patch.


#968

Anyone having problems with “Up Next” ?

Correctly identifies next episode and plays but only once, the second time it identifies it, counts down then goes back to the menu. The video it plays freezes the first frame for 10 seconds… the audio continues. then the video stops and the video catches up and all is fine.

Does not work with Smart Playlists… identifies next episode but never plays.


#969

I have the same problem that osmc does not start on my vero 4k+ after todays update. I tried copying the skin and editing the settings.xml + downgrading - but still no luck. How can this be solved?


#970

This worked for me.

  • Rename skin folder
  • Edit settings.xml
  • Edit guisettings.xml

#971

Thanx @gmc - but unfortunatelly it still does not work.
renamed skin-folder to skin.osmc (is it correct that there is only a settings.xml in that folder?)
Afterwards I edited
/usr/share/kodi/system/settings/settings.xml
/home/osmc/.kodi/userdata/guisettings.xml
But still get
14:38:28.753 T:4071608928 ERROR: Failed to load skin ‘skin.osmc’
14:38:28.753 T:4071608928 FATAL: Default skin ‘skin.osmc’ could not be loaded! Terminating…
Anything missing? Did you downgrade to an older version os osmc?


#972

Very odd.

You could try downgrade the skin.

sudo apt-get install mediacenter-skin-osmc=17.9.3-37

Or maybe try 17.9.3-36

Also have a look under:
/usr/share/kodi/addons

You should have a skin.osmc folder (Maybe yours is skin.osmc.v18alpha?)


#973

I’m in the same boot loop it seems, but this file editing is beyond me, if I wipe it back to stock, can I install v18 test build but an older one? If so how?


#974

Great: downgrading the skin to 17.9.3-37 works. But be carefull that you DON’T edit settings.xml and guisettings.xml in that case (they have to stay on skin.osmc.v18alpha)


#975

This worked for me also.


#976

Yes, downgrading the skin works!

THANKS


#977

This issue will occur again once the v18 stable release is out. The skin will be named skin.osmc then like it was under v17 as well to ensure a smooth migration for most of our users who’re not using the nightlies… We should find a way to make a transition from the nightlies to the stable release possible with our skin eventually - would be a bummer, if a re-install would be necessary.


#987

OK, so there is a defintely an audio sync problem when using the Up Next plugin that isn’t present on LibreElec… When it tells another episode to play, the first frame freezes and plays audio for 10 seconds, then you get 10 seconds of video with no audio and then it all syncs up…

https://paste.kodi.tv/upekiteyun.kodi


#988

Please paste full logs

Sam