[TESTING] Kodi 18 (Leia) builds for Vero 2 & 4K


#670

Ok, so after a couple of hours of watching content on the Vero this afternoon with no problems I’m now experiencing the crash, restart loop again. I’ve switched on debug and here are the logs:-

https://paste.osmc.tv/aximevegek


#671

Ok, so I’ve narrowed the problem down to one addon. I deleted the Addons27.db file and through trial and error have narrowed the problem down to the Rector Stuff repository, as soon as I enable it OSMC crashes and goes into a crash/restart loop.

https://github.com/rmrector/repository.rector.stuff/raw/master/latest/repository.rector.stuff-latest.zip

This is the repository for the Artwork Beef addon.


#672

It might be an idea to contact the maintainer of this repository and see if anything needs to be done for v18.


#673

17.8.347 Kodi crashes during scanning.
Crash occurs always at the same moment looking at the debug logs:
22:27:13.853 T:3935302384 DEBUG: FindMovie: Searching for ‘Generation War’ using The TVDB scraper (path: ‘/home/osmc/.kodi/addons/metadata.tvdb.com’, content: ‘tvshows’, version: ‘3.0.12’)
22:27:13.866 T:3935302384 DEBUG: scraper: CreateSearchUrl returned https://api.thetvdb.com/login?{“apikey”:“439DFEBA9D3059C6”}|Content-Type=application/json
22:27:13.867 T:3935302384 DEBUG: CurlFile::ParseAndCorrectUrl() adding custom header option ‘Content-Type: application/json’
22:27:13.867 T:3935302384 DEBUG: CurlFile::Open(0xef11ab10) https://api.thetvdb.com/login
22:27:13.867 T:3935302384 INFO: easy_acquire - Created session to https://api.thetvdb.com

Full debug log: full debug log

Edit: after 30+ kodi reboots it suddenly finished scraping and it didn’t crash. Fine I guess :sunny:

Edit 2: after 10m into my episode, crash and new loop. :cloud_with_lightning_and_rain:


#674

wow yes 347 is totally broken - can’t update library and can’t thumbnail youtube videos without crashing


#675

I’ve done a new test build and issues still occur so am trying various builds to see what commit caused the problem.


#676

No problem for me at all


#677

Same problem here; any addon I’ve tried seems to crash when some thumbnails are involved. Amazon VOD, VRT.nu (local TV addon).


#678

There may be something up with the build environment. It doesn’t appear to be a general Kodi thing, nightlies for Windows x64 and LibreELEC are fine.

I compile gmc-18 with a couple of unrelated patches and 346 worked fine, but then I applied apt updates in the chroot and compiled 347 and it crashes.

Then I purged the arm7-toolchain-osmc and removed the ccache, reinstalled the toolchain, and left it to build overnight, and my new 347 is working fine.


#679

Interesting. Thanks for the info. Will give that a shot and see what happens.


#683

Hi
having a problem
addon Tele5 is freezing in
menu selecting movies.

running : 17.8-347

it was working
on: 17.8-345

T


#684

https://kodi.wiki/view/Add-on:Tele5.de

The add-on appears to be broken.


#685

Hey do you remember a while ago I reported that video calibration isn’t getting saved, I did a fresh install of my vero 4k, updated it to the beta version, and I did the video calibration.

After exiting the calibration with back button I could see all the ui without it being cut off around the edges.

Then I did exit -> reboot and when it loaded again I entered video calibration and reset to 0,0

I have make no mods, its a fresh install. Any ideas?


#686

I found this just now

https://forum.kodi.tv/showthread.php?tid=310512

perhaps this is the same thing, if you go to the last page of that thread, it seems the fix was only merged at the beginning of this month, would that be in OSMC builds yet?


#687

That fix was specifically for Windows.

I’ll see if I can replicate. What skin are you using?


#688

Its OSMC skin, everything is default after fresh install and only running the update to Kodi 18 as specified at top of this thread.

Im wondering if its something weird about my TV that causes it to reset.

Let me know if I can provide any logs


#689

Still crashing.

osmc@osmc:~$ grep VERSION_ID /etc/os-release
VERSION_ID="2018.10-1"
osmc@osmc:~$ dpkg -l | grep mediacenter-osmc | awk '{ print $3 }'
17.8-347

#690

just installed the october update and kodi 17.8-347 is still crashing on displaying the thumbnails for most youtube videos and when updating the library, so definitely seems to be the kodi beta specific not an os/kernel issue.


#691

Roll back to 17.8-345, something is wrong with these last two builds.

I’ve been able to build 346 and 347, but it’s tricky. It seems to be a recent update to an SSL lib in the build environment, but I don’t know enough to find the actual fix.


#692

That’s why these builds are still experimental. Please give @gmc some time to resolve this

Sam