[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


#1445

1 suggestion

logs!


#1446

Added link to kodi.log in the original post, thanks.


#1447

There is a fix for this. Will be in the next nightly.


#1448

17.8-375, 18 Dec 2018: Based off OSMC commit (cad46ba08) and newclock5 (fef525b7)

Leia OSMC Skin 17.9.3-26

  • Bugfixes

XBMC:

  • libinput: add support for absolute pointer motion (PR:15032, 1 commit, 3 files changed)
  • OMXPlayerVideo: Send PLAYER_AVCHANGE message when stereo mode changes (PR:15054, 2 commits, 1 file changed)
  • AMLCodec: fix contrast setting (PR:15047, 1 commit, 1 file changed)
  • Screenshot: simplify logic and bail out if no folder is set (PR:15068, 1 commit, 1 file changed)
  • RenderAML: support vertical shift (PR:15045, 1 commit, 1 file changed)
  • [settings] Fix announcement call (PR:15070, 1 commit, 2 files changed)
  • VideoPlayer: release reference to m_pInputStream after usage (PR:15067, 1 commit, 1 file changed)
  • bump to v18.0 rc4 (PR:15075, 1 commit, 1 file changed)
  • [settings] Parser for oldsettings - Fix label settings starting with integers (PR:15072, 1 commit, 1 file changed)

newclock5:
Commits no longer in build:

  • ffmpeg: hevc: Fix for green artefacts (60cb0ab7)
  • OMXPlayerVideo: Fix 3d horizontal/vertical mix up (6ed77ca7)
  • OMXPlayerVideo: Send PLAYER_AVCHANGE message when stereo mode changes (fef525b7)

pvr.hts

  • 4.4.5 - Fix buffer overflow in Logger::Log (PR:388, 1 commit, 4 files changed)

Includes latest addons: inputstream.adaptive (efd4b4f,
+3), inputstream.rtmp (ce7f559), peripheral.joystick (5429dc4), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe, +1), pvr.dvbviewer (cda813e), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts(6a12442), pvr.iptvsimple (90a8d6f), pvr.mediaportal.tvserver (b17fdad), pvr.mythtv (d3a5af2, +3), pvr.nextpvr (ccdfd63), pvr.njoy (4467cac), pvr.octonet(203f800), pvr.pctv (b60b971), pvr.stalker (2245b0d, +1), pvr.teleboy (50689bd), pvr.vbox (6ed2f63), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (1207082), pvr.wmc(81e2090), pvr.zattoo (4688f45), vfs.libarchive (6d39012), vfs.sftp (6749200), pvr.sledovanitv.cz


#1449

Thanks for the update.
I have just installed 17.8-375, but it doesn’t seem to have made a difference.


#1450

Hi,
using 17.8-375 tvheadend (using pvr.hts) does not show live TV any more .

Here’s a log snipped:
"

19:33:57.746 T:1760555760 WARNING: CreateLoader - unsupported protocol(pvr) in pvr://channels/tv/Alle Kanäle/pvr.hts_425687731.tbn
19:33:59.639 T:1487729392 NOTICE: Opening stream: 1001 source: 256
19:33:59.640 T:1487729392 WARNING: OpenStream - Unsupported stream 1001. Stream disabled.
19:33:59.640 T:1487729392 NOTICE: Opening stream: 1002 source: 256
19:33:59.640 T:1487729392 NOTICE: Finding audio codec for: 86018
19:33:59.650 T:1487729392 NOTICE: CDVDAudioCodecFFmpeg::Open() Successful opened audio decoder aac
19:33:59.650 T:1487729392 NOTICE: Creating audio thread
19:33:59.651 T:1479340784 NOTICE: running thread: CVideoPlayerAudio::Process()
19:33:59.652 T:1487729392 NOTICE: Opening stream: 1001 source: 256
19:33:59.652 T:1487729392 WARNING: OpenStream - Unsupported stream 1001. Stream disabled.
19:33:59.652 T:1487729392 NOTICE: Opening stream: 1002 source: 256
"
Any ideas?


#1451

Hi Tobias - is this really not working for you only since 17.8-375?
Because for me the last version to work was 17.8-369 (see my posts above). I would be curious to know if the versions in between really worked for you (and ofc why…)


#1452

I can confirm the last working version was 369 and I get the same log messages posted above. Does it follow that since the errors state a problem with stream 1001, it seems a problem with whatever codec is being used to decode the video - MPEG2VIDEO?

17:14:19.154 T:1420432112 DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - id: 1001, type MPEG2VIDEO, codec: 2
17:14:19.154 T:1420432112 DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - id: 1002, type AC3, codec: 86019
17:14:19.154 T:1420432112 DEBUG: AddOnLog: Tvheadend HTSP Client: pvr.hts - id: 1003, type AC3, codec: 86019


#1453

Same problem for me, tvheadand not working for videos, just radio and epg


#1454

I can confirm the last working version was 369 …

tvheadend does run recorded videos (matroska format).

Live TV (htsp) is broken (no sound, no video).


#1455

Think I found the issue.
PR15010 caused some issues and PR15020 was implemented to fix them.

PR’s were then merged but I still had a patch for 15010 which broke it again. I’ve now removed this so hopefully this fixes the issue in the next build (Won’t be 376 as this build is almost done)

Will be in 377.


#1456

17.8-376, 19 Dec 2018: Based off OSMC commit (10424a4da) and newclock5 (922b68c)

OSMC Skin Leia 17.9.3-27

  • Overlay patch

pvr.hts:

  • 4.4.5 - Fix buffer overflow in Logger::Log (PR:388, 1 commit, 4 files changed)

Includes latest addons: inputstream.adaptive (efd4b4f,
+3), inputstream.rtmp (ce7f559), peripheral.joystick (5429dc4), peripheral.xarcade (f09a0e7), pvr.argustv (83aa1e9), pvr.demo (964686d), pvr.dvblink (4ae42fe, +1), pvr.dvbviewer (cda813e), pvr.filmon (e850633), pvr.hdhomerun (a9d7309), pvr.hts(6a12442), pvr.iptvsimple (90a8d6f), pvr.mediaportal.tvserver (b17fdad), pvr.mythtv (d3a5af2, +3), pvr.nextpvr (ccdfd63), pvr.njoy (4467cac), pvr.octonet(203f800), pvr.pctv (b60b971), pvr.stalker (2245b0d, +1), pvr.teleboy (50689bd), pvr.vbox (6ed2f63), pvr.vdr.vnsi (cbb75ab), pvr.vuplus (1207082), pvr.wmc(81e2090), pvr.zattoo (4688f45), vfs.libarchive (6d39012), vfs.sftp (6749200), pvr.sledovanitv.cz


#1463

Any updates on the green artifacts when playing HEVC, or a workaround perhaps? Much appreciated!


#1464

Which version did you start having the problems on? If you go back to the previous version does it fix it?


#1465

I have had the problem since I upgraded to Leia; I’ve tried 370 and 374 and higher. Thanks


#1466

Ok, thought it was due to a recent change.
Is it happening with all movies? Can you upload a sample?


#1467

Sure: one minute sample here (mediainfo here).
And yes, it seems to happen with every HEVC file.


#1468

Link is not valid. I get a 404


#1469

My bad, just updated the link, please try again.


#1470

Cool, working. I’ll run a few tests.