[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


Wow great News. Thank you so much.


This might be a bit OT here, but how would I access that?


When its in the next build you need to run the nightly builds and then under Addons you need to enable ScummVM


17.8-177, 16 Feb 2018: Based off OSMC commit (b340ead91) and newclock5 (7283b1)


  • Include addon game.libretro.scummvm


  • [uPnP] Content-Disposition Header (PR:13520, 1 commit, 1 file changed)
  • FreeBSD fixes (PR:13532, 8 commits, 19 files changed)
  • FIX: [3D;win] initialize 3D flags in renderer (PR:13543, 1 commit, 1 file changed)
  • [cleanup] FreeBSD 8 is EOL & move FreeBSDGNUReplacements include (PR:13544, 2 commits, 4 files changed)
  • DVDVideoCodecAmlogic: remove pts-based frame rate tracking (PR:13539, 2 commits, 2 files changed)
  • [cleanup][windows] remove system.h defines & includes (PR:13545, 4 commits, 31 files changed)
  • [wayland] Move EGL context attribs to winsys context, add GL fallback (PR:13527, 1 commit, 9 files changed)


  • [Game API] Update to v1.0.36: Controller topology (#13499)

New commits in this build:

  • ffmpeg: hevc: Fix artifacts if bright scenes (43cdd5dd)

Includes latest addons: inputstream.adaptive (b28d3f0), inputstream.rtmp (b3ffc49), peripheral.joystick (02da6ed, +4), pvr.argustv (a4d3ec7), pvr.demo (8f62053, +1), pvr.dvblink (89d1687, +1), pvr.dvbviewer (64c4356, +1), pvr.filmon(2721611, +1), pvr.hdhomerun (7379fbc), pvr.hts (095784b, +1), pvr.iptvsimple (933a5c4, +1), pvr.mediaportal.tvserver (dec444f, +2), pvr.mythtv (3200b09), pvr.nextpvr (aa1c8d2, +1), pvr.njoy (67b837d), pvr.octonet (689afbf), pvr.pctv(5b47d9f, +1), pvr.stalker (77eec69, +1), pvr.teleboy (3ae0297), pvr.vbox (57f3198, +1), pvr.vdr.vnsi (4db947c), pvr.vuplus (f05f158, +1), pvr.wmc (38e670a, +1), pvr.zattoo (3c46173, +1), vfs.libarchive (128394c, +3)


Dear OSMC-Team,

I keep having problems with playing some Amazon Prime videos. I post this here, since I’m not sure, what actually causes the issue (InputStream, the addon, Kodi itself…).
Most videos play fine. But some play with a broken video stream (see picture); audio is always OK.

This issue even occurs for different episodes within the same season. E.g. Elementary, Season 2, Episode 4 (German title: “Späte Bestrafung”) works fine, while Episode 5 (“Schwarzes Herz”) doesn’t.

I’ve uploaded the Kodi-Log here: http://paste.osmc.tv/ayifavahin

Just search for “Bestrafung” to find the example, which works and for “Schwarzes” for the one with the broken video stream.

Thanks in advance for your help!


you need to disable the OMX Player


Thanks for your quick reply.
I’ve disabled the OMX Player in the player settings. Unfortunately, this does not solve the problem. What has changed:
The formerly greenish video is now black and stops after a few seconds.


This is maybe a problem with the audio stream. After you start the video and the screen is black you need to change the audio stream to a 5.1 stream. Then it should work.


Is this reproducible, i.e. is it always the same episodes that are failing? I’ve had some instances (with an earlier OSMC build) where videos would sometimes start with sound only but would usually run fine on the second or third attempt.

I can give episode 5 a try on my system if you like, to see whether it’s a general problem.


Yes, it’s absolutely reproducible: Always the same episodes and the problem has been there for weeks and several versions of Kodi 18 alpha.
For the 3 seasons of elementary, I’d estimate that about 25…35 % of all episodes are affected.

@hedeon: There is no 5.1 audio stream available, when the video is playing. That’s strange, because the preview information (before starting the video) says, it’s 5.1

One more thing I’ve found: For the videos that are playing correctly, I could change the Deinterlace-Method. This option is not available for the broken videos.


I just checked: Both episodes 4 and 5 play on my Pi 3.


Thanks for testing. Hmm…strange…
Any ideas on how I could analyze this issue further?


One thing that comes to mind (although it shouldn’t in 2018) is that the video that doesn’t play has an Umlaut in its title. What about the other videos that don’t play?

If it’s not that, I can only think of two things:

  • Try to get a minimal debug log of both a working and a failing video starting and compare them line by line.
  • Ask in the release thread for the Plugin (on another forum, don’t know whether I’m allowed to link there).


On my Pi3 these episodes also play fine.
Have you update the firmware files like @Manul wrote some posts above?


I faced the issue also. After updating the firmware with the files from Manul, Amazon VDO files are playing again fine


Thanks a lot, that works!
Memo to myself: I should not rely on the search (because the search terms might be not suitable…), but read through the whole thread. Lessons learned. :roll_eyes: Sorry!


I’m seeing the same errors when using netflix/amazon vod plugins and it appears to be related to the version of libwidevinecdm.so installed. Here are my finding, hoping that it helps to track down the root cause:

With libwidevine.so from “http://odroidxu.leeharris.me.uk/xu3/chromium-widevine-

  • Playing videos using netflix plugin works fine
  • Playing videos using amazon vod plugin fails because it fails to get the licenses, amazon appears to require a newer version of libwidevine.so and the plugin offers to update (using inputstreamhelper)

With libwiedevine obtained by inputstreamhelper (obtained from latest chromeos recovery image)

  • Playing videos using amazon plugin always yields the error described by tdoe
  • Playing videos using the netflix plugin yields the same error.
  • See https://paste.osmc.tv/oxuxuhorib for logs


With these firmware files (either wait for OSMC February update or download them manually): [TESTING] Kodi 18 (Leia) builds for Raspberry Pi
and the most recent libwidevinecdm.so from inputstreamhelper everything should work.


17.8-178, 19 Feb 2018: Based off OSMC commit (b5f982b) and newclock5 (fb2c927)


  • [Estuary] - fix info display for sets (PR:13530, 1 commit, 4 files changed)
  • RetroPlayer: GL(ES) don’t hardcode pixelformats (PR:13504, 3 commits, 23 files changed)
  • Python: Normalize Python exception before processing (PR:13554, 1 commit, 1 file changed)
  • RetroPlayer: Move and document GUI code (PR:13553, 2 commits, 32 files changed)
  • [cleanup] remove unnecessary PlatformInclude.h & system.h includes (PR:13550, 4 commits, 295 files changed)
  • amlcodec: reduce video decoder pre-buffering time, pre-buffer more only when decoder is busy (PR:13541, 1 commit, 1 file changed)


  • [android] Add buttonmap for Xbox One S wireless controller (PR:139, 1 commit, 1 file changed)


New commits in this build:

  • paplayer (vp): fix out-of-bounds error in audiocodec passthrough (83ae5402)
  • fixup: MVC: remove SAFE_DELETE (fb2c9271)

Commits no longer in build:

  • FIX: [3D] broken since awhile (cc959ab1)

Includes latest addons: inputstream.adaptive (b28d3f0), inputstream.rtmp (b3ffc49), peripheral.joystick (12e7d52, +1), pvr.argustv (a4d3ec7), pvr.demo (8f62053), pvr.dvblink (89d1687), pvr.dvbviewer (64c4356), pvr.filmon (2721611), pvr.hdhomerun (7379fbc), pvr.hts (095784b), pvr.iptvsimple (933a5c4), pvr.mediaportal.tvserver (dec444f), pvr.mythtv (3200b09), pvr.nextpvr (aa1c8d2), pvr.njoy (67b837d), pvr.octonet (689afbf), pvr.pctv (5b47d9f), pvr.stalker (77eec69), pvr.teleboy (3ae0297), pvr.vbox (57f3198), pvr.vdr.vnsi (4db947c), pvr.vuplus (f05f158), pvr.wmc (38e670a), pvr.zattoo (3c46173), vfs.libarchive (128394c)


@Manul Do you know, what exactly is changed by the new start_x.elf and fixup_x.dat you mentioned in your post above?
Reason, why I’m asking: They fixed my problem with playing Amazon Prime videos.
But since I updated these files, I experience significant performance issues… Some further information on this:
I use (misuse :sweat_smile:) my OSMC installation as multi-purpose home server. There are some additional services running besides Kodi, such as a couple of samba shares and a NextCloud installation. Therefore, I had to create some SWAP memory, because the RAM of the PI 3 was not sufficient. The SWAP is distributed to the SD card and a USB drive to allow parallel access for (a bit) better performance. It has worked like that for more than a year…not super fast, but sufficient for my needs. After updating the aforementioned files the system often gets stuck for long (5…20 min) at super high loads (> 50). The boot time more than tripled…
The reason seems to be that kswapd is reorganizing the memory over and over. This freezes the system because of the limited I/O-performance of the SWAP drives (> 95% wait). I haven’t had such effects before the update. Therefore, my question: Have there been any changes in the way the memory is accessed or any other things, which could explain these effects?
It is reproducible. I changed the fies for the old ones from a backup --> speed as usual and back again --> performance issues.
Thanks a lot in advance for your help!