[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


#672

finally got it to work! thank u thank u!!!

updating to stretch took quite long, keep on seeing the “sad” face after updating (on 136), then i manually updated to 156 and finally got into osmc gui.

:+1:


#673

Is pvr.mythtv in the latest build? I decided to try out Leia in the latest nightly build (coming from the stable version) only to find pvr.mythtv missing. I did a bit of digging and it looks like it might have been removed back in Sep '17 and never re-added (based on this change in commit #da91b1d). Is this the case, or am I looking at the wrong thing.


#674

Last build post seems to indicate it is. Did you enable it in the addon browser?


#675

That’s the thing… it’s not listed in Add-ons --> PVR clients.


#676

I’ve just checked the build script and it is indeed missing. I’ll re-add to the next nightly is its building successfully.


#677

17.8-158, 10 Jan 2018: Based off OSMC commit (cb88c8a) and newclock5 (28fcdeca0)

OSMC:

  • Update patch to reflect armv7 instead of arm (3f7d7ac). Netflix addon needs to be tested after this a it might break it.

XBMC:

  • [PVR] Fix crashes on pvr client addon install/uninstall/update. (PR:13335, 1 commit, 3 files changed)
  • AE: register setting handlers inside ActiveAE (PR:13334, 1 commit, 7 files changed)
  • FIX: [droid] “Attempt to remove non-JNI local” messages (PR:13330, 1 commit, 9 files changed)
  • [PVR][Estuary] PVRInfoPanel: Add percent played progress bar, for exa (PR:13338, 1 commit, 1 file changed)

pvr.hts[/url]:

  • Fixed crashes on addon destruction. (PR:348, 1 commit, 5 files changed)

Includes latest addons: inputstream.adaptive (fb0ca21), inputstream.rtmp (482f5c1), peripheral.joystick (3a93486), pvr.argustv (a4d3ec7), pvr.demo (0224cbd, +1), pvr.dvblink (4ac2f2d), pvr.dvbviewer (c2275e1), pvr.filmon (e754b4b), pvr.hdhomerun (7379fbc), pvr.hts (e5e89b1, +5), pvr.iptvsimple (a768d0e), pvr.mediaportal.tvserver (dcf0512), pvr.nextpvr (11dfdbb), pvr.njoy (67b837d), pvr.octonet (c4af00a), pvr.pctv (c7a13d7), pvr.stalker (c91421d), pvr.teleboy (3ae0297), pvr.vbox (24126fd), pvr.vdr.vnsi (66050a9, +1), pvr.vuplus (020e1d2), pvr.wmc (920ade6), pvr.zattoo (4940bcc), vfs.libarchive (568a2a1)[/b]


#678

@gmc

I have updated. Mine didn’t break it.

Also, it may be premature to tell. But since the build before Christmas day, when I first installed, this one seems to put less strain on the CPUs of my RPi3 while playing Netflix. I didn’t get a single temperature notification.

On a side note. I wonder, is there any possibility to someday use HW decoding instead of SW on the Kodi Netflix addon?


#680

Getting this in update:

Err:5 http://ftp.fau.de/osmc/osmc/download/dev/gmc-18748 gmc-18 Release
404 Not Found

Ouch, copying the link from first post also copy the number of people who clicked the link…


#681

Seems to be a common problem. I’ve changed the formatting :slight_smile:


#682

17.8-159, 12 Jan 2018: Based off OSMC commit (01a741) and newclock5 (d6e5222d5)

OSMC:

  • Vero 4K: make helper routines V4K only for now (29cca69)
  • Add dependency for libnspr4 libnss3 (1d4626c)

XBMC:

  • Just kidding, remove controller models (PR:13316, 3 commits, 26 files changed)
  • release application player if new type does not match old one (PR:13337, 1 commit, 1 file changed)
  • [RFC] Get rid of frames-(m)sec conversion (PR:13288, 6 commits, 18 files changed)
  • Allow video scrapers/NFO files/library import to add any artwork type (PR:12612, 1 commit, 2 files changed)
  • changed: improve iterate variable names and a switch to for each (PR:13342, 1 commit, 1 file changed)
  • [cmake] move ifdef conditions to cmake (PR:13336, 4 commits, 34 files changed)
  • fixed: use visible, not hidden (PR:13343, 1 commit, 1 file changed)
  • VideoPlayer: fix audio/subtitle delay (PR:13345, 1 commit, 1 file changed)

newclock5:
New commits in this build:

  • fixup: CStereoscopicsManager reduce logging spam (e3d49aa4)
  • fixup: Fix compile with gcc 4.9.3 (d6e5222d)

Includes latest addons: inputstream.adaptive (fb0ca21), inputstream.rtmp (482f5c1), peripheral.joystick (3a93486), pvr.argustv (a4d3ec7), pvr.demo (0224cbd, +1), pvr.dvblink (4ac2f2d), pvr.dvbviewer (c2275e1), pvr.filmon (e754b4b), pvr.hdhomerun (7379fbc), pvr.hts (e5e89b1, +5), pvr.iptvsimple (a768d0e), pvr.mediaportal.tvserver (dcf0512), pvr.nextpvr (11dfdbb), pvr.njoy (67b837d), pvr.octonet (c4af00a), pvr.pctv (c7a13d7), [url=https://github.com/kodi-pvr/pvr.stalker]pvr.stalker/url, pvr.teleboy (3ae0297), pvr.vbox (24126fd), pvr.vdr.vnsi (66050a9, +1), pvr.vuplus (020e1d2), pvr.wmc (920ade6), pvr.zattoo (4940bcc), [url=https://github.com/notspiff/vfs.libarchive]vfs.libarchive/url


#685

17.8-160, 13 Jan 2018: Based off OSMC commit (9f91aa5e) and newclock5 (8fa588c)

OSMC:

  • Re-add pvr.mythtv (9f91aa5e2)

XBMC:

  • [fix] boolean condition window.is does not work properly (PR:13346, 1 commit, 1 file changed)
  • [depends] bump python27 to 2.7.14 (PR:13328, 4 commits, 13 files changed)
  • Update RetroPlayer’s Render Manager documentation (PR:13341, 2 commits, 3 files changed)
  • RendererDRMPRIME: add atomic support (PR:13192, 4 commits, 11 files changed)

pvr.vdr.vnsi:

  • fix osd for legacy OpenGL (4db947c)

newclock5:

New commits in this build:

  • Revert “[bluray] Update libbluray to version 1.0.2.” (8fa588c4)

#686

Since upgrading to version 156 I can’t get any sound when watching movies or tv series. Currently running 159 and the debug log is from starting a movie, the movie starts playing but with no sound.
Running the same movie in Kodi v18 nightlies on a Mac works without any issues.

If I play music then I get sound and the sound from the interface is also coming thru.

Debug log https://paste.osmc.tv/iduhaqepob

Any suggestions as to what might be the cause?


#687

Can you enable debug logging.

If you go back to 155 does it fix the problem?


#688

I’ll give it a try. Wasn’t the log I provided debug?


#689

Nope, it was a normal log file. You need to enable debug logging. See first post.


#690

Hi!
I’ve exactly the same issue on my RP3 like @haegg78 .

I’ve enabled Debug-Logging and played a movie (“Die Chroniken von Narnia” --> you can search the logfile for it to find the relevant part). Here is the log:

https://paste.ubuntu.com/26382936/

The on-screen player info displayed this information while playing the movie:
Video-Decoder: omx-h264 (HW)
Audio-Stream: FL, FR, FC, LFE, SL, SR, dca, 32 bits, 48,000 Hz

Downgrading to 155 (via sudo apt-get install rbp2-mediacenter-osmc=17.8-155) fixes the problem: Sound is back! The on-screen player info shows the same data as mentioned above.


#691

Hopefully now this is a debug log, think the “debug” setting has changed since the last version. You now had to select all the components also and not just enable logging.
I played the movie Cobain: Montage of Heck and I’m on a RBP1 device.

Debug log with issue: https://paste.osmc.tv/wevuwoheco
Debug log with 155 (working): https://paste.osmc.tv/paqonebaxo


#692

Thanks for the logs. Not seeing anything issues.

Looking through the changelog for 156 there was a change for ActiveAESink.

Are you using audio passthrough? What options do you have set?

@haegg78 Still no debugging I’m afraid. Would also help to check the passthrough settings.

08:29:59.460 T:2989419392 NOTICE: Disabled debug logging due to GUI setting. Level 0.

Even with no component logging enabled and just debug logging used your kodi.log file will include tons of DEBUG: lines

You could also try and force logging using the advancedsetting xml file:

http://kodi.wiki/view/Log_file/Advanced#Turn_on_debugging_using_a_file_.28advancedsettings.xml.29


#693

Screenshot of my audio settings, no passthrough:

Debug log with version 160: https://paste.osmc.tv/uvofoficuj

Still no audio.


#694

@sam_nazarko any idea on this one? I can’t replicate the issue but 2 users having the same problem so far.