[TESTING] Kodi 18 (Leia) builds for Raspberry Pi


#591

Sorry, copy and paste error. That was the debug package. Try this:

wget http://kodi.gjmccarthy.co.uk/Nov2017/rbp2-mediacenter-osmc-25112017.deb -O /tmp/rbp2-mediacenter-osmc-25112017.deb
sudo dpkg -i /tmp/rbp2-mediacenter-osmc-25112017.deb

#592

You will need to reinstall your system if you tried to install a build before updating to Stretch.


#593

@sam_nazarko: the funny thing is the Leia build was working under old version of Debian.
After @gmc’s suggestion I’ve almost updated the OS to Stretch.
The only issue right now is ca-certificates, but after installing the package separatly the update is now in progress.
I will update this topic once it’s successful (or not :wink: ).
I keep my finger crossed so that fresh installation of the OS is not needed.


#594

That’s because Leia builds have only depended on Debian Stretch very recently.


#595

Now running Stretch and Leia with video inputstreams loaded and enabled with no errors. Loaded Netflix addon but get an error.

Log at https://paste.osmc.tv/ehekodabuw

The Netflix zip file loaded is from here downloaded a week ago.

https://github.com/asciidisco/plugin.video.netflix/archive/master.zip

Is this an issue or have I missed something building the system.

Process followed is from a clean install OSMC , upgrade to Stretch, upgrade to Leia, add media keys, load netflix from zip.

Thanks


#596

You mayneed to uninstall the Netflix add-on and reinstall it.

Sam


#597

Tried uninstall and reinstall. This time actually reinstalled the repo rather than just the plug-in and installing from the repo. Same problem arises.

Log after this failure.

https://paste.osmc/tv/ucuvahixol

when installing from repo kicked up a message window stating adaptive not installed and cryptodome not installed (or similar but didn’t screen capture precise wording) Cryptodome is the problem when trying to run Netflix after the install is complete albeit with errors.

You’ll see a few warnings not associated with Netflix problem early in log. I do not think these are related to the netflix issue but are related to an issue with where you access “Install from Zip File” within the skin. (works when menu accessed via the little box icon top left of screen but nothing happens when you click on big icon on the Addons screen.


#598

Suggest to restart from scratch and follow these steps (worked for me).


#599

Thanks

I always start from scratch following below process. I note you have an additional instruction after adding gpg.key during Kodi upgrade which appears to start up a crypo service but ends with Crypto for “netflix plugin: sudo …” This looks to be related to my issue. What comes after Crypto for netflix plugin: sudo …

Process followed

Burn OSMC (2017.10.1)
• Selecting Pi2/WiFi
• Boot & Config country etc.
• sudo apt-get update && sudo apt-get dist-upgrade

Upgrade to Stretch
• /etc/apt/sources.list deb http://apt.osmc.tv jessie-devel main
• Update via My OSMC (might need to do this more than once)

Upgrade to Kodi 18
• /etc.apt/sources.list deb http://download.osmc.tv/dev/gmc-18 gmc-18 main
• Import gpg Certificate wget -qO - http://download.osmc.tv/dev/gmc-18/gpg.key | sudo apt-key add –
• sudo apt-get update && sudo apt-get dist-upgrade (this will install latest nightly)

Config Kodi 18
• Set screen size
• Ensured videoplayer inputstream enabled (adaptive and RTMP)
• Add additional media keys
• Rolled SMB back to V1 (this just lets me use my NAS for file transfers between operating systems)

Install Netflix
• Downloaded repository
• Added repository
• Installed Netflix
• posted error log


#600

@gmc Let’s talk about the dependency issues in Slack. There should be a way to present them as satisfied to Kodi and the add-on.

Sam


#601

Did you open the post I linked? Click on “Can I use Netflix on my Raspy OSMC”!!!
All clearly explained there!


#602

Now I have :grinning:

Cheers, Ill amend my process.


#603

@sam_nazarko: After successful upgrade Kodi works without any issue, so reinstallation was not needed :slight_smile:
Thanks guys once again for your support and help!


#604

Is there estimative when the 17.8-152 build will be available?

I’m eager to try it. Lost my sound with the 17.8-150/151.


#605

I am on 136 trying to download the newest .
sudo apt-get update

W: Failed to fetch http://download.osmc.tv/dev/gmc-18/./Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
osmc@osmc:~$


#606

@Rickt1962 There has been some changes in how to get Leila, first post describes how to get leila now. And remember you need stretch nowerdays.


#607

Here is what I have for source

eb http://ftp.debian.org/debian jessie main contrib non-free

deb http://ftp.debian.org/debian/ jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free

deb http://apt.osmc.tv jessie main

deb http://download.osmc.tv/dev/gmc-18 ./


#608

You are clearly not reading the top post. You MUST install stretch to move forward on Leia.


#609

Hopefully within the next few days. There are some cmake build issues due to the latest commits.


#610

game.libretro Unavailable?

I’ve been trying to get emulation to work, specifically NES, but am not succeeding. I go to Add-ons>My add-ons>Game add-ons>Emulators and enable one the the NES emulators. After enabling one you can go to Dependencies which show two: NES Controller and game.libretro. NES Controller v 1.0.0 is installed but it says that game.libretro is Unavailable. I’ve checked multiple different emulators, for different systems, and they all say that game.libretro is missing.

Debug log output after enabling the NES/Famicom(Quickness) emulator is as follows:
18:06:56.051 T:1924702208 WARNING: CAddonMgr: ‘game.libretro’ required by ‘game.libretro.quicknes’ is missing. Add-on may not function correctly
18:06:56.082 T:1924702208 DEBUG: CAddonMgr: enabled game.libretro.quicknes
18:06:56.082 T:1538257664 DEBUG: CBinaryAddonManager::EnableEvent: Enable addon ‘game.libretro.quicknes’ on binary addon manager
18:06:56.232 T:1924702208 DEBUG: CGUIMediaWindow::GetDirectory (addons://user/category.emulators)
18:06:56.232 T:1924702208 DEBUG: ParentPath = [addons://user/category.emulators]
18:06:56.368 T:1538257664 DEBUG: CAddonMgr::GetAvailableUpdates took 66 ms
18:06:56.392 T:1469797120 DEBUG: Thread BackgroundLoader start, auto delete: false
18:06:56.395 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.4do/icon.png
18:06:56.395 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.cap32/icon.png
18:06:56.397 T:1538257664 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.hatari/icon.png
18:06:56.401 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.lutro/icon.png
18:06:56.402 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.fmsx/icon.png
18:06:56.403 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.o2em/icon.png
18:06:56.404 T:1538257664 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.beetle-pcfx/icon.png
18:06:56.406 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.pokemini/icon.png
18:06:56.410 T:1538257664 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.vecx/icon.png
18:06:56.411 T:1469797120 DEBUG: Thread BackgroundLoader 1469797120 terminating
18:06:56.411 T:1486889728 DEBUG: GetImageHash - unable to stat url /usr/share/kodi/addons/game.libretro.fuse/icon.png

Do we have to build game.libretro ourselves or is there someway to enable it that I am missing?