[TESTING] Kodi 17 test builds for Raspberry Pi


#142

Skin issue report that to the skin creator not a Kodi 17 bug


#143

My wildest guess is here that you have a different build of v17 on your PC than on the PI. Would suggest to wait till GMC posts a new updated build after he sorted out the current issue he faces.


#144

Hopefully the builds will be going again soon. There have been quite a few fixes for the Estuary skin.


#145

is it possible to build without the blueray lib at the time until a patch is made ?


#146

I think the skin is assuming it’s already downloaded. You can use the wrench icon and tick ‘download sub’


#147

Builds are going again. Should have it completed within the next few hours :smiley:


#148

Seems like Retroplayer is being pushed back to Kodi 18 but its good to hear that the builds are going again


#149

Ok, just checked. On the PI it says Estuary skin is version 0.5.0 and on PC its 0.7.1. However when I try updating the skin on the Pi, it says there are no updates. So my conclusion is that the skin is updated with the PI builds, and not separately regardless of the kodi version.


#150

For the latest build see the first post

16.8-042, 04 March 2016: Based off OSMC commit (cb763d4) and newclock5 commit (6dcbf2af)

Build Highlights

  • Confluence skin has now been retired and replaced with Estuary. This is now the default skin in the nightlies.

  • For current builds DVD playback remains temporarily disabled

  • Estuary updates (additional colour themes)

  • Includes pkg patch: # Quick fix for libdvd build issues


RPi1:

wget http://download.osmc.tv/dev/gmc/rbp1-mediacenter-osmc-04032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

RPi2:

wget http://download.osmc.tv/dev/gmc/rbp2-mediacenter-osmc-04032016.deb   -O /tmp/kodi.deb && sudo dpkg -i /tmp/kodi.deb && sudo systemctl start mediacenter

#151

I just tried the new build and it breaks CEC control. I found the problem already.

kodi.log reported
03:18:07 12.709553 T:1959215664 ERROR: Unable to load libcec.so.3.0, reason: libcec.so.3.0: cannot open shared object file: No such file or directory

So I found that that file didn’t exist in /usr/osmc/lib/ so I just created a symlink to libcec.so.3.0.1 and rebooted which fixed it.


[TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)
#152

did you actually take the time to read the opening post perhaps testing aint your strong suit


#153

Yes I did read the first post, and I just read it again to see what I missed then even did a search for cec and I still don’t see any mention of cec changing in this build.

I know that these test builds required a updated cec before but I’m only moving from the previous 042 build and already had that updated cec version installed.

Point me to a quote of what I missed in the first post please.


#154

Seems that info was removed sry but still your CEC version should be in anycase

sudo dpkg -l | grep libcec | awk '{ print $3 }'
3.0.1-14

#155

Yes and that is what I have.


#156

wierd cause my logs doesnt have those entries still you might be on to something

ATTN @gmc might be worth checking out why some users gets that and other don’t

osmc@osmc:~$ls /usr/osmc/lib/
libbluray.a   libbluray.so.1      libcec.so.3      libshairplay.a   libshairplay.so.0      libsqlite3.la    libsqlite3.so.0.8.6
libbluray.la  libbluray.so.1.9.2  libcec.so.3.0    libshairplay.la  libshairplay.so.0.0.0  libsqlite3.so    pkgconfig
libbluray.so  libcec.so           libcec.so.3.0.1  libshairplay.so  libsqlite3.a           libsqlite3.so.0  python2.7

this is what i had per default


#157

Strange why I didn’t have the file and I just finished upgrading a second Pi 2 to the newest nightly and it was the same.

Also I noted that the deb does not provide the libcec.so.3.0 file as shown here

osmc@osmc:~$dpkg -L rbp2-libcec-osmc
/.
/usr
/usr/osmc
/usr/osmc/bin
/usr/osmc/bin/pyCecClient.py
/usr/osmc/bin/cecc-client-3.0.1
/usr/osmc/bin/cec-client-3.0.1
/usr/osmc/lib
/usr/osmc/lib/python2.7
/usr/osmc/lib/python2.7/dist-packages
/usr/osmc/lib/python2.7/dist-packages/cec
/usr/osmc/lib/python2.7/dist-packages/cec/init.py
/usr/osmc/lib/python2.7/dist-packages/cec/_cec.so
/usr/osmc/lib/pkgconfig
/usr/osmc/lib/pkgconfig/libcec.pc
/usr/osmc/lib/libcec.so.3.0.1
/usr/osmc/bin/cec-client
/usr/osmc/bin/cecc-client
/usr/osmc/lib/libcec.so.3
/usr/osmc/lib/libcec.so


#158

indeed well atleast its reported good catch ! kinda get used to users not reading the documentation and then reporting stuff when there is a fix already provided (see posts above)


#159

Thanks. Will look into it.


#160

Excellent, a new contruccion!! thank you for the great work !!!.
I have the same problem as Shadow, but i generate a symlink and works perfectly .
again , thanks to everyone !.


#161

Its a really odd one with the libcec.so.3.0 file missing. I’ve rebuild my Pi1 and Pi2 with latest stable version installed the latest nightly. No libcec issues. Wonder if its a issue from one of the upgrades.

Hopefully these kind of problems will be sorted out when we have a apt in place which will then auto install all the correct dependencies.