[TESTING] Kodi 17 (Krypton) builds for Raspberry Pi (continued)


#801

16.8-187, 11 Nov 2016: Based off OSMC commit (b9120ae19) and newclock5 (b4ce16c47)

XBMC:
[guiinfo][pvr] Fix LISTITEM_RESUMABLE to prefer recording info tag over video info tag, fire recordings updated event on playcount change" (PR:10899, 1 commit, 2 files changed)
[cmake] Fix issue with PLATFORM_OVERRIDE (on linux) (PR:10897, 2 commits, 5 files changed)

pvr.vbox:
Added reminders (popup only) to EPG+channels menus (PR:150, 2 commits, 12 files changed)


#802

tried 186 too same issue

http://paste.osmc.io/kofikiyifi

debug enabled.


#803

tried 188 same result

http://paste.osmc.io/keqopuyago

debug enabled

ATTN @sam_nazarko


#804

Yes, It is but still not working :frowning:

11:50:08.827 T:1958178816 ERROR: CGUITextureManager::GetTexturePath: could not find texture ''
11:50:08.829 T:1958178816 ERROR: CGUITextureManager::GetTexturePath: could not find texture ''
11:50:08.831 T:1958178816 ERROR: CGUITextureManager::GetTexturePath: could not find texture ''
11:50:08.832 T:1958178816 ERROR: CGUITextureManager::GetTexturePath: could not find texture ''
11:50:09.950 T:1294988272 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
11:52:25.711 T:1463809008 WARNING: Previous line repeats 4 times.


#805

After upgrading to .188 I keep getting bootloops and Lodi won’t start up into GUI. .187 worked fine, video and audio, too.

Downgrading to .187 and even to .185 worked but did not resolve the boot loops.

Will try out some more things. Seems to be related to my installation …

Eriol


#806

thanks Eriol for the lovely description though a simple debug log seems to be too much to ask for so that developers can actually compare crashlogs for a proper patch so tnx again for just adding random noise to the thread complains about your broken installation.


#807

My understanding is he thinks it may be local to his installation; so let’s see if he can solve things himself first.

Calm down.


#808

Sorry @Toast I thought that since this is a general problem, i do not have to provide log, but here you go.

http://paste.osmc.io/ikewegiqic

Basically, none of my SVCD Iso-s none of the DVD5 iso-s , none of the DVD 9 iso-s are working, while all the BluRay ISO-s are working well.

All the SVCD, DVD5, DVD9 iso-s where working with Kodi 16.


#809

so now you can fix the problem @Toast …always screaming blinking in red blah blah blah do some useful instead of screaming here …It’s you just adding random noise to the thread complains about something BLINKING IN RED


#810
16:43:31.943 T:1426564080   ERROR: Unable to load /usr/lib/kodi/system/players/VideoPlayer/libdvdnav-arm.so, reason: /usr/lib/kodi/system/players/VideoPlayer/libdvdnav-arm.so: cannot open shared object file: No such file or directory

That’s why :slight_smile:. Thanks for the report. It might be giving other users problems too.

I’ll investigate this. Can you try one of my Beta builds for Krypton and let me know if you still experience the problem? You might want to back up your card as switching back to @gmc test builds are not trivial.

Also: do you remember when this stopped working?


#811

@gmc

Check you don’t still have the old libdvd* packages (we abandoned that approach after we got it building properly in tree).

dpkg -l | grep libdvd | grep osmc should return nothing in the armv6l and armv7 toolchains.


#812

Don’t have any of those packages.


#813

16.8-188, 12 Nov 2016: Based off OSMC commit (b9120ae19) and newclock5 (b4ce16c47)

OSMC
Updated OSMC Skin (4.4.1-1)

XBMC:
[cmake] separate_arguments() is stupid (PR:10900, 1 commit, 8 files changed)
Picture: Partially revert f5f9b8d and aadfc21d (keeping fixes) (PR:10906, 1 commit, 1 file changed)
[depends] Force link generation (PR:10891, 1 commit, 2 files changed)
[PVR] Fix and cleanup pvr window’s sort methods. (PR:10907, 1 commit, 1 file changed)
[PVR] Guide info dialog: fix record/add timer button visibility. (PR:10908, 1 commit, 1 file changed)
[cmake] Allow building add-ons by regex match without bootstrapping f… (PR:10902, 1 commit, 1 file changed)

peripheral.joystick:
[cocoa] Fix race condition by merging CJoystickAsync into CJoystickCocoa (f0feece1)


#814

Hey everyone,

I have a Raspberry 3 running RetroPie. I initially had the Jarvis Kodi installed within the RetroPie system.

I did the indicated steps in order to install the latest Krypton build. However when I run “sudo apt-get install rbp2-mediacenter-osmc” it stops with the following errors:

Setting up mediacenter-addon-osmc (3.0.621) …
chown: invalid user: 'osmc:osmc’
chown: invalid user: 'osmc:osmc’
chown: invalid user: 'osmc:osmc’
chown: invalid user: 'osmc:osmc’
dpkg: error processing package mediacenter-addon-osmc (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of rbp2-mediacenter-osmc:
rbp2-mediacenter-osmc depends on mediacenter-addon-osmc (>= 3.0.39); however:
Package mediacenter-addon-osmc is not configured yet.

dpkg: error processing package rbp2-mediacenter-osmc (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
mediacenter-addon-osmc
rbp2-mediacenter-osmc

I tried to Google the “invalid user” thing but nothing came up. Any help is appreciated. :slight_smile: Thanks!


#815

Are you running OSMC? You cannot add this repository on a Raspbian system or RetroPie system and expect it to work, but you could run Retrosmc.

cat /etc/os-release


#816

I guess not:

pi@retropie:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian

So I could somehow install Retrosmc and then I could proceed with the usual apt-get commands?


#817

You need to install OSMC to use these builds.


#818

Hi @sam_nazarko , I not sure what you mean with “Can you try one of my Beta builds for Krypton” as I am already on Beta 6 10/11/2016.

“Do you remember when this stopped working?” I can’t tell the exact date but I do see from my play list that these ISO files where played when i was using Kodi 16. I am using ISO files quite frequently so I would say it isn’t working since the update from Kodi 16 to Kodi 17. I might be wrong, but I was playing ISO within a month, and now i can’t. Hope this helps.


#819

Thanks. If you’re on an official OSMC beta you should be posting in that thread rather than the @gmc thread.

So just to clarify, you are not using the test builds in this thread?


#820

I am not sure what am I using :smiley: I know it may sound quite lame. I use OSMC 16.8.187 Beta 6.

ps: i have just updated from 16.8.187 to 16.8.189 and it is the same, and also the system just crashed at first boot after restart.