[TESTING] Kodi 17 (Krypton) Beta Builds for all platforms


#507

Yes i can confirm playing that videos on jarvis.

i will upload a small sample tomorrow.

Thanks


#508

Hi Sam,

Here is a small sample of one of the Files. I’ve tested it with more Movies with VC-1 codec and it is the same with all of them.

MediaInfo:

http://paste.osmc.io/agatakayez.coffee


#509

I have the raspberry connected via HDMI to my TV and the TV is connected to the receiver.

I have enabled Passtrough and DD5.1 and DTS.
But a movie with DTS has no sound.

The receiver shows no input.

What can cause this problem?
Is this a known problem? Or is the problem on my side?
Any tips? Help?


#510

Most TV’s don’t support passthrough of DTS.


#511

OK, just for the record in case somebody encounters a similar error with failed extraction while upgrading.

The reason was a corrupted file system which messed up the file from the error message. The solution is to just completely remove the broken file and then run the upgrade again. It will create a new updated copy of the file and all will be fine again.


#512

You do indeed have file system corruption.

I suspect this may be an issue with your card, but you will soon find out if this is the case.

I would advise backing up anything important in the interim.

Also put sudo touch /forcefsck to force a full filesystem check on reboot

Sam


#513

OK thanks for the info.
So I will check my TV and otherwise I will attach a sound cable directly to the receiver.


#514

Thanks for the hint! I will run the check when back home.

I doubt it’s a broken card though – the root fs is on an extarnel HDD. :wink:


#515

So freezing is gone as far as I can say, thanks


#516

I have multiple clients currently running OSMC with Kodi Jarvis just fine (RPi2/3, Windows 10 and Ubuntu 16.04) but would like to try OSMC Krypton RC3 on one of the Pis. I’m using a MySQL backend.

I assume that if I were to install Krypton on one of the Pis, it will create new MySQL databases but it won’t drop the existing ones, correct? (Previous upgrades behaved in this way.) So I would be okay to run both versions of the client as long as I’m willing to update the library on two client systems (one Krypton and one Jarvis) on any changes to media, correct?

TIA,
TL


#517

The old database will be preserved.


#518

Thank you, Sam!


#519

Follow the steps, restarting my osmc left in a loop with sad face :(, this is the log
http://paste.osmc.io/cekerezija


#520

RC4 announced :slight_smile:


#521

The normal way is to plug the rasp to the receiver and from the AVR via HDMI to the ARC Channel of the TV so that the AVR does the encoding and decoding of your sound.

Try it this way :wink:


#522

This is only possible if his avr has HDMI connections. If he’s having these issues, I’d suspect that it doesn’t.


#523

RC4 delivered

On a Friday night no less :wink:


#524

Hello

Kodi Krypton RC4 is now available for all OSMC users for testing. Here are the key improvements in this release:

  • Update Estuary and Estouchy with some bugfixes and improvements
  • Revert changes that disabled plugin listing cache that which caused reduced browsing speed
  • Fix the cause of favourites not refreshing
  • Fix add-ons not being added to favourites if done through add-on manager
  • Update our default webinterface Chorus2 with several fixes and features
  • Fix possible deadlock when installing/uninstalling PVR add-ons
  • Fix changing song ratings
  • Make sure to stop playback before uninstalling a PVR add-on
  • Fix long timeout for certain audio streams

To update to the latest version, you can check for updates in My OSMC, or follow the original instructions in my initial post.

I expect this to be the final RC of Kodi Krypton. We will shortly follow with a final, stable version for all OSMC users.

I’m looking forward to your feedback and I would like to thank everyone who has tested these builds. You have improved the OSMC experience and ensured that the final release of Kodi Krypton will be well received by other users.

Cheers

Sam


#525

Is the Nvidia fixed in this version for ATV?

Thanks


#526

I doubt this is related to the RC4 release, it might be related to the January OSMC release