[TESTING] Kodi 16 (Jarvis) test builds for OSMC


#122

I can also confirm that airplay works (iOs 9.2.1) on rbp1, but doesn’t on rbp2. Both running RC3, both having the updated libshairplay (of course, one arm6, the other one arm7)

Can anybody confirm that it works on their rbp2, to rule out any arm7 libshairplay problems?


#123

Ok, I think I figured it out: if you use osmc on two devices in the same wifi, airplay only works on one of them, almost randomly based on the boot up time. The reason appears to be the libshairport implementation, which used to (and still does, unless configured differently) announce itself using a fixed, always the same, mac address. The latest commit of libshairport allows for a different mac address to be configured, but most likely kodi doesn’t make use of it, nor does it allow you to manually change it.

Now I got it to work on my rbp2, but of course that broke the functionality of the rbp1…


#124

Have you tried using different host names?


#125

Of course, have been using different host names since the functionality was added. If you read the last commit notes of libshairplay, the mac address issue is described, I remember seeing there should be now possible to pass a different mac as a command line parameter to the executable. As far as I know, kodi makes use of the library, so not sure what it takes to get it implemented as a setting.

Edit: Actually the latest commit of libshairplay just fixes the formatting in its readme file, nevertheless the parameter there is the one I was mentioning:

  •  --hwaddr=address            Sets the MAC address, useful if running multuple instances
    

Multiple Instances

Shairplay advertises over mDNS in the form 485D607CEE22@Dining Room Speakers where 485D607CEE22 is a MAC address. This is hardcoded to a nonsense value, which is not a problem so long as it’s unique. However, if you run multiple Shairplay instances, iOS devices will only recognize one of them. To fix this, supply the --hwaddr option with different values on each device.


#126

I have realised that a lots of addon cannot be installed is it normal?


#127

From the release notes of Jarvis

General: So far in version 16 there are no add-on
changes that would impact any add-ons except for PVR. Since our 12.x
Frodo release there have been some gradual changes but in general all
add-ons, even from that time should still work, of course there are some
exceptions. If the add-ons worked in Gotham, Helix and Isengard then we
are happy to say that all these add-ons should still work.


#128

Short follow up: kodi has its own broadcasting system, the problem I was witnessing was caused by the mediacenter booting up before the network came up, causing the airplay server to fall back to a default 000102030405 mac address. Enabling “Wait for network” on both my pis allows me to use airplay on both my devices at the same time.


#129

Enable wait for network in My OSMC?


#130

Exactly, in My OSMC.


#131

MyOSMC -> Network -> wired/wirelss at the bottom :wink:


#133

Hi guys
I’ve tried installing osmc Jarvis but it stops at:

Connecting to 192.168.1.108 port 22, please wait…
login as:
osmc@192.168.1.108’s password:

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Feb 18 18:38:13 2016 from 192.168.1.106

wget http://paste.osmc.io/raw/afopazadum
converted ‘http://paste.osmc.io/raw/afopazadum’ (ANSI_X3.4-1968) -> ‘http://paste.osmc.io/raw/afopazadum’ (UTF-8)
–2016-02-18 18:39:24-- http://paste.osmc.io/raw/afopazadum
Resolving paste.osmc.io (paste.osmc.io)… 159.253.212.250
Connecting to paste.osmc.io (paste.osmc.io)|159.253.212.250|:80… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [text/plain]
Saving to: ‘afopazadum.6’

afopazadum.6 [ ] 0 --.-KB/s
afopazadum.6 [ ] 531 --.-KB/s in 0s

2016-02-18 18:39:24 (6.88 MB/s) - ‘afopazadum.6’ saved [531]

What is wrong?
Thanks.


#134

You aren’t using the correct command… It’s clearly stated in the OP as

wget http://paste.osmc.io/raw/afopazadum -O- | sudo bash


#135

Hi, after the update for Airplay fix (or perhaps on an a earlier RC3 branch) the scraper for theMovieDB.org has stopped working saying that it cannot connect to the server. Other scrapers seem to work fine. I checked on theMovieDB.org forum and some users were reporting the same error but community reported that this was due to recent update in Kodi.

https://www.themoviedb.org/talk/56c48f70c3a36872000027cd


#136

Quick question guys, would the auto update method available via my OSMC or via apt-get update work once RC3 is moved to Stable? And to any possible RC4?


#137

TMBD contacted OSMC a few days ago:

We need our own API key. This may be tricky as we don’t supply our own repo.

Sam


#138

Thx Sam. Any chance of a temporary fix (ie. replacing json via SSH) or does it require change in code?


#139

As said above, there is no solution to this yet.

Sam


#140

Thx Sam! Sorry I misinterpreted :slightly_smiling:


#141

Hi Marcos

I have a solution for the problem of Kodi RC3 that the scraper for theMovieDB.org has stopped working. In the addon there is a directory “metadata.common.themoviedb.org” with version 3.8.8. Thus, the scraper is working properly you need the version 3.9.0. I have the contents of the directory simply copied with the new version.

Not sure why the addon does not updates automatically, maybe Sam has a solution or there is a problem of Kodi developer. However, under OSX, Windows and Android it runs flawlessly.


#142

Thanks, i updated the TMDB addon manually to 3.9.0 and its working again! (RBP 2, OSMC with Kodi 16 RC3)
edit: but it doesnt finds any movie posters/fanart when i add a new movie to the db…


AirPlay Not working