[TESTING] Kodi 16 (Jarvis) test builds for OSMC


#81

To get a better understanding of the problem you are experiencing we need more information from you. Please see http://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/ for advice on how to help us.


#82

Is there a way to downgrade back to beta 5?


#83

You should have the archive cached in /var/lib/apt/cache and should be able to dpkg -i it from there.

Sam


#84

I can’t find that folder cache


#85

well Im just going to do a clean install I have a lot of junk I need to clean up any ways


#87

RC2 is here!

Is possible that the “january” update will be moved to first weeks of February to include Kodi 16? Or you prefer launch a january update (without Kodi 16) and 1 month testing Kodi 16 to avoid “problems”?


#88

Way ahead of you! Just waiting for the builds to finish now.

The January update is coming shortly for the weekend

Sam


#89

As I’ve been reading about some people experiencing problems with the January update, I just wanted to write an FYI:
did an manual update to Jarvis RC2 (from RC1) yesterday and just ‘auto’-updated to OSMC 2016.01-1 an hour ago - everythings fine :slight_smile:
Thanks a ton!

(…forgot to mention: RPi2 and RPi1… :blush: )


#90

It’s good to hear things went well for a change, as users tend to only post here when there’s an issue.

Cheers

Sam


#91

I report as well all things working well.

I have still reported one bug upstream.

I am soon planning to fully switch to osmc as my main tv system.
It is so far the best release ever for me.


#92

I’ve just had chance to catch up and update to RC2. It all seems to be working well for me. Profiles and skins working as expected.

Thanks Sam.


#93

working fine here.


#94

I wanted to follow up on the issues I was seeing with buffering on Live TV. After being frustrated with it for a couple of weeks, I tried fiddling with the cache settings in advancedsettings.xml again. I now have the following, which seems to have pretty much solved the problem:

<advancedsettings>
    <pvr>
        <minaudiocachelevel>50</minaudiocachelevel>
    </pvr>
</advancedsettings>

Anything less than 50% wasn’t enough. When things are running in sync, the audio queue (aq) seems to sit around 40% higher than the video queue (vq), so this setting indirectly ensures that the video queue is full enough to avoid buffering. Setting minvideocachelevel doesn’t achieve the same thing: as soon as the buffer reaches the right level, it starts playing much too quickly and empties the buffer almost immediately. Meanwhile, the sync stats report huge errors. So I think there’s a bad interaction between the A/V sync algorithm and the buffering algorithm. I daresay this is a problem general to kodi rather than OSMC specifically.

Anyway, the workaround above seems fine; hopefully others might find it useful.


#95

After I wrote this, I upgraded to RC2, and it seems to behave much better. There is no need for the advancedsettings.xml, with the added benefit that the buffering time on channel changes is much lower.

Great stuff. Thanks very much!


#96

Hi all!

Apologies I posted this in a new topic rather than a reply!

Been a long time since I pulled my old RPi out (original 512mb one) and wanted to catch up on things.

Really liking what you’ve done with OSMC! Im awaiting my RPi2 to replace my FireStick so thought Id give OSMC a whirl on my older gen first.

I am having a small issue with updating the stable build to RC2 though (all my other Kodis are 16RC2 for the MySQL).

I use the windows installer to install 01-01-2016 and all goes well. SSH in and run:

sudo wget http://paste.osmc.io/raw/alakedayiv -O- | sudo bash

Everything looks fine and at 36% it reboots the Pi.

This is where it hangs on a black screen with:

[ok] Starting Set Time using HTTP query
Starting LSB: Start NTP daemon
[ok] Started LSB: Start NTP daemon
[ok]Reached target Multi-User System
[ok]Reached target Graphical Interface
Starting Update UTMP about System RunLevel Changes...
[ok]Started Update UTMP about System RunLevel Changes.

At this point I also lose SSH access as well.

I attempted this last night using a different SD card and achieved the same. I pulled the power after about 2hrs and it booted into OSMC 15.2 still so the update didn’t ‘take’.

Running the update command again brings errors such as (from memory) “dbpkg failed” and needed to run something like “dpkg --configure -a” to fix and also “rbp1-mediacenter-osmc is partly installed”.

Ive also tried running apt-get update and upgrade before running the update command.

Heres the shell from the fresh install running the command after OSMC’s OOBE and the stock addons have finished updating:

http://pastebin.com/G55z372R

Wondering if Im missing something simple?

I don’t know if this is a Kodi issue but can attempt to grab logs if it helps.

Appreciate any help :slight_smile:


#97

How long did you wait for?

Sam


#98

Right, I’ve sorted it.

My Pi2 came today and have just installed RC2, followed it start to finish.

The Pi1 WAS working fine but it was doing very, very slowly. To the point after 2hrs is where I thought it had crashed/frozen etc.

I didnt realize that after the reboot (36%) that it was actually still going.

I misspoke on the SSH losing access, it was still connected just no output due to the Pi1 doing its thing.

Watching the Pi2 install fly through I saw what should be happening and where so I set the Pi1 off again from scratch this afternoon. Took a total of 3hrs start to finish but eventually got to RC2.

I know the Pi1 is obviously slower but I couldn’t find anything relating to install times. Google brought me to a lot of boot time videos or ‘comparison’ stuff but nothing really saying “This could take up to Xhrs” etc.

Anyway, RC2 is now running ok on my Pi1 and blazing on my Pi2!


#99

2 hours isn’t acceptable. Check your SD card and power supply


#100

hi guys,

Kodi Release Candidate 3 is now available :slightly_smiling:

Hope here soon too.


#101

Now I have an understanding of the ‘timings’ Im gonna chalk it up to the quality of the SD Cards.

They are both (tried two of them) old and cheap 16GB Class 10 play.com ‘own brand’.

OSMC and Rasbian run ok when they are booted, just the update process was slow. Havnt really used Raspbian on the Pi1 much though, so couldnt say the card has een pushed much.

Maybe its just really slow read/write or [insert SD timing stat here]? Either way, the Pi2 was a blazing fast install and update and now running brilliantly.

Best decision I’ve made recently, ditching the FireStick for a Pi2 :slight_smile: