[TESTING] Improved multi-channel PCM for Vero 4K


Following on from our improvements to 5.1 PCM output, there have now been further changes that should permit the output of multi-channel PCM in a more native output format. This is beneficial as it allows AVRs to perform more accurate post-processing and populate channels with upmixing where applicable.

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

You may wish to review your audio settings after this. If you encounter a problem, please include a Kodi debug log and a system log with a verbose description of the problem.

Many thanks to @grahamh for his improvements and @Wuschel_Wuschel and @JimKnopf for many hours of testing.



[TESTING] Improved LPCM output for Vero 4K
AVR Onkyo TX-RZ820, DTS-HD HRA/Hi Res Passthrough Issue
5.1PCM being converted to 7.1PCM - how to stop this?
No Multichannel output with Music
Multichannel audio incorrectly mapped

With all these changes to audio, I’d like to request one more.

In the Kodi GUI audio settings menu, if the channel output is something where downmixing is disabled (5.1 or above?), can you hide the choices for downmix in the menu?

Basically, the settings menu needs to get rid of any options that don’t have any effect right now, based on other things that have been chosen. I think it would help with debugging and avoid user confusion.


Noted and understood. Also need to grey out ‘Send low volume noise’ when ‘keep audio alive’ is off I think.


with the feb upgrade my setup is work without any issues, no cracking noise or distortion on aac audio tracks. Thank you all for this! question, Is there further development from the feb update? or is the feb kind of final regarding the multi channel?

ps, it might just be my imagination but i have a sensation that the audio is more clear now especially the front center channel with speech seems much more clear than before. Might just be me but wanted to share it.


Probably just imagination, but glad you’re happy with the update!
Out of curiosity: Have you tested surround files and experienced any strange noises on the rear channels every now and then? This question also goes to @nabsltd :slightly_smiling_face:


Did you get crackling noise or distortion before?

Is there anything you would like to see? We thought it was perfect now! :wink:


i tested a few episodes of the Americans that some have 5.1 aac sound before the feb update and had some issue with it (i think i did not use the latest test version either). Every time i paused an episode and continued it gave noises and cliches in the sound. I had to stop and re start the episode. Anyway with the feb release i dont have this issue any more. Nuff said, for me everything is working perfectly now.


Hi all,

only for my understanding… Please, do not kill me.
When I watch a movie, I enable “passthrough”. When I like to hear Music (DTS etc.) I have to disable the passthrough option - right?

Cheers, Marc


Nobody will be killed for asking questions here! :wink:

No :stuck_out_tongue_winking_eye: With passthrough enabled, all formats that can be bitstreamed via HDMI to an AVR (DTS, Dolby) will be passed on to the AVR untouched - what you most definitely want. All other formats will be decoded by the Vero and passed as PCM. So, if your AVR can decode all Dolby/DTS formats (which it most likely can), enable passthrough and best set your audio settings to HDMI / 7.1 / best match / keep alive off / low volume noise off / passthrough on (all of the passthrough options).

And then, please just test whether (especially) surround audio files (like FLAC, AAC - non-bitstreamable files) are played back without issues for us to know whether everything’s fine :slightly_smiling_face:


Hi Wuschel,

thank you. Now it is 100% clear for me. My Anthem AVM 60 has a serious issue with DTS in music files and also DTS HRA (in movies). It is not the fault of the Vero 4K. I will now introduce this to the support of Paradigm / Anthem.

Thank you again, Marc


Oh, ok… That issue also many Denons are showing. :see_no_evil:

If you have time for it, could you give PCM playback with the Vero a try (preferrably with surround music content/non-DTS files)?


Hi Wuschel,

yes - I did. flac5.1 for example works absolutely fine. This issue is only related to DTS.
I will stress this with the manufacturer of my A/V processor.

thanks, Marc


I still get crackling noise after stopping a multichannel PCM stream and start playing another. It’s always after stopping playback and restarting. Usually no issues on initial playback.

Seems more frequent now than it was before although it did happen before too.

Stopping playback and restarting doesn’t immediately work. I have to stop, wait a minute or so, then start playback again for the problem to go away (at least it seems). I haven’t scientifically tested.

In my setup the only thing that plays back multichannel PCM is LiveTV from my HDHomeRun. So it’s not very often I run into this problem.


Thanks for that. Please confirm you have ‘keep alive’ disabled.

I think the relevant time you have to wait after a track finishes is 10 seconds if ‘keep alive’ is off. If anyone has the time to confirm this it would be useful.


Nothing I have heard. I’ve tested 2,0, 5.1, and 7.1 FLAC, 5.1 and 7.1 TrueHD, and just about every DTS-HD and DTS-HR movie channel layout. The only glitch is the slow sync to DTS-HR, and that’s not the Vero. FLAC sends out PCM with perfect channel layouts every time.


A new thought…I have Audio->Output Configuration set to “Optimized”. Would “Best Match” help with the DTS-HR sync? I have a full 7.1 speaker setup, and have that set, along with passthrough of all Dolby and DTS formats.

Also, with the PCM output update, people who are having trouble with DTS-HR could just tell Kodi not to pass it through, and get channel-perfect PCM. Sure, it would raise the CPU usage a bit, but not that much.


9 posts were split to a new topic: AVR Onkyo RZ820, DTS-HD HRA/Hi Res Passthrough Issue


One last issue: At the moment I have to turn “passthrough off” when I like to hear some DTS music (related to my A/V processor). But after switching to passthrough “off”, the sound is very distorted. Is there a possibility to reset the chipset when switching? Otherwise I have to reboot first.

Cheers, Marc


Can you try describing the distortion (and specifically when it does happen, after which actions, is there a way to stop it, etc.) or even make an audio recording of it?


Ideally that’s what we’re trying to achieve (work out what states are stuck and reset them fully).