[TESTING] Debian Stretch upgrade for OSMC


#84

The update seemed to have gone ok here. Two sad faces, but now everything seems to be running like before!


#85

Just upgraded today Sam. Smooth as!

Just a question. I went back in and edited sources.list - the lines

http://apt.osmc.tv stretch main

http://apt.osmc.tv stretch-devel main

were both there so I deleted the stretch-devel one - I’m assuming I don’t need both unless I want to get the continuing development releases? I’d prefer to stay on stable.

Edit: I’m on a Vero 4.


#86

That’s right.


#87

I’m getting this info if I do a cat /proc/version:

Linux version 3.14.29-45-osmc (root@vero3-db) (gcc version 6.3.0 20170516 (Debian 6.3.0-18) ) #1 SMP Wed Nov 29 00:31:03 UTC 2017


#88

Upgraded my Pi3 earlier today and no problems, not even a sad face.


#89

Mm i wonder if i actually upgraded.

Did an apt-get dist-upgrade and i have lots of packages still needing an upgrade.
osmc@osmc:~$ sudo apt-get update
Get:1 http://security.debian.org stretch/updates InRelease [63.0 kB]
Ign http://ftp.debian.org stretch InRelease
Get:2 http://ftp.debian.org stretch-updates InRelease [91.0 kB]
Get:3 http://security.debian.org stretch/updates/main armhf Packages [230 kB]
Hit http://apt.osmc.tv stretch InRelease
Hit http://ftp.debian.org stretch Release.gpg
Get:4 http://ftp.debian.org stretch-updates/main armhf Packages/DiffIndex [1,720 B]
Get:5 http://apt.osmc.tv stretch/main armhf Packages/DiffIndex [229 B]
Hit http://ftp.debian.org stretch-updates/contrib armhf Packages
Hit http://ftp.debian.org stretch-updates/non-free armhf Packages
Hit http://ftp.debian.org stretch-updates/contrib Translation-en
Get:6 http://ftp.debian.org stretch-updates/main Translation-en/DiffIndex [1,720 B]
Hit http://ftp.debian.org stretch-updates/non-free Translation-en
Hit http://security.debian.org stretch/updates/contrib armhf Packages
Hit http://ftp.debian.org stretch Release
Hit http://security.debian.org stretch/updates/non-free armhf Packages
Hit http://security.debian.org stretch/updates/contrib Translation-en
Hit http://security.debian.org stretch/updates/main Translation-en
Hit http://security.debian.org stretch/updates/non-free Translation-en
Hit http://ftp.debian.org stretch/main armhf Packages
Hit http://ftp.debian.org stretch/contrib armhf Packages
Hit http://ftp.debian.org stretch/non-free armhf Packages
Hit http://ftp.debian.org stretch/contrib Translation-en
Hit http://ftp.debian.org stretch/main Translation-en
Ign http://apt.osmc.tv stretch/main Translation-en_GB
Hit http://ftp.debian.org stretch/non-free Translation-en
Ign http://apt.osmc.tv stretch/main Translation-en
Fetched 388 kB in 25s (15.1 kB/s)
Reading package lists… Done
osmc@osmc:~$ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… The following packages were automatically installed and are no longer required:
armv7-irqbalance-osmc armv7-libass-osmc armv7-libbluray-osmc
armv7-libcrossguid-osmc armv7-libnfs-osmc armv7-librtmp-osmc
armv7-libshairplay-osmc armv7-libsqlite-osmc busybox eject exfat-fuse
exfat-utils fake-hwclock fuse g+±4.9 hdparm hfsprogs hfsutils ifupdown
iproute2 libapt-inst1.5 libasn1-8-heimdal libasprintf0c2 libavresample-dev
libavresample3 libbind9-90 libboost-atomic1.55.0 libboost-chrono1.55.0
libboost-filesystem1.55.0 libboost-locale1.55.0 libboost-serialization1.55.0
libboost-system1.55.0 libboost-thread1.55.0 libcdio13 libconfuse-common
libdns100 libegl1-mesa libelfg0 libenca0 libfribidi0 libfuse2 libgbm1
libgif4 libgraphite2-3 libharfbuzz0b libhcrypto4-heimdal libhdb9-heimdal
libheimbase1-heimdal libhx509-5-heimdal libilmbase6 libisc95 libisccc90
libisccfg90 libjasper1 libjson-c2 libkrb5-26-heimdal liblwres90
libmicrohttpd10 libmysqlclient18 libntdb1 libntfs-3g871 libopenexr6
libplist2 libpsl0 libraw10 libroken18-heimdal libsmbclient libsndfile1-dev
libssh-4 libssl1.0.0 libswscale3 libtag1-vanilla libtimedate-perl
libtinyxml2.6.2 libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa
libwayland-server0 libwebp5 libwebpdemux1 libwebpmux1 libwind0-heimdal
libyajl2 mediacenter-addon-osmc mediacenter-eventclients-common-osmc
mediacenter-send-osmc mysql-common nano ntfs-3g python-chardet
python-colorama python-dbus-dev python-distlib python-html5lib
python-imaging python-ntdb python-pexpect python-pil python-ptyprocess
python-requests python-six python-support python-unidecode python-urllib3
python-webencodings rbp2-libcec-osmc
Use ‘apt-get autoremove’ to remove them.
Done
The following packages will be REMOVED:
armv7-diskmount-osmc armv7-udisks-glue-osmc debconf-i18n
libboost-atomic1.55-dev libboost-chrono1.55-dev libboost-date-time1.55-dev
libboost-date-time1.55.0 libboost-filesystem1.55-dev libboost-locale1.55-dev
libboost-serialization1.55-dev libboost-system1.55-dev
libboost-thread1.55-dev libboost1.55-dev libconfuse0 libguichan-0.8.1-1
libguichan-allegro-0.8.1-1 libguichan-opengl-0.8.1-1 libguichan-sdl-0.8.1-1
libpcrecpp0 libreadline6-dev libtext-iconv-perl libusb-1.0-0-dbg
module-init-tools perl-modules rbp2-device-osmc rbp2-mediacenter-osmc
The following NEW packages will be installed:
cpp-6 dh-python dirmngr g+±6 gcc-6 gcc-6-base gnupg-agent keyutils
libapparmor1 libapt-inst2.0 libapt-pkg5.0 libasan3 libassuan0 libavcodec57
libavformat57 libavresample3 libavutil55 libbind9-140 libbluray1
libboost-atomic1.62-dev libboost-atomic1.62.0 libboost-chrono1.62-dev
libboost-chrono1.62.0 libboost-date-time1.62-dev libboost-date-time1.62.0
libboost-filesystem1.62-dev libboost-filesystem1.62.0
libboost-locale1.62-dev libboost-locale1.62.0 libboost-serialization1.62-dev
libboost-serialization1.62.0 libboost-system1.62-dev libboost-system1.62.0
libboost-thread1.62-dev libboost-thread1.62.0 libboost1.62-dev libc-l10n
libcairo2 libcc1-0 libchromaprint1 libdns162 libdrm-amdgpu1 libdrm-tegra0
libegl1-mesa libelf1 libfdisk1 libfftw3-single3 libgbm1 libgcc-6-dev libgme0
libgnutls30 libgpgme11 libguichan-0.8.1-1v5 libguichan-allegro-0.8.1-1v5
libguichan-opengl-0.8.1-1v5 libguichan-sdl-0.8.1-1v5 libhogweed4 libicu57
libidn2-0 libilmbase12 libip4tc0 libip6tc0 libiptc0 libisc160 libisccc140
libisccfg140 libisl15 libjsoncpp1 libjxr0 libksba8 libldap-common
liblwres141 liblz4-1 libmagic-mgc libmnl0 libmpdec2 libmpg123-0
libnetfilter-conntrack3 libnettle6 libnghttp2-14 libnpth0 libntfs-3g871
libopenexr22 libopenjp2-7 libopenmpt0 libpcre16-3 libpcre32-3 libpcrecpp0v5
libperl5.24 libpixman-1-0 libpng16-16 libprocps6 libpsl5 libpython3-stdlib
libpython3.5-minimal libpython3.5-stdlib libraw15 libreadline7 libseccomp2
libshine3 libsnappy1v5 libsndio6.1 libsoxr0 libssh-gcrypt-4 libssl1.0.2
libssl1.1 libstdc+±6-dev libswresample-dev libswresample2 libswscale4
libtwolame0 libuv1 libva-drm1 libva-x11-1 libvdpau1 libvpx4 libwavpack1
libwayland-client0 libwayland-cursor0 libwayland-egl1-mesa
libwayland-server0 libwebp6 libwebpdemux2 libwebpmux2 libx264-148 libx265-95
libxcb-shm0 libxtables12 libzip4 libzvbi-common libzvbi0 perl-modules-5.24
pinentry-curses python-pip-whl python-ptyprocess python-webencodings python3
python3-minimal python3.5 python3.5-minimal
The following packages have been kept back:
libsdl1.2-dev libsdl1.2debian libsdl2-2.0-0 libsdl2-dev stella sudo
The following packages will be upgraded:
acl adduser alsa-utils apt apt-utils autoconf automake autotools-dev
avahi-daemon base-files base-passwd bash bash-completion bind9-host binutils
bison bluetooth bsdutils build-essential busybox bzip2 ca-certificates
cifs-utils cmake cmake-data coreutils cpp curl dash dbus debconf
debian-archive-keyring debianutils dialog diffutils dmsetup dosfstools dpkg
dpkg-dev dvb-tools e2fslibs e2fsprogs eject exfat-fuse exfat-utils
fake-hwclock fbset file findutils flex fontconfig fontconfig-config
fonts-dejavu-core frotz fuse g++ gcc gettext gettext-base gir1.2-glib-2.0
git git-man gnupg gpgv grep gzip hdparm hfsprogs hfsutils hostname ifupdown
init init-system-helpers initscripts insserv iproute2 iptables kbd kmod less
lhasa libacl1 liballegro4-dev liballegro4.4 libao-common libao4
libarchive-dev libarchive13 libargtable2-0 libargtable2-dev
libargtable2-docs libasn1-8-heimdal libasound2 libasound2-data
libasound2-dev libasyncns0 libatasmart4 libatomic1 libattr1 libaudio2
libaudiofile-dev libaudiofile1 libaudit-common libaudit1 libavahi-client-dev
libavahi-client3 libavahi-common-data libavahi-common-dev libavahi-common3
libavahi-core7 libavcodec-dev libavformat-dev libavresample-dev
libavutil-dev libbison-dev libblkid1 libbluetooth3 libboost-date-time-dev
libboost-dev libboost-filesystem-dev libboost-locale-dev libboost-system-dev
libboost-thread-dev libbsd0 libbz2-1.0 libbz2-dev libc-bin libc-dev-bin
libc6 libc6-dev libcaca-dev libcaca0 libcap-ng0 libcap2 libcap2-bin
libcdio13 libcloog-isl4 libcomerr2 libconfuse-common libcroco3
libcryptsetup4 libcups2 libcurl3 libcurl3-gnutls libcurl4-openssl-dev
libcwiid1 libdb5.3 libdbus-1-3 libdbus-1-dev libdbus-glib-1-2
libdbus-glib-1-dev libdebconfclient0 libdevmapper-event1.02.1
libdevmapper1.02.1 libdirectfb-1.2-9 libdirectfb-dev libdirectfb-extra
libdpkg-perl libdrm-dev libdrm-exynos1 libdrm-freedreno1 libdrm-nouveau2
libdrm-omap1 libdrm-radeon1 libdrm2 libdvbv5-0 libedit2 libeigen3-dev
libenca0 liberror-perl libevdev-dev libevdev2 libevent-2.0-5 libexpat1
libexpat1-dev libfaad-dev libfaad2 libffi6 libfl-dev libflac-dev libflac8
libfluidsynth-dev libfluidsynth1 libfontconfig1 libfreeimage-dev
libfreeimage3 libfreetype6 libfreetype6-dev libfribidi0 libfuse2 libgcc1
libgcrypt20 libgdbm3 libgeoip1 libgirepository-1.0-1 libgl1-mesa-dev
libgl1-mesa-glx libglapi-mesa libglib2.0-0 libglib2.0-bin libglib2.0-data
libglib2.0-dev libglu1-mesa libglu1-mesa-dev libgmp10 libgomp1 libgpg-error0
libgpm2 libgraphite2-3 libgsm1 libgssapi-krb5-2 libgudev-1.0-0
libguichan-dev libharfbuzz0b libhcrypto4-heimdal libhdb9-heimdal
libheimbase1-heimdal libhx509-5-heimdal libice-dev libice6 libidn11
libjack-dev libjack0 libjbig-dev libjbig0 libjpeg-dev libjpeg62-turbo
libjpeg62-turbo-dev libjpgalleg4.4 libjs-jquery libk5crypto3 libkeyutils1
libkmod2 libkrb5-26-heimdal libkrb5-3 libkrb5support0 liblcms2-2
libldap-2.4-2 libldb1 liblhasa0 liblocale-gettext-perl liblvm2app2.2
liblzma-dev liblzma5 liblzo2-2 libmagic1 libmikmod-config libmikmod-dev
libmikmod3 libmng1 libmount1 libmp3lame0 libmpc3 libmpeg2-4 libmpeg2-4-dev
libmpfr4 libncurses5 libncursesw5 libnfsidmap2 libnl-3-200 libnl-genl-3-200
libnss-mdns libnss-myhostname libntdb1 libopenal-data libopenal1 libopts25
libopus0 liborc-0.4-0 libp11-kit0 libpam-modules libpam-modules-bin
libpam-runtime libpam-systemd libpam0g libparted2 libpcre3 libpcre3-dev
libpcsclite1 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0
libpopt0 libportaudio2 libportaudiocpp0 libproc-processtable-perl
libpulse-dev libpulse-mainloop-glib0 libpulse0 libpython-dev
libpython-stdlib libpython2.7 libpython2.7-dev libpython2.7-minimal
libpython2.7-stdlib libqt4-network libqt4-xml libqtcore4 libqtdbus4
libqtgui4 libreadline-dev libroken18-heimdal librtmp1 libsamplerate0
libsamplerate0-dev libsasl2-2 libsasl2-modules-db libsdl-gfx1.2-5
libsdl-gfx1.2-dev libsdl-image1.2 libsdl-image1.2-dev libsdl-mixer1.2
libsdl-mixer1.2-dev libsdl-sound1.2 libsdl-sound1.2-dev libsdl-ttf2.0-0
libsdl-ttf2.0-dev libselinux1 libsemanage-common libsemanage1 libsepol1
libsgutils2-2 libsigsegv2 libslang2 libslang2-dev libsm-dev libsm6
libsmartcols1 libsmbclient libsndfile1 libsndfile1-dev libspeex-dev
libspeex1 libspeexdsp-dev libspeexdsp1 libsqlite3-0 libss2 libssh-4
libssh2-1 libssl-dev libstdc++6 libswscale-dev libsystemd0 libtalloc2
libtasn1-6 libtdb1 libtevent0 libtext-charwidth-perl libtext-wrapi18n-perl
libtheora-dev libtheora0 libtiff5 libtiff5-dev libtiffxx5 libtinfo-dev
libtinfo5 libtirpc1 libtool libubsan0 libudev-dev libudev1 libunistring0
liburiparser-dev liburiparser1 libusb-0.1-4 libusb-1.0-0 libusb-1.0-0-dev
libusb-1.0-doc libustr-1.0-1 libuuid1 libva1 libvorbis-dev libvorbis0a
libvorbisenc2 libvorbisfile3 libwbclient0 libwebp-dev libwind0-heimdal
libwrap0 libx11-6 libx11-data libx11-dev libx11-xcb-dev libx11-xcb1 libxaw7
libxaw7-dev libxcb-dri2-0 libxcb-dri2-0-dev libxcb-dri3-0 libxcb-dri3-dev
libxcb-glx0 libxcb-glx0-dev libxcb-present-dev libxcb-present0 libxcb-randr0
libxcb-randr0-dev libxcb-render0 libxcb-render0-dev libxcb-shape0
libxcb-shape0-dev libxcb-sync-dev libxcb-sync1 libxcb-xfixes0
libxcb-xfixes0-dev libxcb1 libxcb1-dev libxcursor-dev libxcursor1
libxdamage-dev libxdamage1 libxdmcp-dev libxdmcp6 libxext-dev libxext6
libxfixes-dev libxfixes3 libxi6 libxinerama1 libxkbcommon-dev libxkbcommon0
libxml2 libxmu-dev libxmu-headers libxmu6 libxpm-dev libxpm4 libxrandr2
libxrender-dev libxrender1 libxshmfence-dev libxshmfence1 libxslt1.1
libxt-dev libxt6 libxtst6 libxvidcore4 libxxf86dga1 libxxf86vm-dev
libxxf86vm1 libyajl2 libzip-dev linux-libc-dev locales locate login lsb-base
lswm m4 make mawk mc mc-data mesa-common-dev mime-support mount
multiarch-support mysql-common nano ncurses-base ncurses-bin net-tools
netbase nfs-common ntfs-3g ntp openssh-client openssh-server
openssh-sftp-server openssl passwd patch perl perl-base pkg-config
policykit-1 portaudio19-dev procps psmisc pv python python-apt
python-apt-common python-chardet python-colorama python-crypto python-cwiid
python-dbus python-dbus-dev python-dev python-distlib python-dnspython
python-gi python-gobject python-gobject-2 python-html5lib python-imaging
python-ldb python-minimal python-ntdb python-pexpect python-pil python-pip
python-pkg-resources python-requests python-samba python-setuptools
python-six python-talloc python-tdb python-unidecode python-urllib3
python2.7 python2.7-dev python2.7-minimal qtcore4-l10n readline-common
rpcbind samba samba-common samba-common-bin samba-dsdb-modules samba-libs
scons sed startpar systemd systemd-sysv sysv-rc sysvinit-utils tar tdb-tools
timidity tzdata ucf udev unzip update-inetd usbutils util-linux uuid-dev
vorbis-tools w-scan wget wminput wpasupplicant x11-common x11proto-core-dev
x11proto-input-dev x11proto-kb-dev xkb-data xmlstarlet xtrans-dev xz-utils
zlib1g zlib1g-dev
555 upgraded, 140 newly installed, 26 to remove and 6 not upgraded.
Need to get 1,328 kB/266 MB of archives.
After this operation, 138 MB of additional disk space will be used.
Do you want to continue? [Y/n] n


#90

Check /etc/debian_version. If it doesn’t show 9, then you haven’t updated.


#91

Yes it was on 8.0 so doing the upgrade now. Bizarre it just missed 1,328 kB to do the upgrade


#92

I think i am going to run in troubles :persevere:

Said yes to the dist-upgrade and now it failst to do the uprade.

I am forcing it to upgrade now. Will see what i end up with.

EDIT mm look bad isn’t it

Removing rbp2-device-osmc (1.4.4) …
WARNING: You have tried to remove a package that is essential to OSMC’s operation.
To undo these changes, run ‘sudo apt-get -f install’.
dpkg: error processing package rbp2-device-osmc (–remove):
subprocess installed pre-removal script returned error exit status 1
dpkg: libconfuse0:armhf: dependency problems, but removing anyway as you requested:
armv7-udisks-glue-osmc depends on libconfuse0.

Removing libconfuse0:armhf (2.7-5) …
dpkg: armv7-diskmount-osmc: dependency problems, but removing anyway as you requested:
rbp2-device-osmc depends on armv7-diskmount-osmc.

Removing armv7-diskmount-osmc (1.5.5) …
Removing 'diversion of /sbin/mount.exfat-fuse to /sbin/mount.exfat-fuse.distributed by armv7-diskmount-osmc’
Removing armv7-udisks-glue-osmc (1.3.5-7) …
Errors were encountered while processing:
rbp2-device-osmc
E: Sub-process /usr/bin/dpkg returned an error code (1)


#93

I really fail to understand why you didn’t use the My Osmc addon to update.


#94

Won’t help him now to discuss that thought… :wink:


#95

I did on the day but it did not update successfully. I came back and osmc was up and running thought it successfully updated but i had all those packages not installed.

I had to re-enabled stretch devel and i went forward a little. Now i am failing on samba.

Can someone who upgraded successfully share with me its /etc/apt/sources.lsit


#96
deb http://ftp.debian.org/debian stretch main contrib non-free

deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free

deb http://apt.osmc.tv stretch-devel main

P.S

It would probably better to revert to a jessie image and restore your settings. When you update again, keep checking MyOsmc for updates till it says there a no more updates;


#97

thanks Tom i removed samba and continue to upgrade… Kodi still works though


#98

Hi,

Was this the Samba server? If so you could try reinstalling from the MyOsmc app store again.

Tom.


#99

Hi,

I’m on vero4k running Debian Jessie. What happens if I replace jessie with stretch in the sources.list (without having stretch-devel in there) and run a dist-upgrade?

What’s the difference between stretch-devel and stretch?


#100

\o/ yeah success

the two problems i had wer:

When i did the dist-upgrade i previously removed the stretch-devel to stretch re-enabling it solved the problem

The installation stalled on samba after removing the package i could successfully finished the upgrade.

I have just re-installed the samba package from osmc store.

Thanks everyone.


#101

You will probably bork your system. The migrate has been designed to do it the way described above. Why not follow the instructions?

stretch will become the stable release. The devel versions are a foretaste of what the next upgrade will be and may have side-effects.


#102

It will indeed break the system as it will only receive a partial upgrade at this time. The Stretch repository is not yet populated.


#103

How did you remove the samba package without removing vero2-device-osmc?