[TESTING] Bluetooth audio streaming (A2DP)


#619

This likely won’t change anything, but an external Bluetooth adapter may help


#620

That’s disappointing but thanks for the quick reply


#621

The official OSMC adapter works well – you shouldn’t get dropouts.


#622

Hello, I followed the discussion on the thread and got my bluetooth dongle working . I can now stream music from bluetooth enabled devices to raspberry pi the audio the gets routed through my hdmi to my tv and is played through tv speakers. ( no analog output )
However, this happens despite the fact that I have set the settings > audio to send the audio to “Analog” only.
I want the audio to be sent to my speakers ( through the 3.5m jack on pi ) at all times. I assume this should be a pulseaudio configuaration problem.

here is the output of “pacmd list” https://pastebin.com/FEkbzvV9


#623

BT audio is routed independently of Kodi settings.
You’d need to configure Pi’s ALSA sink to do this.


#624

Thanks. any hint on how to do that? It should be configured in /etc/pulse ?
ls /etc/pulse client.conf daemon.conf daemon.conf.distributed default.pa system.pa system.pa.distributed

osmc@hpi:/etc/pulse$ aplay -l card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA] Subdevices: 8/8 Subdevice #0: subdevice #0 Subdevice #1: subdevice #1 Subdevice #2: subdevice #2 Subdevice #3: subdevice #3 Subdevice #4: subdevice #4 Subdevice #5: subdevice #5 Subdevice #6: subdevice #6 Subdevice #7: subdevice #7 card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI] Subdevices: 1/1 Subdevice #0: subdevice #0ed


#625

PulseAudio manual shows that I can set the default sink by an environment variable.
I can also see a file in my home directory under .config/pulse which is pointing to the default sink on my RPI3

osmc@hpi:/etc/pulse$ cat ~/.config/pulse/5c693405e29740b98a2ed5f2da69ff71-default-sink
alsa_output.0.analog-stereog-stere

> osmc@hpi:/etc/pulse$ pacmd list-sinks
> 1 sink(s) available.
>   * index: 0
>         name: <alsa_output.0.analog-stereo>
>         driver: <module-alsa-card.c>

Shouldn’t I have 2 sinks? one for hdmi out and one for the analog sound?


#626

I’m trying for weeks now to get Bluetooth working on OSMC.
I simply want to stream from my phone to the pi but this is like rocket science or what ??

  1. Is it possible to stream using the built-in Bluetooth on the pi3 or do I have to use a dongle ?
  2. Anyone has a tutorial on how to do it ? i’m using a hifiberry dac+

#627

I didn’t have much luck with the built in bluetooth module. The audio stutters.
for a guide, take a look at the first post.
disclaimer: as you can see in my post, I’m stuck too.


#628

Hi guys,

It’s still experimental, but very easy to set up.
Streaming to a DAC however, is a bit trickier. It’s not rocket science, but it adds a spanner in the works :wink:

It’s possible – but you may experience stuttering. This is quite common with the internal adapter and that’s why we recommend this.

Sam


#629

Ok, definitely no rocket science here :slight_smile: I tried so many things that I screwed up my install I guess, so did a complete new install. Then selected my hifiberry from the OSMC setup. in system settings changed output to hifiberry dac. So far so good, ready for a test. did the few commands from the first post, checked back audio settings. Now only alsa to Bluetooth speakers / to headphones was available. Selected this and … Bluetooth Is working like a charm through my hifiberry dac :smiley: This adds soooo much more to the experience. No need to start my MacBook to enjoy apple music through airplay, and my girlfriend, oh my she’s going to be so happy to be able to play her Spotify list from android through Bluetooth. thx a lot

Only it’s stupid to see it like this in audio settings. Can I change this text somewhere so it says Alsa through Hifiberry DAC ? And any possibility to change volume from the device that sends the music ?

EDIT: Ok cheered too soon. On android it’s still playing choppy :confused: When I disable wifi all is ok. So I need to, or buy an external wifi dongle, or the Bluetooth dongle you sell here. cable is no option because of the layout

if I buy the Bluetooth dongle -> How do you install and select the external dongle ? Do you have to change a lot in the settings ?


#630

Disable Internal BT

And as long as you get a supported Bluetooth (e.g. From OSMC) than new dongle will work automatically.


#631

Hi,
I had posted this in its own thread, but found this topic and thought it might be more appropriate here.

I’m having an issue with pairing my iPod touch with OSMC on a raspberry pi2. I had read that some external Bluetooth adapters can be finicky, so I made sure that I got the official OSMC Bluetooth dongle.

Basically I went into MyOSMC/Network and then into the Bluetooth settings. Then I enabled the Bluetooth adapter and started discovery mode. It recognised my iPod, I then selected it and got the menu for Pair with Pin or Pair without Pin etc. I tried Pair with Pin first, my iPod asked me to enter a pin, but OSMC didn’t tell me the pin to enter. So the pairing failed…

Then I tried Pair without Pin, and this also failed. Have I done something wrong or not enabled/downloaded an add on etc?

Debug log here: https://paste.osmc.tv/wubazubobu

I then tried with an iPad as well.

Same steps as above, however when I selected Pair with Pin, nothing happened and the pairing failed. My device then no longer appears in the available devices box.

Debug log here: https://paste.osmc.tv/pabidateci


#632

Hi Wolf7250,

I’ve updated on your original topic, as I don’t think this is related to this post; as you are having issues with pairing, not testing A2DP.

Regards Tom.


#635

Set up Bluetooth audio streaming via A2DP as per the instructions at the top of this topic. Everything worked really well except for being unable to adjust the output volume at all either through my tablet or through OSMC itself.

I have OSMC installed on a rasberry pi 2 connected to my TV through HDMI. I switched my tv from the HDMI input source to just watch some regular TV for an hour or so. When I came back to OSMC I couldn’t get any audio output at all, Bluetooth or even GUI sounds. Tried rebooting, that didn’t help. So very confused I shut down the Pi and went to bed.

Woke up this morning and booted the Pi up. Sound was kinda working, but it was very distorted. So went searching through settings. Found the PulseAudio service under MyOSMC/Services and on a hunch tried disabling the service. Now audio works as per normal. Haven’t tried re-enabling the PulseAudio service as i’m kinda scared to.

It seems to me as though the PulseAudio service became corrupted or stopped working correctly. But to be honest I know very little about the subject…


#636

Make sure to set audio back to HDMI in settings --> system --> audio output


#637

Hi @the_bo, I did check that and I believe that it was set to HDMI the entire time, I never adjusted that setting.


#638

So stopping the PulseAudio service restored the audio for me as I mentioned above. I have since restarted the service and everything appears to be working well so far. So fingers crossed…

I am still unable to adjust the volume either through OSMC or from my tablet from which I am streaming the audio. Is this normal?


#639

Changing the volume on the Tablet should work as far as I know

I am working on a way to be able to control the volume of BT streaming I was hoping to be able to control the audio volume of the phone/tablet from BTPlayer but this is not possible with Bluez at the moment

The reason changing the volume in Kodi is not working is PulseAudio is being used to play the BT Audio stream and that is not what Kodi is using for audio output

I am currently testing a solution where the BTPlayer addon listens for volume change events and changes the PulseAudio output volume when requested


#640

Awesome! Sounds great. Thanks for your response and efforts :slight_smile: