[TESTING] Bluetooth audio streaming (A2DP)


#579

I’ve bought the OSMC BT adapter, and It’s still just stutter. I’ve disabled the internal BT module.

Logs: http://paste.osmc.io/zatusaziti


#580

How did you disable the internal adapter?
What power supply are you using?
What device are you streaming from, or to?


#581
  • dtoverlay=pi3-disable-bt
  • Official 2.5A PSU
  • I’m streaming from an Google Nexus 5X

Off-topic: Bought your Wifi adapter to, I get worse speed than the internal, any tips?


#582

Did you get the 802.11ac one?
There were improvements but for new installs only. I can guide you through them in another thread.

Try and avoid connecting to 802.11n network and BT streaming at the same time if possible. 802.11ac and BT should be fine.


#583

I’m using the 802.11ac, but it looks like it’s connected to 802.11n, I’ll check if I found how to change it.

Edit: Connected to AC now, but still stutter and unusable BT streaming.


#584

Hi Sam

Is it still necessary to run

sudo systemctl disable brcm43xx.service

after putting dtoverlay=pi3-disable-bt in config?


#585

OK – I wonder if it’s an issue with some Android devices.
Quickest test would be:

  • Remove OSMC dongle temporarily. Does it improve?
  • If not, post a debug log and I’ll take a look. There’s a Nexus tablet in the house so might be able to investigate. What App on Android are you streaming from?

Cheers


#586

Been a while since I made such recommendations.
I don’t believe disabling this service has ever been necessary, as the service will only upload firmware if the device is present in DT. I believe that setting the above dtoverlay will mask those pins from being present.

Sam


#587

It is only reproducible for me when streaming (local SMB shares), however with Bluetooth disconnected, streaming works flawlessly


#588

in my case external dongle does not work and error message shown in console each system shutdown without this command.


#589

I think the problem here is that the BT audio data is sharing the same bus/channel as the ethernet video data.
You can verify this by copying the file to the SDcard, or USB connected HDD (ie not a network share).
Then try playing the video with BT streaming audio.
If it’s ok locally, but not across the network, then I think that’s due to a limitation of the Pi USB/Ethernet.

Others here could explain it better - it’s the Broadcom chip in the Pi which shares USB and Ethernet.


#590

Not sure, as apparently this behaviour is reproducible for me using only some Bluetooth devices, and it did not use to be an issue.


#591

Actually I’m wondering how good a2dp works in libreelec.
Does it have same limitations for integrated bluetooth and issues?
Sorry for incorrect question, but I’m interesting with their experience and challenges :blush:


#592

They use PulseAudio like we do.
But I don’t believe they use our BTPlayer, so no playback progress is visible.

I also believe that they experience issues with the internal adapter on the Raspberry Pi. But this is the OSMC forums: so best to ask them on their forum.


#593

Hi there guys…

I have been following this thread for some time and finally got it working on a Pi3 with a cheap external BT dongle.

I am certain the challenge now face will be common to may people on this thread.

My setup is very simple at them moment:

Android phone plays music over BT
RPi3 running latest OSMC with this A2DP setup
HDMI from Pi to Hisense smart TV

I now wish to achieve the following:

HDMI (via Audio Return Channel) from Hisense TV to a Samsung Home Theatre system
Full 5.1 sound from Samsung Home Theatre system.

To date I am only getting poor output from the Samsung system. None of the sound modes result in all the speakers producing sound well.

My question is thus how to achieve 5.1 sound output via HDMI on the RPi3?

The Samsung Home Theatre cannot be relied upon to mix up to 5.1 it would seem.

Many thanks in advance.


#594

Did you set stereo to 5.1 upmix?
http://kodi.wiki/view/audio_quickstart_guide


#595

What phone are you using? When I upgraded from a Samsung galaxy s5 to s7 the quality improved tremendously.


#596

I have an S5 and S6 in front of me — both perform equally well.

You have, nevertheless, just inspired me to make the upgrade to S7 :slight_smile:


#597

Hi there Fzinken

I have tried every permutation of settings possible.

My next attempt will be to plug the Pi HDMI directly into the Samsung HT to see if the TV is not responsible the loss of channels…

Will revert back with results this evening…

Thanks


#598

That could be a cause