[TESTING] Bluetooth audio streaming (A2DP)


#559

There are several references to “updated instructions” for installation for v17. Could someone post a link to the updated instructions? Kind Regards.


#560

If any instructions were updated, the original post for this thread would have been edited accordingly to reflect them.


#561

Thanks for the fast response. I’ll do a fresh install and try again this evening.


#562

do you have seen the logfile, about the wifi error, when bt stick is missing?


#563

Hi!

My first post here. I bought my RP3 with the HifiBerry Digi+ Standard the other day and I’m surprised how smooth everything worked. I also have a Logilink Bluetooth adapter that works really well with Kodi/OSMC and the Bluetooth-installation instructions in the first post. Thanks a lot for the effort in making the BT streaming work so well. My only nag is that every time I want to watch a movie with my headphones (Sennheiser Momentum Wireless), I have to reconnect them through the OSMC->Network menu. This is only mildly annoying and something I can live with. But has someone had the same issues with no automatic reconnect when you turn your Bluetooth device on? Is there something you can do/hack to make it automatic? I’ve seen that a lot of people has had the same problems on reboot and solved it with a startup-command. I’m thinking that if there’s no quick-fix that you could make a cron-job that runs every minute and looks for the Bluetooth-device or similar. Or perhaps write a daemon that polls for active bluetooth connections and tries to reconnect if they’re not alive… IF there’s not a simple way to solve this of course.
Thanks again.


#564

Hi,

I’m using a RPi3 with an IQaudIO Pi-DigiAMP+. Everything worked fine with Krypton until I installed a2dp-apps-osmc. Now the IQaudIO isn’t listed anymore under Settings->Audio->Device but aplay shows it’s there.

How can I debug this?


#565

Hi,

Firstly I’d like to say thank you for this as this app has allowed me to complete my media centre pi. I have a pi zero w, phatdac, wifi, Bluetooth and a DVD / CD drive as the setup. One curiousity I have noticed is that after playing an audio CD the Bluetooth stops working and requires a reboot. I don’t know if this is a bug or if I’ve done something wrong. Apart from that works like a charm with decent quality. Thank you one again.


#566

I had similar issues with a pi zero and phat dac combo. In the end I found that installing the a2dp app first is essential then the audio card. Hope that helps.


#567

I disabled the IQaudIO-overlay in MyConfig->Hardware config, rebooted, enabled the IQaudIO-overlay and rebooted again. But no success …

Pulseaudio lists the IQaudIO-card, but not KODI.


#568

I’ve just updated OSMC on my pi zero w so that Bluetooth and wifi work. Big thank you to everyone who worked on that. Connectivity is fine but when using the a2dp pass through the audio is choppy. The logs are at http://paste.osmc.io/ogovawekiv. Any help on this would be appreciated.


#569

This is a known limitation of the internal adapter. Get a good adapter if you want reliable audio streaming. Support for the internal adapter may improve in the future.


#570

Thank you Sam. I will follow your advice. It’s a shame that the chip is limited and can’t handle the a2dp.

Edit:

@sam_nazarko Do you know what the limitations are? I know a few software and hardware engineers who may be able to help but they would need to know more about the limitations?


#571

To clarify: for now, it’s generally just found that there can be stuttering when streaming audio using the internal adapter on the Pi 0 W and Pi 3. This might change in the future. I haven’t looked in to this in much detail yet.


#572

Hi,

I just downloaded to latest Image (02.2017) and updated it to 03.2017.
After this I installed BT Streaming and connected my iPhone 6s to stream music to OSMC

I can see BTPlayer is playing the music and I can control the music on my iPhone from osmc :thumbsup: but I can’t hear the music. :frowning2:
-> System sounds are hearable.
-> RPi3 is connected directly via HDMI

Thats my log: http://paste.osmc.io/wiwudawiwi

hope you can help me!


Video freezes on "buffering" when streaming audio via Bluetooth
#573

Hi Guys,

An issue which (I think) has been introduced in one of the recent versions - when streaming audio via Bluetooth, the video freezes after couple of seconds. In fact, it starts “buffering”, but just hangs there seemingly forever. I’m using an up to date OSMC (March update) on RPI3, with a Bluetooth dongle.

Below is a log showing two attempts at playing a video file - the first time (no Bluetooth), everything goes smoothly, but once Bluetooth is connected, playing the same video causes OSMC to buffer “forever”.

http://paste.osmc.io/iyimagerar.vhdl

Let me know if more info is necessary?

Thanks!
Adi


#574

the errors 1+2 [TESTING] Bluetooth audio streaming (A2DP)
already exist on last update.

my log is placed: http://paste.osmc.io/qokilidori.vhdl


#575

Is the video file loaded locally (ie on a HDD USB)…? I have tried streaming TV (HD) channels with the audio streamed to BT speaker. It works… almost. But it’s too much for a Pi3, and the video keeps stuttering.

I haven’t tried with a local video file, but probably that would work fine.


#576

Hi Sam,

I’m using A2DP streaming on a Pi3 with USB BT dongle streaming to BT speaker.
It’s working great…! We use it 24/7, and it’s brill :slight_smile:

We already have a Vero4K in the LivingRoom, and it’s working great too :slight_smile:

Thinking about upgrading this Pi3 to Vero4K … will the BT streaming work… or not yet?

Thanks.
Best regards,
Niall.


#577

Hi

The BT streaming will work, but with the same ‘experimental’ disclaimer we promise for Pi.

Hope to stabilise it for Vero 4K and other platforms this month.

Sam


#578

ok, grand … just ordered one, so … thanks :slight_smile: