[TESTING] 4K HDR playback with banding & flickering fixes


#224

The shortest way to put it is that you should just enable 10-bit in rc.local for now. You won’t get banding or flickering.

No – because as explained above, the auto switching does not always work. This was added as an experimental feature. The goal is to simplify HDR autoswitching in the future. For now however, we have fixed banding and flickering when colour depth is set properly.

Our focus is to work on improving the HDR autoswitching now, which is why I’m trying to finalise this topic, as the original reported issue is fixed.


#225

The easiest is to just fix the file. If you can connect to your box i made a pretty simple step-by-step a few posts up on how to modify the file.


How To Reverse HotFix
#226

You can also go to updates -> manual controls -> apply hotfix and type:

ebuhuyajej

Sam


Vero 4K h265 HDR movies banding / pixelated
Vero 4K Crashes playing UHD MKV rip of Maze Runner Death Cure
#227

Hallelujah! The hot fix sorted it instantly for me. I know it’s been me not knowing the jargon. Hot fix is my best friend.

So in the background has that set the player to force 10 bit out put for all files?


#228

That’s right.


#229

And how will it affect 8 bit files?


#230

Wow the hotfix thing should be more common knowledge :slight_smile: i havent seen any difference playing regular 8bit stuff


#231

I only added it last night at the request of a customer.

Sam


#232

Awesome. Is it possible to customize the hotfix name? ebuhuyajej doesnt really roll or the tongue nicely :smile:


#233

Ok… for the first time i understand the meaning of the hdr auto switch and the entry in the rc.local - think my banding problem is solved… it looks like that the entry in my rc.local has an typo error so the hdr content was played in 8bit and the result was banding… i wonder that before april upate i don´t see banding but after i set the entry new yesterday and do some tests with the 4k demo i haven´t seen any banding yet…thanks again for your support!


#234

Not at this time

Sam


#235

You only have to do it once.


#236

Will future update effect this Hotfix or is it set once and never need to do again?


Audio Drop Outs/Clicks
#237

You can set it once, provided you’re happy with the results.


#238

The combination of the April update and the hot-fix fixed all the banding and flickering issues I was having with 10-bit 4K HDR material on my Panasonic OLED. Thanks Sam!


#239

I am glad to hear this.

Once this thread closes and everyone’s on the same page we can work on improving auto-switching.

Sam


#240

Hi Sam,

I’m reasonably adept with Linux on PC (Mint, Kali) and Pi (Raspbian), etc, but don’t have time to diagnose and recover a destroyed Vero 4k if applying the April update goes wrong (I have major surgery pending).

Is there a simple way to backup and restore my system as-is, given the o/s is stored on hard-wired internal storage?


#242

The next update will not destroy your Vero 4K.

If you had a failed update that damaged your system. you could reinstall from osmc.tv/download in 2-3 minutes with a spare SD card or USB stick. We haven’t had any reports of damaged systems or boot issues after this update on any OSMC supported devices, including Raspberry Pi.

See https://osmc.tv/wiki/general/backing-up-settings/ for how to make a backup.

I wish you the very best of luck with your surgery.

Sam


#243

Applied the Hotfix. All 10 bit movies play fine with no banding. Played various 8 bit movies and can’t fault the picture. Pleased I am.


#245

So, what does the hotfix do exactly? Does it set the bit depth to 10 for everything?