[TESTING] 4K HDR playback with banding & flickering fixes


#182

@Martorias
Thank you for this information. I will make a note of it for whenever I need to do things like this.


#183

Forget my issue about pixelisation. It was LG TruMotion which was set too aggressive. I didn’t noticed it changed the settings when switching in HDR mode.

No more flicker, no more banding : image is perfect now. Thanks for the great job sam !


#184

Nice! Yes the hdr profiles on the TV are different from regular ones so you need to adjust them as well. I think I have 10 deblur and 2 dejudder or what it’s called, looks fine to me.


#185

Thanks for the feedback. This might help some other users.


#186

More on HDMI cables mentioned previously. Whereas I thought the HDMI cable supplied cannot do 10 bit, it is hit and miss. I tested 8 other cables I have today and occasionally, when trying to play a 10-bit 4K movie, all the cables gave me a black screen and my Onkyo receiver displayed “Error”, instead of resolution and bit rate. It is just that the supplied cable did it many more times than the others. Even the original Microsoft branded cable that came with my old Xbox 360 would play the 4K 10-bit movie.

With the auto-switching on, sometimes, while playing the same 10-bit movie with any of the cables, the movie will play at 8-bit. Stop and start it again, it will play at 10-bit. Did this with many 10-bit movies and the result was the same.

I think the problem is with the experimental nature of the auto-switching. I can live with it like this while it gets worked on for improvement.

The banding I saw on Blade Runner 2049 and Dunkirk disappeared when they played in 10 bit.


#187

Just a thought, does it work with the hdr auto switch turned off? It’s not needed unless you have issues getting the tv/receiver to accept the hdr signal.


#188

Auto switch off: played 6 different movies, all showed 8-bit.
Chose one movie, played 6 times, always showing 8-bit.
Auto switch on: same movie, played 4 times always showing 10-bit. 5th, 6th & 7th played at 8-bit. 8th played at 10-bit.


#189

If you turn off auto-switching you need to enable 10-bit output via rc.local


#190

Ah right, I assumed he has. Sorry @theoldfarter, could you try adding the line in rc.local as I described above and try without the autoswitch?


#191

I just do not have enough knowledge to do that. You have given instructions but I have never used Kodi before and am lost without step by step instructions. This situation reminds me of 20 years ago when I first was given my first PC, an old Pentium 100. I needed to format it and install Windows C. I bought a D.O.S for Dummies book and it took me hours before I succeeded. What would have made it quicker was if the book had said that there needed to be spaces between some letters. You can imagine what was happening when I was entering the commands with no spaces. lol

That’s where I am at, with Kodi. You guys need to spend your time and effort in improving the Vero 4K, instead of holding my hand. I am happy to toggle the Auto Switch and curse and swear until the team perfects the Auto Switch. :slight_smile:


#192

This entry is also needed after the April Update and not a part of the build?!


#193

Haha allright :slight_smile: i saw you managed to connect to the box (you got the osmc@osmc:~$ prompt)

If you get there again and follow my commands step by step you should be fine i think. If not, this will hopefully be fixed quite soon :slight_smile:

I could offer to help you via remote (teamviewer for instance) but then again you shouldn’t let random people on the internet touch your computer :joy:


#194

I would like to have a go but lack spare time any time soon as my ‘new’ laptop is being delivered to me tomorrow from the repair shop and I will have to configure it all over again. High end HP, four months old and the USB controller failed. Ah well… :frowning:

As for you doing it remotely, appreciate your offer but will pass on it as I don’t mind waiting for the ‘fix’.
On a lighter note, your offer reminds me of those phone calls I was getting from ‘Microsoft’, telling me I had a virus on my computer and to let them ‘do’ something. Those calls stopped after I changed my phone number and went unlisted. :slight_smile: I am off to bed now.


#195

It is but it’s experimental. This is explained in the release notes and other posts


#196

Haha unlucky with the laptop :frowning_face:

No worries, hopefully it’ll be sorted soon and will work without and extra tampering.


#197

Ah ok, it´s the HDR auto switch setting in Kodi… seen this today for the first time…


#198

Hi all, can I just ask if the April update fixes the banding without having to do anything apart from enable ‘Enable HDR Autoswitching’? I’m confused if this is supposed to be fixed or not for users that don’t tinker with advanced stuff? Because I’ve switch the above setting on and sometimes I get banding and sometimes I don’t.


#199

@sam_nazarko
With the April Update i now have horrible banding in some 4k movies like Iron Man 1 and 2! Have the 10bit switch in my rc.local file and the Kodi callback script enabled - this script eleminate the banding before the April Update and didn´t work anymore! :frowning:
In this demo the banding is seen in the second scene with the blue sky - bevore the April update it looks perfect with the Kodi callback script enabled…

What i don´t understand - after set the HDR auto switch in Kodi to “on” the banding is gone in the demo sometimes…but i have the 10bit switch in the rc.local, so this is double setting?! but unfortunately banding is not gone in Iron Man… so the April Update brings back this big problem for me…


#200

Super weird! Double check that your rc.local has the right stuff and is executable (sudo chmod +x /etc/rc.local)

You hdr auto switch should be off if you set the rc.local and callbacks isn’t needed anymore.


#201

@Martorias… i check it and for testing put the command in a shell

osmc@osmc-wozi:~$ sudo chmod +x /etc/rc.local
attr@osmc-wozi:~$ echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/a
“444,10bit”
osmc@osmc-wozi:~$

Then i set the HDR auto switch to “off” and play the demo 6 times and have banding at all… set the HDR auto switch to “on” and play the demo again 6 times… the result is 4 times without banding and 2 times with banding… and also banding in Iron Man… this is very strange and it seems that the command “echo “444,10bit” | sudo tee /sys/class/amhdmitx/amhdmitx0/a” hasn´t any effect after the April Update…?!

So the April Update needs a fix very urgent i think!