SSH Update issue Pi 1B+


#21

That definitely means something is serious wrong. Suggest you backup the files you need and reinstall (ideally on a new SD Card).

Also just saw

Did you install a separate SSH Server? Because this is not the default OSMC config file.


#22

just replaced card into pi, booted. exit from Kodi. ESC on splash, get terminal login, osmc pass osmc. didnt even type anything, 10 secs tops it rebooted. Kodi works and plays, remote Kore on phones works. The only thing failing here is ssh


#23

this came from sudo apt update followed by sudo apt full-upgrade. I did 2 this morning. a 1B and and 1B+ B= is the one that messed up. same sources etc. watched them side by side over ssh terminals


#24

Why are you running full-upgrade? OSMC only ever recommends dist-upgrade for commandline upgrading.

https://osmc.tv/wiki/general/keeping-your-osmc-system-up-to-date/


#25

So I grabbed the newest Pi 1 image and dd it to card and its up and running now on my Pi 1B+ and updating its library from mysql. SSH is working(after I had to clear my local key and get a new one)
Just ran sudo apt update then sudo apt list -upgradable…

It’s exactly the same upgrades that I did this morning… including listing ssh updates:
openssh-client/stable 1:7.4p1-10+deb9u3 armhf [upgradable from: 1:7.4p1-10+deb9u2]
openssh-server/stable 1:7.4p1-10+deb9u3 armhf [upgradable from: 1:7.4p1-10+deb9u2]
openssh-sftp-server/stable 1:7.4p1-10+deb9u3 armhf [upgradable from: 1:7.4p1-10+deb9u2]
systemd/

I have verfied on my other Pi 1B that the upgradable packages listed above are in fact installed on the 1B and ssh is working on it, kinda leary to do the update at the moment…


#26

anytime I ssh in and run sudo apt update i run sudo apt list --upgradable so I can see what packages are available. If I run sudo apt upgrade it complains about “… properly administrating…” and it says to use apt full-upgrade otherwise I would NOT do it. I only ever use sudo apt upgrade on my Ubuntu systems


#27

Got you. I see now. I’m not sure how our warning message ended up with full-upgrade instead of dist-upgrade. They are functionally the same so no issues there, I was just curious why one would use it. I’d never even heard of the command until a few days ago. sudo apt-get upgrade is the command we want to make sure people avoid. Thanks for answering and we’ll look into making that message more clear.

EDIT: We’ve found the issue. The warning will be more clear in the near future


#28

If you use apt, then we will tell you to use apt full upgrade.
If you use apt-get, then we will tell you use apt-get dist-upgrade.

They are functionally the same, however it should be noted that apt does not yet have a stable CLI interface. Commands are subject to change in newer versions of Debian.