Received OSMC wifi-ac adapter - ISSUES


#151

https://paste.osmc.tv/omolizeyuy for my try with channel 64 (on ddwrt) and 58 in /lib/firmware/mt7610u_sta.dat


#152

https://paste.osmc.tv/necebuqofa
ddwrt ac-only mode, channel 36
dongle wirelessmode = 14 and channel 36

I removed the dongle coz can’t upload the logs so I guess not working


#153

As already requested, please leave Channel=0 in the dongle config file.

Each time you make a change, you need to clear out the old connman details and re-scan, since the old details might be causing a few problems:

sudo rm -rf /var/lib/connman/wifi*
connmanctl
scan wifi
agent on
services
connect wifi_000000000000_64642d7772742d352d42_managed_psk

Please also confirm that you are using a 20 MHz channel width. If 36 doesn’t work, try a few higher channels, all at 20 MHz (eg channels 40, 44 or 48). Make all channel changes only on the router.


#154

yes 20 mhz
ok retry with channel = 0 and switch channels on ddwrt
yes I replay connman each time


#155

https://paste.osmc.tv/ihocijuron
ddwrt:
AC-N mixed mode
channel width 20MHZ
channel 36 5.180HZ

dongle:
wireless mode =11
channel =36

status ddwrt
|7C:DD:90:B7:68:93|wl2|0:56:39|72M|6M|HT20|-66|-92|26|68%|


#156

https://paste.osmc.tv/fekiribugu

same previous except swith ddwrt AC-N mixed to AC only mode
connman error connecting


#157

https://paste.osmc.tv/sugudoduna

back to AC-N mixed and VHT80
connection ok but working as VTH40

ddwrt status
|7C:DD:90:B7:69:19|wl2|0:02:42|108M|6M|HT40|-71|-92|21|58%|


#158

Why did you change the wireless mode from 14 to 11? You should only be changing one parameter at a time: the channel number. And only on the router.

Channel = 36. ??? As already requested – twice – please use Channel=0

Anyway, your log shows that you got an Internet connection using channel 36 on AC-N mixed mode:

Sep 16 17:22:35 chambreparent avahi-daemon[237]: Joining mDNS multicast group on interface wlan0.IPv4 with address 192.168.1.23.
Sep 16 17:22:35 chambreparent avahi-daemon[237]: New relevant interface wlan0.IPv4 for mDNS.
Sep 16 17:22:35 chambreparent avahi-daemon[237]: Registering new address record for 192.168.1.23 on wlan0.IPv4.
Sep 16 17:22:35 chambreparent kernel: RTMP_TimerListAdd: add timer obj b349fa3c!
Sep 16 17:22:35 chambreparent connmand[284]: wlan0 {add} address 192.168.1.23/24 label wlan0 family 2
Sep 16 17:22:35 chambreparent connmand[284]: wlan0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253 <LINK>
Sep 16 17:22:35 chambreparent connmand[284]: wlan0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 <LINK>
Sep 16 17:22:35 chambreparent connmand[284]: wlan0 {add} route 0.0.0.0 gw 192.168.1.1 scope 0 <UNIVERSE>
Sep 16 17:22:36 chambreparent connmand[284]: wlan0 {add} route 212.227.81.55 gw 192.168.1.1 scope 0 <UNIVERSE>
Sep 16 17:22:36 chambreparent connmand[284]: wlan0 {del} route 212.227.81.55 gw 192.168.1.1 scope 0 <UNIVERSE>
Sep 16 17:33:41 chambreparent systemd[1]: Time has been changed
Sep 16 17:33:41 chambreparent http-time[317]: Updated time from Sun Sep 16 15:22:38 UTC 2018 to Sun Sep 16 15:33:41 UTC 2018 using HTTP query to www.google.com

When you switch from AC-N to AC mode did you remember to clear all the connman settings and re-scan?

Switching back to AC-N:

Sep 16 18:15:31 chambreparent wpa_supplicant[372]: wlan0: Trying to associate with e8:fc:af:fe:a9:d0 (SSID='dd-wrt-5-B' freq=5260 MHz)

You changed to channel 52 (5260 MHz) and the wifi mode. Only change one thing at a time.


#169

AC-N VHT40(ddwrt) = https://paste.osmc.tv/tenehivujo => OK
AC-N VHT80(ddwrt) but client detected as VHT40 = https://paste.osmc.tv/yagubazoce => OK
AC only VHT40 (ddwrt) = https://paste.osmc.tv/nanafegafi => not OK
AC only VHT80(ddwrt)= https://paste.osmc.tv/hisonipamu => not OK

all tests performed with same settings mt7610u_sta, channel =0 and wirelessmode =11. Channel is set “auto” in ddwrt too

Should respect your test protocl @dillthedog


#170

You should be setting the channel manually on the router.

As far as the AC protocol is concerned, you are getting authentication timeouts.

Sep 23 19:53:23 chambreparent wpa_supplicant[369]: wlan0: Authentication with e8:fc:af:fe:a9:d0 timed out.

so it’s clearly having problems communicating with the router when using the AC protocol, supporting your hypothesis that it’s using the N protocol when it successfully connects on AC-N mixed mode. I suggest you return to wirelessmode = 14 and see if that changes anything.


#171

AC only and VHT80 on ddwrt and set wirelessmode 14.

Logs seems ok, connection and IP attribution but can’t ping it


#172

on reboot, after unplug ethernet cable, so only connecting via wifi can see this error in journalctl
IPv4 online check failed for 0x125ee20 dd-wrt-5-B


#173

If you are getting an IP address, that’s a step in the right direction.

I know it was a over a week ago and it might have slipped your mind after all this time, but you should be testing only using a 20 MHz channel width. Remember, we are trying to take small steps.


#174

test result for AC mode only, VHT 20 MHZ and channel 36 in ddwrt. Client in wirelessmode 14

Blockquote
Sep 25 11:02:16 chambreparent dbus[199]: [system] Activating via systemd: service name=‘net.connman.vpn’ unit=’
Sep 25 11:02:16 chambreparent dbus[199]: [system] Activation via systemd failed for unit ‘connman-vpn.service’:
Sep 25 11:02:24 chambreparent kernel: ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 336
Sep 25 11:05:16 chambreparent connmand[240]: ipconfig state 2 ipconfig method 1
Sep 25 11:05:21 chambreparent wpa_supplicant[364]: wlan0: Trying to associate with e8:fc:af:fe:a9:d0 (SSID='dd-
Sep 25 11:05:21 chambreparent wpa_supplicant[364]: wlan0: Association request to the driver failed
Sep 25 11:05:21 chambreparent kernel: ===>rt_ioctl_giwscan. 2(2) BSS returned, data->length = 336
Sep 25 11:05:21 chambreparent kernel: ==>rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=36)
Sep 25 11:05:21 chambreparent kernel: PeerBeaconAtJoinAction(): HT-CtrlChannel=36, CentralChannel=>36
Sep 25 11:05:21 chambreparent kernel: PeerBeaconAtJoinAction(): VHT->center_freq_1=36, CentralChannel=>36, vht_
Sep 25 11:05:21 chambreparent kernel: PeerBeaconAtJoinAction(): Set CentralChannel=36
Sep 25 11:05:21 chambreparent kernel: AdjustChannelRelatedValue(): Input BW=0, rf_channel=36, vht_bw=1, Channel
Sep 25 11:05:21 chambreparent wpa_supplicant[364]: wlan0: Associated with e8:fc:af:fe:a9:d0
Sep 25 11:05:22 chambreparent wpa_supplicant[364]: wlan0: WPA: Key negotiation completed with e8:fc:af:fe:a9:d0
Sep 25 11:05:22 chambreparent wpa_supplicant[364]: wlan0: CTRL-EVENT-CONNECTED - Connection to e8:fc:af:fe:a9:d
Sep 25 11:05:22 chambreparent connmand[240]: wlan0 {RX} 3050 packets 769495 bytes
Sep 25 11:05:22 chambreparent connmand[240]: wlan0 {TX} 81 packets 9016 bytes
Sep 25 11:05:22 chambreparent connmand[240]: wlan0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
Sep 25 11:05:22 chambreparent connmand[240]: wlan0 {newlink} index 3 address 7C:DD:90:B7:69:19 mtu 1500
Sep 25 11:05:22 chambreparent connmand[240]: wlan0 {newlink} index 3 operstate 6
Sep 25 11:05:22 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34a8a00!
Sep 25 11:05:22 chambreparent connmand[240]: ipconfig state 3 ipconfig method 1
Sep 25 11:05:22 chambreparent connmand[240]: wlan0 {del} route fe80:: gw :: scope 0
Sep 25 11:05:22 chambreparent avahi-daemon[193]: Withdrawing address record for fe80::7edd:90ff:feb7:6919 on wl
Sep 25 11:05:22 chambreparent avahi-daemon[193]: Leaving mDNS multicast group on interface wlan0.IPv6 with addr
Sep 25 11:05:22 chambreparent avahi-daemon[193]: Interface wlan0.IPv6 no longer relevant for mDNS.
Sep 25 11:05:30 chambreparent connmand[240]: rp_filter set to 2 (loose mode routing), old value was 0
Sep 25 11:05:30 chambreparent avahi-daemon[193]: Joining mDNS multicast group on interface wlan0.IPv4 with addr
Sep 25 11:05:30 chambreparent avahi-daemon[193]: New relevant interface wlan0.IPv4 for mDNS.
Sep 25 11:05:30 chambreparent avahi-daemon[193]: Registering new address record for 192.168.1.23 on wlan0.IPv4.
Sep 25 11:05:30 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34a8a3c!
Sep 25 11:05:30 chambreparent connmand[240]: wlan0 {add} address 192.168.1.23/24 label wlan0 family 2
Sep 25 11:05:30 chambreparent connmand[240]: wlan0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253
Sep 25 11:05:30 chambreparent connmand[240]: wlan0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253
Sep 25 11:05:31 chambreparent ntpd[469]: Listen normally on 5 wlan0 192.168.1.23:123
Sep 25 11:05:35 chambreparent kernel: Rcv Wcid(1) AddBAReq
Sep 25 11:05:35 chambreparent kernel: Start Seq = 00000003
Sep 25 11:05:35 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34aa814!
Sep 25 11:05:41 chambreparent connmand[240]: IPv4 online check failed for 0x1b09270 dd-wrt-5-B

if I switch wirelessmode 11 client is not detected on ddwrt status interface and get this :

Blockquote
Sep 25 11:46:30 chambreparent kernel: ==>rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=36)
Sep 25 11:46:30 chambreparent wpa_supplicant[374]: wlan0: Trying to associate with e8:fc:af:fe:a9:d0 (SSID='dd-
Sep 25 11:46:30 chambreparent wpa_supplicant[374]: wlan0: Association request to the driver failed
Sep 25 11:46:30 chambreparent kernel: PeerBeaconAtJoinAction(): HT-CtrlChannel=36, CentralChannel=>36
Sep 25 11:46:30 chambreparent kernel: PeerBeaconAtJoinAction(): Set CentralChannel=36
Sep 25 11:46:30 chambreparent kernel: AdjustChannelRelatedValue(): Input BW=0, rf_channel=36, vht_bw=1, Channel
Sep 25 11:46:35 chambreparent wpa_supplicant[374]: wlan0: Authentication with e8:fc:af:fe:a9:d0 timed out.
Sep 25 11:46:35 chambreparent wpa_supplicant[374]: wlan0: CTRL-EVENT-DISCONNECTED bssid=e8:fc:af:fe:a9:d0 reaso
Sep 25 11:46:35 chambreparent connmand[244]: ipconfig state 7 ipconfig method 1


#175

Hi,

Had quick look through and also I can’t remember if this question has been asked or not (sorry if it has), but what WPA Encryption is ddwrt set to aes or tkip? I would recommend aes.

Thanks Tom.


#176

hello @Tom_Doyle

WPA is set as AES in ddwrt


#177

Someone shared with me his tplink router AC for test (all default auto options in router)

Blockquote
Sep 25 15:35:10 chambreparent kernel: ===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 576
Sep 25 15:35:43 chambreparent connmand[243]: ipconfig state 2 ipconfig method 1
Sep 25 15:35:47 chambreparent kernel: ===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 576
Sep 25 15:35:47 chambreparent wpa_supplicant[375]: wlan0: Trying to associate with b0:4e:26:0a:1f:51 (SSID='TP-
Sep 25 15:35:47 chambreparent wpa_supplicant[375]: wlan0: Association request to the driver failed
Sep 25 15:35:47 chambreparent kernel: ==>rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=48)
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): HT-CtrlChannel=48, CentralChannel=>46
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): VHT->center_freq_1=42, CentralChannel=>42, vht_
Sep 25 15:35:02 chambreparent dbus[212]: [system] Activation via systemd failed for unit ‘connman-vpn.service’:
Sep 25 15:35:10 chambreparent kernel: ===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 576
Sep 25 15:35:43 chambreparent connmand[243]: ipconfig state 2 ipconfig method 1
Sep 25 15:35:47 chambreparent kernel: ===>rt_ioctl_giwscan. 3(3) BSS returned, data->length = 576
Sep 25 15:35:47 chambreparent wpa_supplicant[375]: wlan0: Trying to associate with b0:4e:26:0a:1f:51 (SSID='TP-
Sep 25 15:35:47 chambreparent wpa_supplicant[375]: wlan0: Association request to the driver failed
Sep 25 15:35:47 chambreparent kernel: ==>rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=48)
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): HT-CtrlChannel=48, CentralChannel=>46
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): VHT->center_freq_1=42, CentralChannel=>42, vht_
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): Set CentralChannel=42
Sep 25 15:35:47 chambreparent kernel: AdjustChannelRelatedValue(): Input BW=2, rf_channel=42, vht_bw=1, Channel
Sep 25 15:35:47 chambreparent wpa_supplicant[375]: wlan0: Associated with b0:4e:26:0a:1f:51
Sep 25 15:35:48 chambreparent wpa_supplicant[375]: wlan0: WPA: Key negotiation completed with b0:4e:26:0a:1f:51
Sep 25 15:35:48 chambreparent wpa_supplicant[375]: wlan0: CTRL-EVENT-CONNECTED - Connection to b0:4e:26:0a:1f:5
Sep 25 15:35:48 chambreparent connmand[243]: wlan0 {RX} 880 packets 223159 bytes
Sep 25 15:35:48 chambreparent connmand[243]: wlan0 {TX} 81 packets 9024 bytes
Sep 25 15:35:48 chambreparent connmand[243]: wlan0 {update} flags 102467 <UP,RUNNING,LOWER_UP>
Sep 25 15:35:48 chambreparent connmand[243]: wlan0 {newlink} index 3 address 7C:DD:90:B7:69:19 mtu 1500
Sep 25 15:35:48 chambreparent kernel: Rcv Wcid(1) AddBAReq
Sep 25 15:35:48 chambreparent kernel: Start Seq = 00000002
Sep 25 15:35:48 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34b0814!
Sep 25 15:35:48 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34aea00!
Sep 25 15:35:48 chambreparent connmand[243]: wlan0 {newlink} index 3 operstate 6
Sep 25 15:35:48 chambreparent kernel: Rcv Wcid(1) AddBAReq
Sep 25 15:35:48 chambreparent kernel: Start Seq = 00000001
Sep 25 15:35:48 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34b0868!
Sep 25 15:35:48 chambreparent connmand[243]: ipconfig state 3 ipconfig method 1
Sep 25 15:35:48 chambreparent avahi-daemon[244]: Withdrawing address record for fe80::7edd:90ff:feb7:6919 on wl
Sep 25 15:35:48 chambreparent avahi-daemon[244]: Leaving mDNS multicast group on interface wlan0.IPv6 with addr
Sep 25 15:35:48 chambreparent avahi-daemon[244]: Interface wlan0.IPv6 no longer relevant for mDNS.
Sep 25 15:35:48 chambreparent connmand[243]: wlan0 {del} route fe80:: gw :: scope 0
Sep 25 15:35:49 chambreparent avahi-daemon[244]: Joining mDNS multicast group on interface wlan0.IPv4 with addr
Sep 25 15:35:49 chambreparent avahi-daemon[244]: New relevant interface wlan0.IPv4 for mDNS.
Sep 25 15:35:49 chambreparent avahi-daemon[244]: Registering new address record for 192.168.1.102 on wlan0.IPv4
Sep 25 15:35:49 chambreparent connmand[243]: rp_filter set to 2 (loose mode routing), old value was 0
Sep 25 15:35:49 chambreparent kernel: RTMP_TimerListAdd: add timer obj b34aea3c!
Sep 25 15:35:49 chambreparent connmand[243]: wlan0 {add} address 192.168.1.102/24 label wlan0 family 2
Sep 25 15:35:49 chambreparent connmand[243]: wlan0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253
Sep 25 15:35:49 chambreparent connmand[243]: wlan0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253
Sep 25 15:35:51 chambreparent ntpd[477]: Listen normally on 5 wlan0 192.168.1.102:123
Sep 25 15:36:00 chambreparent connmand[243]: IPv4 online check failed for 0x133c690 TP-Link_1F4F_5G


#178

Here’s what I wrote on 16 September:

Yes, stick with 14.

These lines have me a bit puzzled. This from the first log:

Sep 25 11:05:30 chambreparent connmand[240]: wlan0 {add} address 192.168.1.23/24 label wlan0 family 2
Sep 25 11:05:30 chambreparent connmand[240]: wlan0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253 
Sep 25 11:05:30 chambreparent connmand[240]: wlan0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 

and this from the log when connecting to the TP-Link router:

Sep 25 15:35:49 chambreparent connmand[243]: wlan0 {add} address 192.168.1.102/24 label wlan0 family 2
Sep 25 15:35:49 chambreparent connmand[243]: wlan0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253 
Sep 25 15:35:49 chambreparent connmand[243]: wlan0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 

In both cases, the routes for 192.168.1.0 and 192.168.1.1 are sent via 0.0.0.0, ie via the default gateway, but the default gateway isn’t being defined. You haven’t provided full logs so I can’t see if the default gateway had already been defined for the cable connection.


#179

reboot after each test (VHT20) :

test channel 40 (5.200 GHZ) in ddwrt = https://paste.osmc.tv/uyuvabuwuk (has to disconnect usb key to grabs logs)
test channel 44 (5,220GHZ) in ddwrt = https://paste.osmc.tv/ofucoloqaj (has to disconnect usb key to grabs logs)
test channel 52 (5,260GHZ) in ddwrt = https://paste.osmc.tv/dejoyedulu (OK, no need to disconnect usb key to grabs log)
test channel 60 (5,300GHZ) in ddwrt = https://paste.osmc.tv/wefihifaqo (has to disconnect usb key to grabs logs)

back to test channel 52 to reproduce = https://paste.osmc.tv/daxubejazi (OK, no need to disconnect usb key to grabs log)
Something weird si for 40/44/60, passphrase has been requested by conman but not for 52 (twice)

hope these logs will be usefull for you


#180

Good work.

The channels that are failing all produce a large number of error messages in the log, eg:

Sep 26 19:07:42 chambreparent kernel: receive cmd msg fail(-71)
Sep 26 19:07:42 chambreparent kernel: Bulk In Failed. Status=-71, BIIdx=0x3, BIRIdx=0x3, actual_length= 0x0

A bit of digging shows that the “Bulk In Failed” message is produced by code in the Mediatek/Ralnk wifi driver, specifically rt_usb.c. I think it’s quite possible that DD-WRT is either a bit buggy and/or is sending a combination of values that the driver isn’t handling very well.

I think that the pragmatic solution to your problem is therefore to stick with wirelessmode=14 and by trial and error find if there are any more 20 MHz channels that work. Then repeat the process for 40 MHz and 80 MHz channels.

As for the borrowed TP-Link router also failing, that was using either channel 48, which is 80 MHz wide, channel 46, which is 40 MHz or channel 42, which is 20 MHz. Just from reading the log, it’s difficult to tell how the router was configured, since I don’t have a dongle to experiment with:

Sep 25 15:35:47 chambreparent kernel: ==>rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=48)
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): HT-CtrlChannel=48, CentralChannel=>46
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): VHT-&gt;center_freq_1=42, CentralChannel=>42, vht_
Sep 25 15:35:47 chambreparent kernel: PeerBeaconAtJoinAction(): Set CentralChannel=42
Sep 25 15:35:47 chambreparent kernel: AdjustChannelRelatedValue(): Input BW=2, rf_channel=42, vht_bw=1, Channel