Received OSMC wifi-ac adapter - ISSUES


#129

https://paste.osmc.tv/tiyeferiwa this log including network wifi AC tentative
I disconnected the dongle so I can upload le the logs

massive : [ 470.761594] receive cmd msg fail(-71)


#130

what’s the output from

connmanctl services
connmanctl technologies

and

connmanctl services <wifi-service-name>

where <wifi-service-name> is taken from the output of first command.


#131

*AO Wired ethernet_b827eb4ab194_cable
*A dd-wrt-5-B wifi_000000000000_64642d7772742d352d42_managed_psk
dd-wrt-5-A wifi_000000000000_64642d7772742d352d41_managed_psk

/net/connman/technology/wifi
Name = WiFi
Type = wifi
Powered = True
Connected = False
Tethering = False
/net/connman/technology/bluetooth
Name = Bluetooth
Type = bluetooth
Powered = False
Connected = False
Tethering = False
/net/connman/technology/ethernet
Name = Wired
Type = ethernet
Powered = True
Connected = True
Tethering = False

Type = wifi
Security = [ psk ]
State = idle
Strength = 50
Favorite = True
Immutable = False
AutoConnect = True
Name = dd-wrt-5-B
Ethernet = [ Method=auto, Interface=wlan0, Address=00:00:00:00:00:00, MTU=1500 ]
IPv4 = [ ]
IPv4.Configuration = [ Method=dhcp ]
IPv6 = [ ]
IPv6.Configuration = [ Method=off ]
Nameservers = [ ]
Nameservers.Configuration = [ ]
Timeservers = [ ]
Timeservers.Configuration = [ ]
Domains = [ ]
Domains.Configuration = [ ]
Proxy = [ ]
Proxy.Configuration = [ ]
mDNS = False
mDNS.Configuration = False
Provider = [ ]


#132

Let’s try this with the dongle plugged in. (SSH via cable and copy/paste all screen output).

connmanctl
config wifi_000000000000_64642d7772742d352d42_managed_psk --remove
scan wifi
agent on
services
connect wifi_000000000000_64642d7772742d352d42_managed_psk

enter passphrase if prompted, then quit and run ifconfig. (I’m assuming the service name is unchanged.)


#133

Passphrase? what’s? sorry I guess it’s a dumb question. You mean my ddwrt password?


#134

Yes, the wifi password.


#135

connmanctl
connmanctl> config wifi_000000000000_64642d7772742d352d42_managed_psk --remove
connmanctl> scan wifi
Scan completed for wifi
connmanctl> agent on
Agent registered
connmanctl> services
*AO Wired ethernet_b827eb4ab194_cable
dd-wrt-5-B wifi_000000000000_64642d7772742d352d42_managed_psk
dd-wrt-5-A wifi_000000000000_64642d7772742d352d41_managed_psk
connmanctl> connect wifi_000000000000_64642d7772742d352d42_managed_psk
Agent RequestInput wifi_000000000000_64642d7772742d352d42_managed_psk
Passphrase = [ Type=psk, Requirement=mandatory ]
Passphrase? MY_WIFI_PASSWORD???
Agent ReportError wifi_000000000000_64642d7772742d352d42_managed_psk
connect-failed
Agent request cancelled by ConnMan
Error /net/connman/service/wifi_000000000000_64642d7772742d352d42_managed_psk: Operation aborted


#136

Can you post the log showing what happened during these commands?


#137

https://paste.osmc.tv/hucazanoge


#138

ANother question to @sam_nazarko. Whats is the little button of the dongle on the side noted “wps”?


#139

It’s for automatically connecting. Unfortunately security vulnerabilities were discovered in WPS, so we don’t recommend using it.


#140

You wrote back on 27 May:

So I assume you have 4 OSMC dongles, 4 Pi3s and 4 official 2.5A RPi power supplies.

Just to eliminate the possibility of it being a hardware issue, could you:

  1. During future tests, ensure that the dongle is plugged directly into a Pi3.
  2. Swap power supplies and try to connect.
  3. Move the micro-SD card to a different Pi and try to connect
  4. Try a different WiFi Dongle (although it looks like you’ve already tried that).

Please also run paste-log /lib/firmware/mt7610u_sta.dat and post the URL.


#143

https://paste.osmc.tv/cabeyafewo

I tested individually each hardware power supply, hub, raspberry, dongle wifi (ok on windows 7 and 10), everything is working


#144

Looking back over this thread, I see that you were using channel 36 and a channel width of 80 MHz on the router. Channel 36 only supports 20 MHz, so try that combination.


#145

ddwrt 20mhz and channel 36 AC only mode, same problem
Status: No internet


#146

Channel 36 / 80 MHz was clearly incorrect, so at least that’s one thing we’ve corrected. But without new logs, I have nothing to go on.

1 Please run the following:

sudo rm -rf /var/lib/connman/wifi*
connmanctl
scan wifi
agent on
services
connect wifi_000000000000_64642d7772742d352d42_managed_psk

then enter your passphrase when prompted. If it fails to connect, post logs.

2 Move the Pi to a location close to the primary router and run the following (basically a repeat of 1):

sudo rm -rf /var/lib/connman/wifi*
connmanctl
scan wifi
agent on
services
connect wifi_000000000000__xxxxxxxxx_managed_psk

where xxxxxxxxx is the code for the primary router. Enter passphrase when prompted then post logs.

3 As requested on 29 August, please say what channel / channel width you use to connect between the repeater and the primary router.


#147

1/
https://paste.osmc.tv/etocohocuk (/lib/firmware/mt7610u_sta.dat)
https://paste.osmc.tv/yeculadeju
I removed the dongle to upload via ethernet
ddwrt AC-mode only channel width 80mhz & channel 64 (listed as conform in norm)

2/
https://paste.osmc.tv/azaqijopiz (/lib/firmware/mt7610u_sta.dat)
https://paste.osmc.tv/ehepibaduq
well connected on primary router (wifi N) and can upload logs via wifi

3/ wireless mode “repeater bridge”
wireless network mode “NG-mixed”
but I don’t set channel width / channel, I guess it’s automatic settings, just set the primary router passphrase

Hope enough logs

Thanks again to everybody for supports.


#148

I think we’re making progress.

First, I see you set the AC channel on the router and on the dongle to be channel 64. I did a bit of reading up on DD-WRT and, though channel 64 is only 20 MHz wide, DD-WRT will find the nearest 80 MHz channel if you specify 80 MHz channel width. Thus in the log we see this:

Sep 15 15:19:18 chambreparent wpa_supplicant[378]: wlan0: Trying to associate with e8:fc:af:fe:a9:d0 (SSID='dd-wrt-5-B' freq=5320 MHz) 
...
Sep 15 15:19:18 chambreparent kernel: ==>rt_ioctl_siwfreq::SIOCSIWFREQ(Channel=64) 
Sep 15 15:19:18 chambreparent kernel: PeerBeaconAtJoinAction(): HT-CtrlChannel=64, CentralChannel=>;62 
Sep 15 15:19:18 chambreparent kernel: PeerBeaconAtJoinAction(): VHT->center_freq_1=58, CentralChannel=>58, vht_cent_ch=58 
Sep 15 15:19:18 chambreparent kernel: PeerBeaconAtJoinAction(): Set CentralChannel=58 
Sep 15 15:19:18 chambreparent kernel: AdjustChannelRelatedValue(): Input BW=2, rf_channel=58, vht_bw=1, Channel=64, vht_cent_ch=58!`

The dongle is looking for a connection on channel 64 (5320 MHz) but the router has its central channel set to 58. Therefore I think it would be better if you left the channel to its default value on the dongle and then let it scan for available channels on the router. For now, I would also suggest you stick with a 20 MHz channel width. You can try to increase it once we have a working connection

Having successfully negotiated a connection with the router, it needs another 9 seconds for DHCP to allocate an IP address, 192.168.1.23, which is very slow:

Sep 15 15:19:28 chambreparent connmand[238]: wlan0 {add} address 192.168.1.23/24 label wlan0 family 2 
Sep 15 15:19:28 chambreparent connmand[238]: wlan0 {add} route 192.168.1.0 gw 0.0.0.0 scope 253 <LINK> 
Sep 15 15:19:28 chambreparent connmand[238]: wlan0 {add} route 192.168.1.1 gw 0.0.0.0 scope 253 <LINK>

Unfortunately, the dongle then disconnects from USB.

Sep 15 15:22:59 chambreparent kernel: usb 1-1.3: USB disconnect, device number 5

It was suggested in a previous post that adding the line

BackgroundScanning = false 

to /etc/connman.conf (and rebooting) can sometimes help. Since I think you performed a full reinstall, please make sure you added this line to the new system.

Second, I see that you had no problems connecting to the primary router on 2.4 GHz, channel 6. You will also see that in the configuration file you left the Channel=0 and it still connected successfully.

Third, just to clarify one point, the transmission speed to/from the internet and any device connected to the primary router will run at the speed of the “N/G-mixed” link.


#149

According to this link https://wiki.dd-wrt.com/wiki/index.php/Basic_Wireless_Settings#Channel_Width
VHT80, channel 64 should be ok
I will have a try with channel 58 so and another try with 0 for auto scan

I will add BackgroundScanning = false too


#150

According to that link VT80 should be ok wilth 64+LL.

The link also says that VT80 should be ok with 36+UU, whereas you were using 36+LL (lower lower) on the screenshot, though in a later log it looks like you changed it to 36+UU without telling us.

However, to keep things simple, please use only a 20 MHz channel width for now. And also plug the dongle directly to the Pi.