Received OSMC wifi-ac adapter - ISSUES


#84

Hi,

Whats speeds are you getting when its setup up like this?

Do you get the same issue, if you disconnect the wired network?

I would try a different a wifi channel, it may also be worth seeing changing the extension channel setting helps.

Thanks Tom.


#88

hello,

I get same speed, no improvement in comparaison of N-mixed mode but on ddwrt I see the dongle connected in VHT80 rather than VHT40

yes same error with or without ethernet

after reboot ddwrt the dongle got dhcp IP address right however osmc interface still note “Status: no internet”

reboot raspberry… got dhcp and status connected this time but not stable, many connection error and lost connection when try to access my SMB server


#89

Hi,

Is this with or without mt7610u_sta?

Thanks Tom.


#90

With


#91

new reboot but now “status: no internet” …


#92

Hi,

Now you’ve established a connection with wireless 14 mode and dhcp, please try automode again?

Thanks Tom.


#93

Back on AC/N mixed mode and performed :
sudo cp /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mt7610u_sta.dat
connection speed 150M in VHT40, my guess is that key is working only on N mode which seems max rate 150M


#94

Hi,

How far away is the pi from the router, AC only mode tends to only be stable over shorter distances.

Thanks Tom


#95

signal strenght indicates 70%
I perform test in same room than my pc windows using same dongle and I get around 250M with it in VHT80
with my dell laptop I get 350/400m in VHT160

So all speed rates seems to be logic in comparaison of their bands

This guy seems to got 433M with the same chipset :

Dont know if it’s osmc issue, driver issue, config issue but I’m pretty sure it doesn’t work in AC mode but in N mode. and I tweak the mt7610u_sta file I can’t get connection

My 50 cents XD


#96

hi @Tom_Doyle,

Today I tried again auto config and just tweaked the file with CountryCode=FR and WirelessMode=14 and AC/N mixed mode on router and regularity country “off”.
I got a connection in VHT80 and 200M speed rate displayed on the router.

Seems on the good way however, I’m facing now a video or streaming issue. Video are very slow and drops.


#97

Hi,

Could you please provide debug-logs showing this issue, details can be found here:

https://osmc.tv/wiki/general/how-to-submit-a-useful-support-request/

Thanks Tom.


#98

Have you checked the “real” speed with iperf3?


#99

Hello everyone,

thx for replies, but after reboot I got a regression again with status : no internet
Will try to test more about it today


#100

I’m not the only one with this issue :


#101

i can’t ping 8.8.8.8, neither 192.168.1.1

Etc/résolv.conf
Nameserver 192.168.1.1

Blue led is on and blinking. I can see this client in ddwrt wireless status

I tried with open and crypted WiFi network both same result so it’s not auth issue.

Stuck on status no internet

Testing in AC/N mode on ddwrt and wireless mode 14 on osmc

I switched From vht160 to vht80 and got speed improvement. I get 250mbps on ddwrt wireless status for the osmc WiFi dongle. Got improvements on windows and iPhone too.


#102

You mean Kodi reports “no internet” or you don’t have Internet access from OSMC?


#103

On osmc wireless settings page, it’s reported status no internet.
And I can’t use internet in kodi (youtube by example) neither to access my Samba server

Wireless can’t connected


#104

Well the “internet Status” report depends on certain parts and might not be that reliable.
But your ifconfig showed that you got an IP address and data was transferred.
Did you tried DNS resolving?


#105


#106

192.168.1.2 is ddwrt router failed
192.168.1.1 is internet box router failed