Received OSMC wifi-ac adapter - ISSUES


The whole issue is really strange. Did you actually tried the Wifi Stick maybe on your PC to exclude it is a Software issue?


The stick is working well on my pro laptop Win10 on 5ghz


Can you SSH to the router?


no I cant


Well, try the other two ping tests.


test ping from laptop win10 wireless, ping failed
same when laptop is wired on router


On the Pi run: sudo tcpdump -n "icmp" -i wlan0

Then run ping -c3 from another machine.

We’ll then see if the pings are being received on the Pi.


I have issue uploading photo right now but yes I can see the raspberry receiving packets.
try to upload photo later


You probably see something like this (with different IP addresses):

18:17:04.641798 IP > ICMP echo request, id 9059, seq 1, length 64
18:17:04.641894 IP > ICMP echo reply, id 9059, seq 1, length 64

a request and a reply. It looks very much like the reply traffic is being blocked either at the WiFi stick or (more likely) at the router.

You need to check all firewall settings on the router and anywhere else that might be blocking traffic from IP address

One other thing. Try a different IP address on the Pi.


Yes it looks like this.
Firewall is off on router and static IP address with right mac address is set


Did you try a different IP address?


Yes same result than previous IP


Then I’m out of ideas, I’m afraid. The best I can suggest is that you go through all the router settings and see if anything looks like it might be blocking some of the traffic.


Maybe try a fresh install of OSMC on a second SD Card to exclude any possible misconfiguration.


Windows computers using same stick on 5ghz have no issue . I will be surprised if due to router config. (In addition I had same issue testing with another router). I will continue my investigations



A Windows computer would have been given a different IP address, but we’ve now eliminated that possibility.

Other than installing a fresh copy of OSMC, as recommended by @fzinken, together with a reboot of the router, I can’t think of a way forward.


ok thanks but I m already using a fresh dedicated install to test wifi


I guess I will try another dongle, any model to recommend me?



If its a fresh install you need to do this again:

sudo cp /lib/firmware/mt7610u_sta.template.dat /lib/firmware/mt7610u_sta.dat

and reboot, it should then establish a connection. Removing mt7610u_sta.dat and rebooting should get the auto-confgiration to then work.



@Tom_Doyle, auto-configuration doesn’t work neither.
arping validated the connection but tcp/ip configuration is not effective on 5GHZ and ping not working.