Randomly blue/green tinted picture


#41

sorry @sam_nazarko. Now it said failed to start /etc/rc.local Compatibility at boot,. Something I’ve must overlooked. Geri


#42

rc.local should look like this:

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb

exit 0

#43

@sam_nazarko. Success. There is a quite a bit of flickering during boot, no error message. Hope your details explained above help others too to resolve. Now testing and report if issue. Thanks a lot.


#44

@sam_nazarko
Partial success only. Screen does not tint anymore on my 9704h Philips. BUT CEC stops randomly, like instantly after boot or after 5-10 minutes. I can still remote it by the KORE app, so Vero is working. A bit helpless what to do. RPi3 works flawlessly, but I really wanted this upgrade:((((. Vero CEC worked well before the rc.local fix was applied.


Problems with HDMI CEC w/ Philips TV
#45

I don’t see any reason why CEC would be affected by this. Have there been any changes to your environment? Such as new devices being attached?

Please try powering all devices off at the mains for ten minutes. That usually fixes CEC issues. If you continue to get problems, please start a new forum post with some logs


#46

Hi there.
@sam_nazarko Thx for all the effort you put into this! You try to help with every problem. With so many users, well done!

I have the same blue/green screen problem with my Sony Bravia LCD TV 50 hz (2009). In this thread they only speak of Philips TV’s. I’ve tried to edit the rc.local file throug SSH but always permission denied (in root + sudo). I tried to change permissions with ‘sudo chmod’ but denied as well.
A few days ago I updated my vero 4k. The option ‘force rgb output’ was added. I turned it on and did reboot. Now the problem happens less often but it’s still there.

I know it’s time for a new tv but that will be for later. Is there anything else you can do?

Thx in advance!


#47

The force RGB option doesn’t seem to work properly yet so it still needs to be set via rc.local until the next update is released

Sam


#48

Ok. Thx Sam!


#49

I think i have this problem too… However it only appears for a split second and i can’t reproduce it accurately…

I’m running the latest ISMC release on the VERO 4K and my TV is a Samsung UE55MU6400


#50

Ive got this issue on a Vero 4K+

The whole screen goes green and only ever green. Its never occured on any other system. Im playing back H265 UHD videos on a hisense 75" panel.

Any thoughts as to why this occurs? A reboot fixes it.


#51

Does it occur during playback?
Does stopping the video help restore the screen?

Can you post a debug log when this happens?

Thanks

Sam


#52

Hi Sam yes it does. Stopping the video does not fix it. Only rebooting. Sure ill do that next time it occurs.


#53

Doesn’t sound like the same issue… Mine was down to the TV and a firmware fault with it (Samsung UE55MU6400)

Ended up returning it under the sales of goods act and getting an LG… No more problems then.