Randomly blue/green tinted picture


#21

Hi, I’m having this exact same issue, with an older Philips TV (not sure of the year, but 2009 wouldn’t be surprising).

Is there likely to be a fix available for this before christmas?

If not, would that older march version of osmc likely work, as suggested above, and how would I downgrade to that version, and what would I be losing by using an older version like that?

Thanks.


#22

We are working on some significant improvements, but I can’t guarantee it would be fixed by Christmas.

For legacy displays, you won’t lose much by using an older version of OSMC at this time. It can be downloaded from osmc.tv/download. See https://osmc.tv/wiki/vero-4k/reinstalling-osmc/

Sam


#23

Hi

I believe this issue is now resolved and this will be included in the next update. It may indeed make it in just before Christmas.

I’ll add a Kodi option for this shortly so that editing via the command line is not necessary and let you know when this is ready for testing.

Sam


#24

Good news! Hopefully this will make it in just before Christmas.


#25

Indeed! Thanks for your patience

Sam


#26

Hi, I’m suffering from the same problem:

Yesterday, I received my Vero 4k and immediately noticed the green tinted screen when setting up the device for the first time, exactly looking the same as in the pictures posted by Vaettur. I’m also experiencing green tinted screen when scrolling through the menus and when watching videos, irrespective of the video codec and source.

The Vero 4K is intended to replace my Raspberry Pi2 running on the current version of LibreElec (LibreELEC-RPi2.arm-8.2.1.). I have never experienced any green tinted screens on my Raspberry Pi2/LibreElec device.

The Vero 4K is connected to my Philips 32PFL9604H / 12 TV set. In order to eliminate the problem I also tried the HDMI cable previously used with Raspberry Pi and also different HDMI sockets at the TV set without any luck.

I also followed the steps in previous posts (“echo ‘rgb,8bit’ | sudo tee /sys/class/amhdmitx/amhdmitx0/attr” and extending “/etc/apt/sources.list”) without any luck.

Are there any news on when expect the issue to be fixed? I’m fearing to explain to my wife why I bought a new device when the existing device (the Raspberry) was working.

Best, Markus


Problems with HDMI CEC w/ Philips TV
#27

This issue has already been solved. It will be in the update included on Sunday 7th January.

You can update in advance, but it may be best to wait if you’re not familiar with the command line.

You’ll need to add echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb to /etc/rc.local. In the future, we’ll make a GUI option available.

Sam


Problems with HDMI CEC w/ Philips TV
#28

Thanks Sam. I added the line and it appears to work (so far).

b.t.w. where in the menu / settings are you going to place the GUI option?

Best, M


#29

It won’t work persistently just yet, but will after Sunday’s update.

Probably under System -> Display.


#30

Thanks Sam.

b.t.w. I really like the Vero 4K and OSMC. Very chic, stylish design and tremendously faster than my old Raspberry Pi2 with LibreElec. Nice work!

It was also quite easy to migrate all my userdate and add-ons from the old to the new device. I simply used the original Kodi backup add-on and a NAS to do the job (in case someone is interested).

Best, Markus


#31

Cheers – I hope you also enjoy OSMC as well. It is a little more open

Sam


#32

Hi Sam, you mentioned a Sunday’s update:

I tried to update my Vero 4k but received the message that no updates are available.

Best, Markus


#33

As a new bug was discovered the Update was not released on Sunday. Be patient for a while or upgrade following the instructions from the Testing Stretch thread


#34

I’ve updated to the Stretch testing build a few days ago and I can confirm the fix works. Watched a lot of TV the past week and no blue/green tinted video any longer.

Thanks @sam_nazarko and the rest of the OSMC team for supporting our “ancient” television sets. With Kodi 18 coming in the near future, which hopefully makes Netflix access a possibility, the Vero will be an even more powerful device than it already is!


#35

Hi! I have a Vero4K and a 52PFL9704H/12. After upgrade and clean re-install of the December update I still have the problem. Any switch available in the GUI as I remember @sam_nazarko mentioning in earlier post a plan to implement one. Thanks guys!


#36

Did you add the option to rc.local? This will fix it for now

Sam


#37

No I did not. Pls. just reconfirm we talk about :
add echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb to /etc/rc.local

just checked quickly… there is no rc.local file in the the /etc directory. Is that normal?


#38

Make sure you are editing as root (sudo -s) before running anything.

Sam


#39

Hi Sam! Double checked. Vero4K is fresh installed and no rc.local file present in /etc directory.
Before the update I tried this method, but I got permission denied ( assume it was because missing sudo -s command at the start.


#40

You can create one and chmod +x it. Make sure it exits 0 at the end.

Sam