Problems with LiveTV stuttering on Vero 4k+


#123

You need to reboot twice to clear the current and previous logs. They are likely too large to paste.


#124

Thanks @ActionA that worked!

@sam_nazarko the logs are available here:

Https://paste.osmc.tv/ibucosagox

I booted up and as soon as the pvr manager had loaded the guide I selected CBBC HD and you should see something around 15:25 and then several occurrence at 15:26

Thanks

Karl


#125

CAMLCodec::OpenDecoder we have no fps hints so we will create a fallback

The backend is not giving FPS hints.
Try setting a fallback under DVBLink settings


#126

Thanks @sam_nazarko, I’ve set that on the Vero and it seems to have solved the issue, I’ll keep an eye on it for a few days and report back.

Oddly that’s not set on any of my intel nucs and there running fine… :thinking:

Thanks again!


#127

IIRC; I was adding a fallback frame rate, but it’s a complete guess and may have been causing issues if it was incorrect.

Sam


#128

Hi @sam_nazarko I’m sorry to say I’m still experiencing the issue although it doesn’t seem to be as frequent now, I can go for quite a while with no stuttering then all of a sudden it stutters every 10 seconds. i’ll try and get some more logs tonight once the kids are in bed. Not sure if it’s relevant but CBBC HD seems to be the worst affected channel. Anything else I can try/test?

Thanks

Karl


#129

To add to this i’ve been monitoring the resources on my NAS (QNAP TVS-473) which is where DVBLink is installed to see if there was anything out of the ordinary going on but I’m seeing on average between 6-10% cpu usage, 5gb ram usage out of 16gb and 0% swap file usage. Network which consists of 4x1GB connections loadbalanced is barely using 10MB/s. Can’t think of anything else to check on the NAS but it doesn’t seem to be struggling for resources


#130

A new log when this happens would be handy

Sam


#131

Sorry @sam_nazarko but im still having problems with some 1080i livetv streams and recordings having picture drag on the Leia dev builds. Last night I watched a recording of Dr Who from bbc1 hd (recorded from freeview) and playback was perfect. Tonight, without changing any picture settings or kodi settings i watched a coronation street recording from ITV HD on freesat and the picture kept dragging every couple of minutes.

I did not have this problem on krypton, but did have the stuttering which we worked on earlier in this thread. The same recording works fine on my old htpc running krypton. I also still see picture drag on livetv 1080i streams.

Any other parameters WRT de-interlacing i can look at? Feels like things arent working as they should in this area with the gmc leia dev builds.

It doesnt look like there are any de-interlacing options that can be selected via the kodi interface.


#132

Does it look like ghosting?

If so, I think @gmc needs to sync a couple of my v17 patches. But I plan to drop the last v17 release this week / early next week and focus on a v18 release over Christmas with a final release in early January.

I’ll have a look over what he’s currently using in his builds. If you’re able to stay on top of updates from GMC’s repo over the next few days and keep me posted, that’ll be great.

Sam


#133

I wouldnt describe it as ghosting, but more as motion judder.

Yes no problems. Will continue to monitor for updates and keep you posted.


#134

Hi @sam_nazarko sorry for the delay, I’ve managed to grab a new log:

https://paste.osmc.tv/acekahidek

It stuttered around 8:52

Thanks

Karl


#135

Hi @sam_nazarko did you manage to take a look at the log? did it show anything?

Many thanks

Karl


#136

Sorry – I missed this because the original thread was opened by a different user.
There are Live TV improvements in Kodi v18 which will be released soon. We only plan one further update for Kodi Krypton.

Sam


#137

@jahutchi

There’s a fix for Gigabit Ethernet on Vero 4K + where an issue was caused by using the wrong IRQ type. This should fix a number of issues including EEE.

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.

It would be good if you could check if you still experience occasional packet drops after this change.

Cheers

Sam


#138

Hard to judge the effectiveness of this change. I’ve been running for 24hrs with the new kernel and certainly havent noticed any ill effects.

I just took a look at the drop counts in ifconfig and i see 3 rx drops in past 24hrs.

eth0: flags=-28605<UP,BROADCAST,RUNNING,MULTICAST,DYNAMIC>  mtu 1500
        inet 192.168.0.147  netmask 255.255.255.0  broadcast 192.168.0.255
        ether c4:4e:ac:28:57:a4  txqueuelen 1000  (Ethernet)
        RX packets 13457788  bytes 19558757361 (18.2 GiB)
        RX errors 0  dropped 3  overruns 0  frame 0
        TX packets 1568315  bytes 104366405 (99.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 40

I’m still experiencing playback smoothness issues for hd livetv/recordings content however (as reported above) but i’m guessing you were expecting that. I’ll continue to upgrade to the leia gmc builds and test.


#139

Back to my original issue…

On the latest Leia Test build and kernel from staging I still have the picture drag when watching 1080i LiveTV or TV Recordings through TVHeadend.

This morning, I took the raw .ts file from one of the recordings and tried playing it over a samba share and still had the picture drag.

I even tried copying the raw .ts file to the Vero4K+, and played it back from the local storage - still the same picture drag.

This same file plays back without any picture drag on my 10yr old HTPC running krypton 17.6


#140

Hi @sam_nazarko I applied the fix above for the Ethernet IRQ issue and that seems to have fixed the issue I was having with live TV stuttering :smiley:

I haven’t noticed any other issues since applying the fix

Many thanks

Karl


#141

Thanks for confirming.

Sam


#142

Hi @sam_nazarko

For my remaining “motion drag” issues with live tv and recordings on Leia…

I think I was too quick to rule this out:

I’ve done more testing and am happy to confirm this resolves my problems. I have a couple of particularly problematic recordings which I kept, and have also been watching a fair amount of live tv, and in all cases the picture was nice and smooth. So I’ve now added this to my rc.local.

Will disabling de-interlacing cause any un-intended side effects elsewhere?

Presumably there is still some kind of de-interlacing going on? Because I know that on my HTPC, if I disable de-interlacing in the kodi settings then the picture drags like mental… hence why I’m surprised this workaround actually works.