Playback of recorded TV hangs on seek step backward


#23

It’s the default. From your log:

<usemmal default="true">true</usemmal>
...
<useomxplayer default="true">false</useomxplayer>

You can change it under Settings > Player Settings


#24

Hi again,

I went to Settings > Player and selected "Allow hardware acceleration with OMXPlayer. That worked well for playing recorded programs – no more hanging with seek step backward, but it wouldn’t play Live TV. That seems to be a very common problem with OMXPlayer and there don’t appear to be any easy fixes for it. At least I haven’t found one.

While I look for a fix for Live TV, I switched back to “Allow hardware acceleration with MMAL” and, for some reason, I’m not getting stalling/buffering with playback of recorded TV now. I also deseclected “Allow hardware acceleration” for both. With that setting, I could see Live TV and seek step back without stalling. Probably just a coincidence and it will come back, we’ll see.

Thanks again for hanging in there with me.


#25

If you haven’t tried already, you could also try with both MMAL and OMX enabled.


#26

I hadn’t tried that. When I did, I could see live TV but I had buffering/stalling on seek step back. So, I tried all possible combinations and, for me deselecting both gives the best seek step back performance and I can see live TV although there might be a slight audio/video sync issue.

Not sure why deselecting both makes sense, but I’ll leave it that way for awhile and see what happens.


#27

They allow video hardware acceleration. Deselecting both will probably run everything on the CPU. You can check using top if you’re thrashing the CPU.